PDA

View Full Version : Screen flickers when I am in terminal or emails..etc?



NewShockerGuy
1st November 2007, 05:21 PM
I am running Fedora 7. This is my first time running linux... I am a windows user all my life. But I figured I might as well learn it since my new job deals heavily in linux.

Needless to say here is my problem. I am currently running an ATI Radeon 9200 pro for dual monitor capabitlity, with two dell E197Fpf flat panel monitors. I never had this problem before when we installed fedora 7 about 3 weeks ago.

When I am in terminal and I hit the backspace key the screen will flicker black. It's ONLY when there is not a charater to erase... IE:

[nnee@mundo Desktop]$ <--- If I hit the back space now the screen would flicker black.

[nnee@mundo Desktop]$ ls <--- If I wanted to delete the ls then it would but if I went more than the two charatcers it would flicker.

I also get this with thunderbird for email. Once I receive a new email from work I get the nice little pop up screen at the bottom of the screen letting me know what type of email contents it is..etc But once that happens the screen flickers really quick.

We have updated to the newest kernal I have all of the newest updates..etc

I tried going on ATI to get a new driver but they are telling me that:
Detected version of X does not have a matching 'x130' directory
You may override the detected version using the following syntax:
X_VERSION=<xdir> ./ati-driver-installer-<ver>-<arch>.run [--install]

Which I don't even know what that means?!

But I will say I do like Fedora. I think there are things that need to be improved especially for someone that doesn't know linux and things should not be so difficult to install... IE: IF I want to install a driver give me a GUI so I don't have to do everything in a terminal.. But that's a learning curve I guess..


Also on a side note when I put my screen to spanning via System -> Display -> I will pick the dell monitor from the options and it says it writes it to a file and that I have to restart. I do which I hold down CTRL + ALT + BACKSPACE as i have read that this is much faster than restarting and when it comes back up I look at the monitor type and it didn't save the changes... Could this be what is causing the flickering? Why would it not save the changes of the monitors?

Sorry for all the questions but i have searched for the past two days trying to find answers with no luck what so ever...

-Nigel

PabloTwo
1st November 2007, 06:15 PM
Hi-

I can't help you with the first part of your problem (flickering screen) as I don't use ATI video cards and/or a dual monitor setup. But, halting and restarting the your X session with CTRL-ALT-BACKSPACE forces an immediate shut down of the X server, without doing any tidying up after itself, such as saving current changes. To do a proper shutdown and restart of X, it's easiest to just log out of the session, then log back in, and only takes a moment or two.

Paul

NewShockerGuy
1st November 2007, 09:29 PM
This is what I currently have but it still appears to be flickering when I hit the back space in terminal.

-------------------------------------------------------------------------
Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Dell E197FP"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 76.0
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Dell E197FP"
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 76.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
EndSection

Section "Device"
Section "Device"
Identifier "Videocard1"
Driver "radeon"
VendorName "Videocard Vendor"
BoardName "ATI Technologies Inc RV280 [Radeon 9200 PRO]"
BusID "PCI:4:2:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
-----------------------------------------------------

This is the dell web page of the monitors that I have.

http://support.dell.com/support/edocs/monitors/E197FP/En/about.htm

Still getting the screen flickering..

-Nigel

RJFUatHOME
1st November 2007, 10:43 PM
You could try changing your monitors to the Generic LCD Display setting and playing with refresh rates so see if anything helps. It seems odd that a keystroke under those circumstances would cause an issue such as that, but who knows.

You could always switch it back if it doesn't help. Look at System > Administration > Display and change the monitor type on the hardware tab. Generic LCD Display is all the way at the top of the listing.

NewShockerGuy
2nd November 2007, 05:52 AM
Yeppers I tried that with the generic monitors...
Still a no go... actually the weird part is once I would set it to DELL monitors after a restart I would go and check what it stated under monitors and it would say "generic lcd"

very weird...


-Nigel

Wayne
2nd November 2007, 05:59 AM
But I will say I do like Fedora. I think there are things that need to be improved especially for someone that doesn't know linux and things should not be so difficult to install... IE: IF I want to install a driver give me a GUI so I don't have to do everything in a terminal.. But that's a learning curve I guess..

There's nothing that can be done in a GUI that can't be done faster in a Terminal :p

In the end, I would guess it all boils down to the crappy ATI drivers :(

Where did you install them from, ATI or the Livna RPM? Maybe Leigh can jump in to help when he logs in...

The latest kernel has its own problems too :mad:

Wayne

leigh123linux
2nd November 2007, 06:05 AM
Your ATI Radeon 9200 pro is unsupported by the fglrx driver (ATI) in F7 because your card requires version 8.28 or less to work , this driver is far to old to build for the xorg & kernel version so you are stuck with the open source radeon driver.

RJFUatHOME
2nd November 2007, 05:55 PM
Yeppers I tried that with the generic monitors...
Still a no go... actually the weird part is once I would set it to DELL monitors after a restart I would go and check what it stated under monitors and it would say "generic lcd"

very weird...


-Nigel

________________

You'll have to manually edit your xorg.conf back to how the monitors sections listed the Dell monitor brand. For some reason once you switch to generic CRT or LCD it seems to want to stay that way! I thought that was only my machine, but I guess it's a "generic" bug, pardon the pun.

Just copy and paste the lines from the xorg.conf file that you listed earlier in this thread.