View Full Version : urgent help needed - running app.s for csh -fedora c.6

1st November 2007, 01:46 PM
I have to use a scientific interpretation program for linux but i am pretty new to linux.It's for my master thesis and my deadline is coming closer every second.
Anyway my prob. is:
The program needs c shell scripts and i used "exec csh" command and activated cshells than run the application, worked fine
after app. finished the job, i tried to run the application for a second time, application did not run and only runs when I log out and after that, log in again and then changed shells to csh, and after all the application runs again. Otherwise it just could not run.For eachtime logout, login, change to csh and run the app.
I need to run the same application at the same time in at least 5 terminal windows. But it runs only in one window. When i run it in one window it's over, needs to relogin to run but when i log out all processes are killed, making it impossible for me to run it in multiple windows.

Any help would be great.

1st November 2007, 02:09 PM
sounds like a memory-leak to me but i'm not that far into programming yet

another option might be to run it a protected environment? so that it can't modify to many files?

2nd November 2007, 07:19 PM
It is not seems to be memory-leak problem, i run the same application in 8 terminal windows at the same time on a different computer, (has less than half memory and cpu power compared to mine) on which the application installed by someone else previously.

only difference that i could find between them is the other one is starts with csh as default.
perhaps the problem is occurring due to that somehow.
how can i change my computer's settings to start with csh default.


2nd November 2007, 10:37 PM
well i don't know about the default settings of csh and stuff

but another possibility might be that the other computer has some extra settings or compilers or codestuff so it can process your codes anyway (it's late where i live and i'm tired as hell... can't even come up with the names anymmore :p:p:p)

nighty night :eek:

3rd November 2007, 11:55 AM
İ don't know, but still looking for a way. I couldn't reach who installed the program on that computer.
Thaks for your answer (good sleep is important)

3rd November 2007, 01:32 PM
awake again now :p

the point i tried to make is that in Fedora there are several compilers and they have a LOT of different versions, it's quite common to have to install the latest version in order to install the latest software in order for it to compile it

i think the same thing needs to happen to you to, have you tried a "yum update all"? it will take a long time but might help you out ;)