PDA

View Full Version : Compiz Failing With No errors?



bradlongo
31st October 2007, 10:45 PM
I am running Fedora 7 with kernel 2.6.23.1-10.fc7.i686. I have no errors from x when i try to start compiz, but I get the message desktop effects could not be enabled. After that my window borders dissapear and I can't click on anything. Beryl however works just fine. I am using kmod-fglrx-8.42.3-4.2.6.23.1_10.fc7 and my xorg.conf is here....

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "Module"
Load "glx"
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
EndSection

Section "Files"

#ModulePath "/usr/lib/xorg/modules/"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


Anyone have any ideas on what's going on? I would like to get compiz to work so I can try compiz-fusion.

Gnafu the Great
31st October 2007, 11:00 PM
The Compiz included in the official F7 repos is an older version and not nearly as good as Beryl. To get Compiz-Fusion, you'll want to look for a thread regarding a Compiz-Fusion repo for F7 (kagesenshi repo). That repo currently has version 0.5.2 of Compiz-Fusion, which is okay. If you read through that thread, you should find F8 SRC RPMs for 0.6.2 that can be rebuilt in F7 (after installing some dependencies from the development repo). All the info is in that thread.

leigh123linux
31st October 2007, 11:04 PM
The Compiz included in the official F7 repos is an older version and not nearly as good as Beryl. To get Compiz-Fusion, you'll want to look for a thread regarding a Compiz-Fusion repo for F7 (kagesenshi repo). That repo currently has version 0.5.2 of Compiz-Fusion, which is okay. If you read through that thread, you should find F8 SRC RPMs for 0.6.2 that can be rebuilt in F7 (after installing some dependencies from the development repo). All the info is in that thread.

If he looks in that thread he will find 0.6.2 already compiled for F7 i386 that I made

http://forums.fedoraforum.org/forum/showpost.php?p=885805&postcount=440

http://forums.fedoraforum.org/forum/showthread.php?t=159056&highlight=compiz-fusion

http://wiki.compiz-fusion.org/Get_Compiz_Fusion

leigh123linux
31st October 2007, 11:15 PM
The Compiz included in the official F7 repos is an older version and not nearly as good as Beryl. To get Compiz-Fusion, you'll want to look for a thread regarding a Compiz-Fusion repo for F7 (kagesenshi repo). That repo currently has version 0.5.2 of Compiz-Fusion, which is okay. If you read through that thread, you should find F8 SRC RPMs for 0.6.2 that can be rebuilt in F7 (after installing some dependencies from the development repo). All the info is in that thread.

The compiz srpm for F8 doesn't compile on F7 without editing the spec file and commenting out two lines ;)

bradlongo
31st October 2007, 11:39 PM
I downloaded compiz-fusion from that repo and it works except for the window manager. I have no window borders so I can't move windows, or close them. The longer compiz runs the more the window manager breaks to. At first the cube worked, then that stopped, and now the Panel that shows which applications are up doesn't show anything. What is going on?

bradlongo
31st October 2007, 11:41 PM
Here is the error message I get...

* Using the GTK Interface
* Searching for installed applications...
/usr/bin/ccsm
/usr/bin/compiz
/usr/bin/gtk-window-decorator
/usr/bin/kde-window-decorator
/usr/bin/emerald
/usr/bin/metacity
/usr/bin/kwin
* gnome session
* No GLX_EXT_texture_from_pixmap present with direct rendering context
... present with indirect rendering, exporting: LIBGL_ALWAYS_INDIRECT=1
* Executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering
compiz (cube) - Warn: Failed to load slide: freedesktop
compiz (cubecaps) - Warn: Failed to load image: fusioncap.png
compiz (cubecaps) - Warn: Failed to load image: compizcap.png
compiz (splash) - Warn: Could not load splash background image "splash_background.png" !
compiz (splash) - Warn: Could not load splash logo image "splash_logo.png" !

leigh123linux
31st October 2007, 11:57 PM
what does this give


as normal user type


emerald --replace &

bradlongo
1st November 2007, 12:00 AM
Without running compiz i typed this into a terminal and got...

$ emerald --replace &
[1] 8104

So no errors.

bradlongo
1st November 2007, 12:03 AM
compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
compiz (core) - Fatal: No manageable screens found on display :0.0
compiz --replace &
[2] 8189
[1] Exit 1 compiz
[brad@naomi ~]$ compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

[2]+ Exit 1 compiz --replace

That's when stuff starts to fail. metacity --replace gets me back to normal.

NoSkill
1st November 2007, 12:34 AM
compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
compiz (core) - Fatal: No manageable screens found on display :0.0
compiz --replace &
[2] 8189
[1] Exit 1 compiz
[brad@naomi ~]$ compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

[2]+ Exit 1 compiz --replace

That's when stuff starts to fail. metacity --replace gets me back to normal.
You did remove Beryl before installing Compiz, right? Beryl (and even orphaned bits of it, settings, etc.), must be completely removed from your system before Compiz plays nice,

The warnings about xxx.png are normal with the 3D cube because probably haven't set the pictures to be displayed for the various backgrounds yet (you'll need CompizConfigSettingsManager (CCSM) for that).

NoSkill
1st November 2007, 12:50 AM
I am running Fedora 7 with kernel 2.6.23.1-10.fc7.i686. I have no errors from x when i try to start compiz, but I get the message desktop effects could not be enabled. After that my window borders dissapear and I can't click on anything. Beryl however works just fine. I am using kmod-fglrx-8.42.3-4.2.6.23.1_10.fc7 and my xorg.conf is here....

# Xorg configuration created by livna-config-display


Section "Module"
Load "glx"
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
EndSection


Section "ServerFlags"
Option "AIGLX" "on"
EndSection


Section "Extensions"
Option "Composite" "Enable"
EndSection

I've highlighted the sections I think might be causing you problems. But having said that, I'm not terribly familiar with setting up ATI cards (they seem to be troublesome with compiz and fusion)...

RED = Probably should just remove or comment out the line.
PURPLE = Try the opposite switch (Disable or comment out the line).

I'm not sure, but I don't think you can use AIGLX with ATI cards yet, but maybe you can if you have the right drivers. :confused:

bradlongo
1st November 2007, 07:31 AM
I'm uninstalling beryl now. The last issue I have is my super key. A lot of the keyboard shortcuts involve super but it doesn' work on my Thinkpad T60. If i use xev my computer shows that it registers the key. This would make me say its compiz's issue except for the fact that it doesn't work in shortcuts anywhere else either. Anyone heard of this before?

NoSkill
1st November 2007, 08:43 AM
The last issue I have is my super key. A lot of the keyboard shortcuts involve super but it doesn' work on my Thinkpad T60. If i use xev my computer shows that it registers the key. This would make me say its compiz's issue except for the fact that it doesn't work in shortcuts anywhere else either. Anyone heard of this before?
Yes. I had the same problem. If you are using GNOME:

1. Go to the System->Preferences->Hardware->Keyboard settings manager.
2. Select the Layout Options tab.
3. Click the Alt/Win key behaviour option.
4. Make sure the Super is mapped to the Win-keys (default) option is selected.

Hopefully that will sort that out ;)

bradlongo
1st November 2007, 06:00 PM
NoSkill thanks a lot for helping me with the windows key. You have no idea how long that has been pissing me off. Unfortunatly though I have tried everything posted above and compiz still doesnt work. I'm getting the same message when I try to start it. I was thinking about going back to beryl until I played with the cube and got the fire writing going. Crazy.

I think the issue has to do with emerald not compiz. I installed it and got it to work with beryl about one week ago. Then I uninstalled compiz, and it stopped working giving me the same result I get now. Windows with no borders. I have now removed beryl though and put back compiz-fusion and emerald. Still my windows are borderless whether or not I choose the gtk manager or emerald. Is there the possibility I am missing a dependancy or could this be related to my ati graphics card?

bradlongo
1st November 2007, 06:24 PM
Btw AIGLX is working with my graphics card.

NoSkill
1st November 2007, 06:48 PM
NoSkill thanks a lot for helping me with the windows key. You have no idea how long that has been pissing me off.
Glad it worked for you. The problem had me stumped for ages too until someone on these forums pointed it out to me :)

Unfortunatly though I have tried everything posted above and compiz still doesnt work. I'm getting the same message when I try to start it. I may just go back to beryl and try compiz-fusion after a little while with fedora 8. I'll give it some more time though if anyone has any ideas.
I am assuming you are getting just the actual window(s) with no borders and no title but still have the menu bar visible... To be sure if compiz is actually running can you press the "ALT" key and left click anywhere on a window and move it around? If so, then compiz is running but the decorator (emerald) is not loading (or it is loading but there's no theme installed for it yet).

Perhaps try running CCSM (CompizConfigSettingsManager). If it loads, go to the "Window decorations" plugin and see if there is anything entered for the "Command" text entry box. Normally there should be emerald --replace entered in there. This is, of course, assuming that compiz is now actually working.

The error:

[brad@naomi ~]$ compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
is still puzzling me though :(

NoSkill
1st November 2007, 07:11 PM
# Xorg configuration created by livna-config-display

Section "Module"
Load "glx"
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
EndSection


Anyone have any ideas on what's going on? I would like to get compiz to work so I can try compiz-fusion.
Having another go at this... :D

Perhaps change the above lines to:

Section "Module"
Load “dbe”
Load “dri”
Load "glx"
EndSection
And restart X (or reboot).

[edit; Also, what command(s) are you using to start compiz? ]

bradlongo
2nd November 2007, 04:25 AM
ok so I got compiz to load correctly by starting it with this command...

$ LIBGL_ALWAYS_INDIRECT=true compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering gconf

By default the parameter --ignore-desktop-hints ccp is in there and that messes it up and gives me the error I was getting before. Can someone tell me how to edit the file /usr/share/fusion-icon/libfusionicon.py to get these parameters fixed. I tried to myself, but I'm having some trouble.

NoSkill
2nd November 2007, 04:54 AM
ok so I got compiz to load correctly by starting it with this command...

$ LIBGL_ALWAYS_INDIRECT=true compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering gconf

By default the parameter --ignore-desktop-hints ccp is in there and that messes it up and gives me the error I was getting before. Can someone tell me how to edit the file /usr/share/fusion-icon/libfusionicon.py to get these parameters fixed. I tried to myself, but I'm having some trouble.
Can you narrow it down some more?

--ignore-desktop-hints is needed otherwise your windows will open up too high.

ccp should be there otherwise ccsm won't work.

gconf may be the cause of your trouble. It's the "filing system" used for the plugins and their settings. If the plugins aren't in the correct order then you get all sorts of problems with plugins not loading or being disabled.

:confused:

NoSkill
2nd November 2007, 05:04 AM
ok so I got compiz to load correctly by starting it with this command...

$ LIBGL_ALWAYS_INDIRECT=true compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering gconf

Also, do you have libcompizconfig installed?

bradlongo
2nd November 2007, 05:27 AM
Alright so here is the error...

* gnome session
* No GLX_EXT_texture_from_pixmap present with direct rendering context
... present with indirect rendering, exporting: LIBGL_ALWAYS_INDIRECT=1
* Executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering
compiz (cube) - Warn: Failed to load slide: freedesktop
compiz (cube) - Warn: Failed to load slide: freedesktop
compiz (cube) - Warn: Failed to load slide: /home/brad/MyStuff/Pictures/theming/shelby.jpg
compiz (cubecaps) - Warn: Failed to load image: fusioncap.png
compiz (cubecaps) - Warn: Failed to load image: compizcap.png
compiz (splash) - Warn: Could not load splash background image "splash_background.png" !
compiz (splash) - Warn: Could not load splash logo image "splash_logo.png" !
Traceback (most recent call last):
File "/usr/bin/fusion-icon", line 129, in <module>
choose_interface()
File "/usr/bin/fusion-icon", line 101, in choose_interface
import_interface(interface)
File "/usr/bin/fusion-icon", line 66, in import_interface
exec('import ' + module)
File "<string>", line 1, in <module>
File "/usr/share/fusion-icon/interface_gtk.py", line 238, in <module>
gtk.main()

I do have libcompizconfig installed, and I think the error mainly has something to do with LIBGL_ALWAYS_INDIRECT=true. In the file /usr/share/fusion-icon/libfusionicon.py they have LIBGL_ALWAYS_INDIRECT=1. I think the syntax may be wrong? I do not know what the gconf parameter does but if I run LIBGL_ALWAYS_INDIRECT=true compiz --replace I get the same results just without the errors(Everything looks ****ty but I get no feedback).

$ LIBGL_ALWAYS_INDIRECT=true compiz --replace gconf
compiz (cube) - Warn: Failed to load slide: freedesktop

That gives me the best results. Hope this helps.

bradlongo
2nd November 2007, 05:37 AM
I am assuming you are getting just the actual window(s) with no borders and no title but still have the menu bar visible... To be sure if compiz is actually running can you press the "ALT" key and left click anywhere on a window and move it around? If so, then compiz is running but the decorator (emerald) is not loading (or it is loading but there's no theme installed for it yet).

Perhaps try running CCSM (CompizConfigSettingsManager). If it loads, go to the "Window decorations" plugin and see if there is anything entered for the "Command" text entry box. Normally there should be emerald --replace entered in there. This is, of course, assuming that compiz is now actually working.


Compiz is running. I can move the cube around and draw with fire. I just cant move the windows. Emerald is installed and has a theme selected. This is also where it should be: emerald --replace.

bradlongo
2nd November 2007, 05:41 AM
haha so I enabled the window decorations and now emerald is working. However I still get the all the errors I pasted above, and it would be nice to get rid of them. I do not know what issues they are causing except the ones about the cubes and the splash screen. Any ideas on how to get those gone too?

NoSkill
2nd November 2007, 05:47 AM
Compiz is running. I can move the cube around and draw with fire. I just cant move the windows. Emerald is installed and has a theme selected. This is also where it should be: emerald --replace.
In the compiz fusion forums, I spotted something about the new ATI drivers not working properly with AIGLX on some systems. Your problem is starting to sound similar to it:
http://forum.compiz-fusion.org/showthread.php?t=5068

Can you post the output of these commands:

whereis libGL.so.1.2
glxinfo | grep direct
glxinfo | grep pixmap

bradlongo
2nd November 2007, 05:58 AM
Here it is...
$ whereis libGL.so.1.2
libGL.so.1: /usr/lib/libGL.so.1 /usr/lib/libGL.so.1.2
$ glxinfo | grep direct
direct rendering: Yes
$ glxinfo | grep pixmap
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap

NoSkill
2nd November 2007, 06:46 AM
haha so I enabled the window decorations and now emerald is working. However I still get the all the errors I pasted above, and it would be nice to get rid of them. I do not know what issues they are causing except the ones about the cubes and the splash screen. Any ideas on how to get those gone too?
Ah crap... I only just saw this reply :rolleyes:

The warnings (not errors) with the cube, cubecaps and splash are that pictures haven't been set for these plugins. You can go to the plugins in CCSM and remove or replace the values (file locations) for "background" and "image files" there.

If you are using "fusion-icon" to start compiz, then the errors you are seeing with:

* No GLX_EXT_texture_from_pixmap present with direct rendering context
... present with indirect rendering, exporting: LIBGL_ALWAYS_INDIRECT=1
is fusion-icon sorting out how to start compiz and not necessarily an error - it's just the output of what it's doing to get compiz running for your rig (AIGLX will always use indirect rendering I believe).

Have fun :D

leigh123linux
2nd November 2007, 07:04 AM
haha so I enabled the window decorations and now emerald is working. However I still get the all the errors I pasted above, and it would be nice to get rid of them. I do not know what issues they are causing except the ones about the cubes and the splash screen. Any ideas on how to get those gone too?


These errors are unrelated and are caused by a incorrect path for the image files ( try adding /usr/share/compiz/ to the paths for these images , look in ccsm )

bradlongo
2nd November 2007, 07:21 AM
The default images actually don't exist on my computer, and I never deleted them. Thanks though I'm all set now.