PDA

View Full Version : xine bad problems...



ispanico
31st October 2007, 03:08 PM
Hi there,

Now it is a lot of time I am having this problem with xine, gxine... and I tried to work around the problem
but no good results so here is the problem:

when I try to view a file.avi with xine
the movie starts but in slow motion, it seem that the whole pc is slower down in fact also the mouse icon moves very slow and not continuously moreover when I quit the xine program the pc log me off, I have to
log in again.

With gxine this is even worth, in fact the video doesn't even start and I am logged off immediately...

I don't have any ideas.....
I tried to reinstall all the xine packages and libs with yum but .......the results is always the same.

Could you please help me
Thank you a lot
Ciao

leigh123linux
31st October 2007, 03:22 PM
What graphics card driver did you install?

ispanico
31st October 2007, 03:34 PM
Actually I don't know
how to see which video driver I installed...sorry I am new in linux. I suppose that by the lsmod
I can see which video module I am using, maybe are the "ata"?
I posted the lsmod command result., my video hardware is: 01:00.0 VGA compatible controller: ATI Technologies Inc M66-P [Mobility Radeon X1700]
thank you

Module Size Used by
vfat 16193 1
fat 53341 1 vfat
openafs 497340 2
autofs4 24773 2
hidp 26689 0
rfcomm 44377 0
l2cap 30401 10 hidp,rfcomm
sunrpc 161981 1
nf_conntrack_netbios_ns 7104 0
nf_conntrack_ipv4 15049 4
xt_state 6593 4
nf_conntrack 63049 3 nf_conntrack_netbios_ns,nf_conntrack_ipv4,xt_state
nfnetlink 9945 2 nf_conntrack_ipv4,nf_conntrack
ipt_REJECT 8641 2
iptable_filter 7105 1
ip_tables 16517 1 iptable_filter
xt_tcpudp 7233 14
ip6t_REJECT 9537 2
ip6table_filter 6849 1
ip6_tables 17669 1 ip6table_filter
x_tables 18629 6 xt_state,ipt_REJECT,ip_tables,xt_tcpudp,ip6t_REJEC T,ip6_tables
dm_mirror 25153 0
dm_multipath 21961 0
dm_mod 57089 2 dm_mirror,dm_multipath
video 20937 0
sbs 22729 0
button 12113 0
dock 13921 0
battery 14149 0
ac 9285 0
ipv6 277957 23 ip6t_REJECT
snd_hda_intel 243545 2
snd_seq_dummy 7877 0
arc4 6209 2
snd_seq_oss 33473 0
snd_seq_midi_event 11073 1 snd_seq_oss
ecb 7617 2
firewire_ohci 20801 0
snd_seq 50609 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
sdhci 20941 0
snd_seq_device 11981 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 43457 0
mmc_core 30149 1 sdhci
hci_usb 20701 2
iTCO_wdt 14693 0
snd_mixer_oss 19521 2 snd_pcm_oss
sr_mod 20837 0
blkcipher 10309 1 ecb
firewire_core 43137 1 firewire_ohci
snd_pcm 74949 2 snd_hda_intel,snd_pcm_oss
bluetooth 57893 8 hidp,rfcomm,l2cap,hci_usb
i2c_i801 12369 0
iTCO_vendor_support 7877 1 iTCO_wdt
joydev 13825 0
snd_timer 24901 2 snd_seq,snd_pcm
crc_itu_t 6337 1 firewire_core
iwl3945 166313 0
mac80211 142033 1 iwl3945
cfg80211 12617 1 mac80211
r8169 33097 0
i2c_core 27841 1 i2c_i801
snd 53317 10 snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,s nd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore 11681 2 snd
snd_page_alloc 14281 2 snd_hda_intel,snd_pcm
serio_raw 10821 0
cdrom 37089 1 sr_mod
sg 37469 0
ata_generic 11589 0
ata_piix 18757 6
libata 118321 2 ata_generic,ata_piix
sd_mod 31297 7
scsi_mod 140749 4 sr_mod,sg,libata,sd_mod
ext3 125641 4
jbd 59881 1 ext3
mbcache 12485 1 ext3
ehci_hcd 35405 0
ohci_hcd 23877 0
uhci_hcd 27089 0

leigh123linux
31st October 2007, 03:38 PM
You will need to install fglrx (ati driver )

see link

http://forums.fedoraforum.org/showthread.php?t=155503&page=1&pp=10

ispanico
31st October 2007, 04:02 PM
Sorry my ignorance,
I did the first step described in your link but now
I should add the line indicated below depending on my driver version....
but I do I know which driver version I have, 8.42 higher or lower?
thank you a lot.
Why I have to do all this?
ciao still thanks
Then add these sections. ( for driver version 8.42 or higher )

Quote:
Section "Extensions"
Option "Composite" "Enable"
EndSection


Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "DRI"
Mode 0666
EndSection


( for driver version 8.41 or lower require these options instead )

Quote:
Section "Extensions"
Option "Composite" "Disable"
EndSection


Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "DRI"
Mode 0666
EndSection

leigh123linux
31st October 2007, 04:09 PM
Try

yum list ati-x11-drv kmod-fglrx


yum list ati-x11-drv kmod-fglrx
Installed Packages
kmod-fglrx.x86_64 8.42.3-5.lvn livna-developmen


ati-x11-drv is still version 8.40

and

kmod-fglrx is version 8.42

ispanico
31st October 2007, 04:18 PM
Yes I checked out :
ati-x11-drv.i386 8.40.4-2.fc7 installed
kmod-fglrx.i686 8.42.3-4.2.6.23.1_10.f livna not installed

So, I think that I don't have to install the kmod-fgrlx since I installed the ati-x11-drv (from freshrpms) is it right?
then following your link, I should modify the xorg.conf file following the lines for driver version lower than 8.41 is it right?
Then wich kind of fix should I apply? I think the one for the 8.40 is it right?
Sorry but it
kind of complicate for me (beginner)...I just would like to be sure
thanks

leigh123linux
31st October 2007, 04:32 PM
Yes I checked out :
ati-x11-drv.i386 8.40.4-2.fc7 installed
kmod-fglrx.i686 8.42.3-4.2.6.23.1_10.f livna not installed

So, I think that I don't have to install the kmod-fgrlx since I installed the ati-x11-drv (from freshrpms) is it right?
then following your link, I should modify the xorg.conf file following the lines for driver version lower than 8.41 is it right?
Then wich kind of fix should I apply? I think the one for the 8.40 is it right?
Sorry but it
kind of complicate for me (beginner)...I just would like to be sure
thanks




I don't have to install the kmod-fgrlx since I installed the ati-x11-drv (from freshrpms) is it right?

Thats correct


I should modify the xorg.conf file following the lines for driver version lower than 8.41 is it right?

Thats correct


Then wich kind of fix should I apply? I think the one for the 8.40 is it right?
Sorry but it

The patch/fix is for 64 bit only.


You may need to install the kernel-devel as well

can you post

yum list kernel kernel-devel

ispanico
31st October 2007, 04:35 PM
So here is the yum list


yum list kernel:

kernel.i686 2.6.22.9-91.fc7 installed
kernel.i686 2.6.21-1.3194.fc7 installed
Available Packages
kernel.i686 2.6.23.1-10.fc7 updates
kernel.i586 2.6.23.1-10.fc7 updates

yum list kernel-devel:

Installed Packages
kernel-devel.i686 2.6.22.9-91.fc7 installed
Available Packages
kernel-devel.i686 2.6.23.1-10.fc7 updates
kernel-devel.i586 2.6.23.1-10.fc7 updates

ispanico
31st October 2007, 04:45 PM
Sorry I forgot to ask:
should I apply the fix (see below):
and where should I put the following options?

Finally, the following options are useful in the section "Device" :

Quote:
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "ForceGenericCPU" "off"
Option "KernelModuleParm" "locked-userpages=0"




su -
cd /usr/lib64/xorg/modules/drivers/
mv fglrx_drv.so fglrx_drv.so.orig
cat fglrx_drv.so.orig | sed "s/\xe8\x61\x2c\xfe\xff/\x90\x90\x90\x90\x90/g" > fglrx_drv.so
diff fglrx_drv.so fglrx_drv.so.orig
aticonfig --initial



Thank you ciao

leigh123linux
31st October 2007, 04:57 PM
Sorry I forgot to ask:
should I apply the fix (see below):
and where should I put the following options?




Thank you ciao


su -
cd /usr/lib64/xorg/modules/drivers/
mv fglrx_drv.so fglrx_drv.so.orig
cat fglrx_drv.so.orig | sed "s/\xe8\x61\x2c\xfe\xff/\x90\x90\x90\x90\x90/g" > fglrx_drv.so
diff fglrx_drv.so fglrx_drv.so.orig
aticonfig --initial

This fix is for 64 bit only and doesn't apply to you as you are running 32 bit




Quote:
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "ForceGenericCPU" "off"
Option "KernelModuleParm" "locked-userpages=0"

the other bits may not be needed ( so don't add them yet )

can you post

cat /etc/X11/xorg.conf

ispanico
31st October 2007, 06:47 PM
Hi,
here is my xorg.conf (see below.)
where I added the last 3 section as it is written on your link.
But So I don't understand if now it should work or not.
I don't have to apply the fix and I don't have to add the options
So basically I just should reboot and it should work?
What should I do now?
thank you ciao

right now the commandands fglrxinfo glxinfo says:

[root@localhost X11]# fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)


[root@localhost X11]# glxinfo
name of display: :0.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,



cat xorg.conf
# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection


Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "DRI"
Mode 0666
EndSection

leigh123linux
31st October 2007, 06:54 PM
Change this bit

from


Section "Device"
Identifier "Videocard0"
Driver "vesa"
EndSection

to


Section "Device"
Identifier "Videocard0"
Driver "fglrx"
EndSection


su
gedit /etc/X11/xorg.conf

after the change restartX

su -
gdm-restart

ispanico
31st October 2007, 07:13 PM
Ok I changed the driver
and now I am going to reboot the system.
the command

after the change restartX
gdm-restart

I don't have I don't know...
let me see by restarting what happens

ispanico
31st October 2007, 07:32 PM
Thank you very much now it works and also the appearances of the all system has changed a little bit.
I posted the results of the command fglrxinfo and glxinfo.
Thank you a lot.
When you have time, could you tell what I did following your suggestions?
So I can learn better.
Thank you
Ciao


fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1700
OpenGL version string: 2.0.6747 (8.40.4)




[root@localhost max]# glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:

leigh123linux
31st October 2007, 07:42 PM
Because your ATI X1700 is to new to work with the open source 3D driver ( radeon ), fedora defaulted to the only other driver that would work ( vesa ) which only provided un-accelerated 2D which has very poor performance.
By installing fglrx you got full accelerated 3D graphics ( direct rendering ) which has the best performance .

ispanico
1st November 2007, 07:54 PM
Thank you very much,
So, I could try to make compix work now?
Ciao
Thank you

ispanico
1st November 2007, 07:55 PM
Thank you very much,
So, I could try to make compix work now or there are some other things to install to optimize the potentiality of my video hardware?
Ciao
Thank you

leigh123linux
1st November 2007, 08:28 PM
Thank you very much,
So, I could try to make compix work now?
Ciao
Thank you

Yes ...................

ispanico
6th December 2007, 07:38 PM
Dear leigh123@linux

some time ago you help to install the right driver for my video card and to make it work properly.
recently I found that there is a new ati-x11-drv (8.42.3).
Since i had the 8.40 which seems to have a bug, I download the 8.42.3 rpm from the same
repository of the older one (Freshrpms) and I execute rpm -U ati-x11-drv-8.42.3-2-fc7
in order to update the older one.
After all the process, the it seem that everything went fine and I copied the option that you say to put for driver abode 8.42 in the xorg.conf.
In this way I was able to make googleearth work too (but not the sky part).
Now my question is:
do you think that right now the video card is well configured and controolled?
do you think I should something more?
I paste some useful output:

Thank you very much
Ciao

[max@localhost ~]$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1700
OpenGL version string: 2.0.6958 Release

[max@localhost ~]$ glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap

[max@localhost etc]$ cat X11/xorg.conf
# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "fglrx"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "DRI"
Mode 0666
EndSection



#Section "Extensions"
#Option "Composite" "Disable"
#EndSection
#
#
#Section "ServerFlags"
#Option "AIGLX" "off"
#EndSection
#
#Section "DRI"
#Mode 0666
#EndSection

FriedChips
6th December 2007, 07:42 PM
I would say everything looks good man. glxinfo reports direct rendering is still working :) How is it going with compiz?

ispanico
6th December 2007, 07:44 PM
actually I didn't install compiz
in fact I am not an expert and I would like to study in better detail how to do
otherwise I am afraid I could be in trouble if something doesn't work.
Moreover I am running on a laptop
and usually on laptop things are more complicated... :)

ispanico
17th December 2007, 02:29 PM
Hi,

I installed the 2.6.23.8-34.fc7
now I see that there is no fglrx module while in the 2.6.22 kernel that I have too it is present since I installed it.
I think I should install it again but I see there is only a version from livna and I have installed
ati-x11-drv from freshrpm
May I install the fgrlx from livna?
Why the kernel module for fgrlx is not present ?
thank you ciao

leigh123linux
17th December 2007, 02:52 PM
Hi,

I installed the 2.6.23.8-34.fc7
now I see that there is no fglrx module while in the 2.6.22 kernel that I have too it is present since I installed it.
I think I should install it again but I see there is only a version from livna and I have installed
ati-x11-drv from freshrpm
May I install the fgrlx from livna?
Why the kernel module for fgrlx is not present ?
thank you ciao


Try looking in livna-testing

http://livna-dl.reloumirrors.net/fedora/testing/7/i386/


su
wget http://livna-dl.reloumirrors.net/fedora/testing/7/i386/kmod-fglrx-8.43-2.7.11.2.6.23.8_34.fc7.i686.rpm
wget http://livna-dl.reloumirrors.net/fedora/testing/7/i386/xorg-x11-drv-fglrx-8.43-1.7.11.lvn7.i386.rpm
rpm -U --oldpackage --replacefiles --replacepkgs kmod-fglrx-8.43-2.7.11.2.6.23.8_34.fc7.i686.rpm xorg-x11-drv-fglrx-8.43-1.7.11.lvn7.i386.rpm

ispanico
20th December 2007, 12:10 PM
Hi,

I install the packages from the livna repo I already had and I found that
with:
kmod-fglrx.i686 8.42.3-4.2.6.23.8_34.f installed
xorg-x11-drv-fglrx.i386 8.42.3-6.lvn7 installed
compiz works.
Should upgrade these packages to the version you already suggest
or it is better not to since theu are in "testing"?

Thank you a lot

leigh123linux
20th December 2007, 03:46 PM
Hi,

I install the packages from the livna repo I already had and I found that
with:
kmod-fglrx.i686 8.42.3-4.2.6.23.8_34.f installed
xorg-x11-drv-fglrx.i386 8.42.3-6.lvn7 installed
compiz works.
Should upgrade these packages to the version you already suggest
or it is better not to since theu are in "testing"?

Thank you a lot

If its working OK leave it as it is and wait for the new ATI driver to be released from testing.