PDA

View Full Version : yum update problem



tsr-nc
31st October 2007, 06:22 AM
i am running fc8 test 3 on an x86_64
well updating computer locked up (compiz problem) after restart i started
yum with "yum -y update -x kernel kmod-nvidia"
it started *****en at me with
/
Transaction Check Error:
file /etc/alsa/cards/SI7018/sndoc-mixer.alisp from install of alsa-lib-1.0.15-1.fc8 conflicts with file from package alsa-lib-1.0.15-0.4.rc3.fc8
file /etc/alsa/cards/SI7018/sndop-mixer.alisp from install of alsa-lib-1.0.15-1.fc8 conflicts with file from package alsa-lib-1.0.15-0.4.rc3.fc8
file /etc/alsa/sndo-mixer.alisp from install of alsa-lib-1.0.15-1.fc8 conflicts with file from package alsa-lib-1.0.15-0.4.rc3.fc8
/
no i have had this problem before and sloved it with a quick yum remove x/yum install x but alsa-lib has 278 depdcs. would it be safe to just remove these files and reinstall alsa-lib or have any other tips

in gentoo you can request that dependencies not be processed but i did not see that listed for yum under man yum or yum --help

stevea
31st October 2007, 07:14 AM
Yeah - this is the yum curse of the day. You could manually force install
alsa-lib-1.0.15-1.fc8 c

Or you can yum erase alsa-lib, then yum install alsa-lib, but the erase may remove other packages.
(read the list before you type 'y').

tsr-nc
31st October 2007, 07:45 AM
yes i tried this however that "list of other packages" was 278 packages long and i have a slow internet connection
how do you force install a packege rpm --force

mickwombat
3rd January 2008, 09:43 AM
Hi there,

Having similar problems with FC8 i386. I get similar to the above when I tried to update the software with Pup or whatever it is. Error message I got was:

installs of tetex-latex-3.0-44.3.fc8 and texlive-2007-5.fc9
file /usr/share/texmf/web2c/platex209-sjis.fmt conflicts between attempted installs of tetex-latex-3.0-44.3.fc8 and texlive-2007-5.fc9

Which repeats itself for 100 pages (when pasted into a Word document). When I tried to do a yum update I got the following at the end:

(543/544): info-4.11-4.fc 100% |=========================| 166 kB 00:00
(544/544): libbonobo-2.20 100% |=========================| 469 kB 00:00
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package transmission needs libcrypto.so.6, this is not available.
Package transmission needs libssl.so.6, this is not available.
Complete!

Don't know what all this means and what the solution is. I tried, using the Software Updater Pup or whatever, to update packages individually and it seems to be working, but obviously this is extremely laborious and frustrating.

Any ideas.

Thanks

Demz
3rd January 2008, 09:54 AM
Hi there,

Having similar problems with FC8 i386. I get similar to the above when I tried to update the software with Pup or whatever it is. Error message I got was:

installs of tetex-latex-3.0-44.3.fc8 and texlive-2007-5.fc9
file /usr/share/texmf/web2c/platex209-sjis.fmt conflicts between attempted installs of tetex-latex-3.0-44.3.fc8 and texlive-2007-5.fc9

Which repeats itself for 100 pages (when pasted into a Word document). When I tried to do a yum update I got the following at the end:

(543/544): info-4.11-4.fc 100% |=========================| 166 kB 00:00
(544/544): libbonobo-2.20 100% |=========================| 469 kB 00:00
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package transmission needs libcrypto.so.6, this is not available.
Package transmission needs libssl.so.6, this is not available.
Complete!

Don't know what all this means and what the solution is. I tried, using the Software Updater Pup or whatever, to update packages individually and it seems to be working, but obviously this is extremely laborious and frustrating.

Any ideas.

Thanks
no wonder your still using the development repo which you shouldnt be
yum --disablerepo=Development
i think your also gonna have to enable Fedora Updates repo

mickwombat
3rd January 2008, 07:10 PM
Hi,

Thanks for that.

Why, if it's a development repo, is it on the Fedora site for general download as being the actual proper, fair dinkum release.

Ok, so I put the command in you suggested and got this.

[root@localhost ~]# yum --disablerepo=Development


Error getting repository data for Development, repository not found
[root@localhost ~]#

What do I need to type to enable the Fedora Update repo as you suggested.

Many thanks

glennzo
3rd January 2008, 08:12 PM
List out yum.repos.d, ls /etc/yum.repos.d, I think you'll find that it's fedora-develpoment and not Development, so yum --disablerepo=fedora-deveolpment. I'm running Windows right now so I can't check.

mickwombat
3rd January 2008, 08:22 PM
Hi there,

Heres what I got below.

[root@localhost ~]# ls /etc/yum.repos.d
fedora-development.repo fedora.repo fedora-updates-testing.repo
Fedora-install-media.repo fedora-updates.repo
[root@localhost ~]#

And when I try the other bit I get

[root@localhost ~]# yum --disablerepo=fedora-deveolpment


Error getting repository data for fedora-deveolpment, repository not found
[root@localhost ~]#


Thanks

Seve
3rd January 2008, 08:36 PM
[root@localhost ~]# yum --disablerepo=fedora-development
Hello:

Try
yum --disablerepo=development

or to permanently disable the repo (which you should)

su -
gedit /etc/yum.repos.d/fedora-development.repo
and
set
enabled=1
to
enabled=0
save, exit and
yum clean all
yum check-update

Seve

glennzo
3rd January 2008, 08:49 PM
That's cuz ya spellzed it wong. :D

mickwombat
3rd January 2008, 09:10 PM
Well spotted. Damn that copy and paste function. lol.

I should have been more alert