PDA

View Full Version : yum update error



zabolots
30th October 2007, 08:35 PM
[zabolots@dvarchive ~]$ sudo yum update
Password:
livna 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 157 kB 00:01
fedora 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.3 kB 00:00
mono 100% |=========================| 951 B 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package vnc.i386 0:4.1.2-19.fc7 set to be updated
---> Package ruby.i386 0:1.8.6.111-1.fc7 set to be updated
---> Package kernel-headers.i386 0:2.6.23.1-10.fc7 set to be updated
---> Package kernel.i686 0:2.6.23.1-10.fc7 set to be updated
---> Package python-devel.i386 0:2.5-14.fc7 set to be updated
---> Package ruby-libs.i386 0:1.8.6.111-1.fc7 set to be updated
---> Package kernel-devel.i686 0:2.6.23.1-10.fc7 set to be updated
---> Package vnc-server.i386 0:4.1.2-19.fc7 set to be updated
---> Package nfs-utils.i386 1:1.1.0-4.fc7 set to be updated
---> Package subversion.i386 0:1.4.4-1.fc7 set to be updated
---> Package python.i386 0:2.5-14.fc7 set to be updated
---> Package rpcbind.i386 0:0.1.4-8.fc7 set to be updated
---> Package python-libs.i386 0:2.5-14.fc7 set to be updated
---> Package vnc-libs.i386 0:4.1.2-19.fc7 set to be updated
---> Package tar.i386 2:1.15.1-28.fc7 set to be updated
---> Package libraw1394.i386 0:1.2.1-11.fc7 set to be updated
---> Package smolt.noarch 0:0.9.9-1.fc7 set to be updated
--> Finished Dependency Resolution
--> Running transaction check
---> Package vnc.i386 0:4.1.2-19.fc7 set to be updated
---> Package ruby.i386 0:1.8.6.111-1.fc7 set to be updated
---> Package kernel-headers.i386 0:2.6.23.1-10.fc7 set to be updated
---> Package kernel.i686 0:2.6.22.5-76.fc7 set to be erased
---> Package kernel.i686 0:2.6.23.1-10.fc7 set to be installed
---> Package python-devel.i386 0:2.5-14.fc7 set to be updated
---> Package ruby-libs.i386 0:1.8.6.111-1.fc7 set to be updated
---> Package kernel-devel.i686 0:2.6.23.1-10.fc7 set to be installed
---> Package vnc-server.i386 0:4.1.2-19.fc7 set to be updated
---> Package kernel-devel.i686 0:2.6.22.5-76.fc7 set to be erased
---> Package nfs-utils.i386 1:1.1.0-4.fc7 set to be updated
---> Package subversion.i386 0:1.4.4-1.fc7 set to be updated
---> Package python.i386 0:2.5-14.fc7 set to be updated
---> Package rpcbind.i386 0:0.1.4-8.fc7 set to be updated
---> Package python-libs.i386 0:2.5-14.fc7 set to be updated
---> Package vnc-libs.i386 0:4.1.2-19.fc7 set to be updated
---> Package tar.i386 2:1.15.1-28.fc7 set to be updated
---> Package libraw1394.i386 0:1.2.1-11.fc7 set to be updated
---> Package smolt.noarch 0:0.9.9-1.fc7 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
kernel i686 2.6.23.1-10.fc7 updates 16 M
kernel-devel i686 2.6.23.1-10.fc7 updates 4.6 M
Updating:
kernel-headers i386 2.6.23.1-10.fc7 updates 644 k
libraw1394 i386 1.2.1-11.fc7 updates 43 k
nfs-utils i386 1:1.1.0-4.fc7 updates 261 k
python i386 2.5-14.fc7 updates 5.4 M
python-devel i386 2.5-14.fc7 updates 2.0 M
python-libs i386 2.5-14.fc7 updates 560 k
rpcbind i386 0.1.4-8.fc7 updates 47 k
ruby i386 1.8.6.111-1.fc7 updates 512 k
ruby-libs i386 1.8.6.111-1.fc7 updates 1.7 M
smolt noarch 0.9.9-1.fc7 updates 219 k
subversion i386 1.4.4-1.fc7 updates 2.3 M
tar i386 2:1.15.1-28.fc7 updates 743 k
vnc i386 4.1.2-19.fc7 updates 91 k
vnc-libs i386 4.1.2-19.fc7 updates 166 k
vnc-server i386 4.1.2-19.fc7 updates 1.8 M
Removing:
kernel i686 2.6.22.5-76.fc7 installed 47 M
kernel-devel i686 2.6.22.5-76.fc7 installed 15 M

Transaction Summary
================================================== ===========================
Install 2 Package(s)
Update 15 Package(s)
Remove 2 Package(s)

Total download size: 37 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package 4Suite needs python(abi) = 2.4, this is not available.
Package 4Suite needs python-abi = 2.4, this is not available.
Complete!

leigh123linux
30th October 2007, 09:14 PM
[zabolots@dvarchive ~]$ sudo yum update
Password:
livna 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 157 kB 00:01
fedora 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.3 kB 00:00
mono 100% |=========================| 951 B 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package vnc.i386 0:4.1.2-19.fc7 set to be updated
---> Package ruby.i386 0:1.8.6.111-1.fc7 set to be updated
---> Package kernel-headers.i386 0:2.6.23.1-10.fc7 set to be updated
---> Package kernel.i686 0:2.6.23.1-10.fc7 set to be updated
---> Package python-devel.i386 0:2.5-14.fc7 set to be updated
---> Package ruby-libs.i386 0:1.8.6.111-1.fc7 set to be updated
---> Package kernel-devel.i686 0:2.6.23.1-10.fc7 set to be updated
---> Package vnc-server.i386 0:4.1.2-19.fc7 set to be updated
---> Package nfs-utils.i386 1:1.1.0-4.fc7 set to be updated
---> Package subversion.i386 0:1.4.4-1.fc7 set to be updated
---> Package python.i386 0:2.5-14.fc7 set to be updated
---> Package rpcbind.i386 0:0.1.4-8.fc7 set to be updated
---> Package python-libs.i386 0:2.5-14.fc7 set to be updated
---> Package vnc-libs.i386 0:4.1.2-19.fc7 set to be updated
---> Package tar.i386 2:1.15.1-28.fc7 set to be updated
---> Package libraw1394.i386 0:1.2.1-11.fc7 set to be updated
---> Package smolt.noarch 0:0.9.9-1.fc7 set to be updated
--> Finished Dependency Resolution
--> Running transaction check
---> Package vnc.i386 0:4.1.2-19.fc7 set to be updated
---> Package ruby.i386 0:1.8.6.111-1.fc7 set to be updated
---> Package kernel-headers.i386 0:2.6.23.1-10.fc7 set to be updated
---> Package kernel.i686 0:2.6.22.5-76.fc7 set to be erased
---> Package kernel.i686 0:2.6.23.1-10.fc7 set to be installed
---> Package python-devel.i386 0:2.5-14.fc7 set to be updated
---> Package ruby-libs.i386 0:1.8.6.111-1.fc7 set to be updated
---> Package kernel-devel.i686 0:2.6.23.1-10.fc7 set to be installed
---> Package vnc-server.i386 0:4.1.2-19.fc7 set to be updated
---> Package kernel-devel.i686 0:2.6.22.5-76.fc7 set to be erased
---> Package nfs-utils.i386 1:1.1.0-4.fc7 set to be updated
---> Package subversion.i386 0:1.4.4-1.fc7 set to be updated
---> Package python.i386 0:2.5-14.fc7 set to be updated
---> Package rpcbind.i386 0:0.1.4-8.fc7 set to be updated
---> Package python-libs.i386 0:2.5-14.fc7 set to be updated
---> Package vnc-libs.i386 0:4.1.2-19.fc7 set to be updated
---> Package tar.i386 2:1.15.1-28.fc7 set to be updated
---> Package libraw1394.i386 0:1.2.1-11.fc7 set to be updated
---> Package smolt.noarch 0:0.9.9-1.fc7 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
kernel i686 2.6.23.1-10.fc7 updates 16 M
kernel-devel i686 2.6.23.1-10.fc7 updates 4.6 M
Updating:
kernel-headers i386 2.6.23.1-10.fc7 updates 644 k
libraw1394 i386 1.2.1-11.fc7 updates 43 k
nfs-utils i386 1:1.1.0-4.fc7 updates 261 k
python i386 2.5-14.fc7 updates 5.4 M
python-devel i386 2.5-14.fc7 updates 2.0 M
python-libs i386 2.5-14.fc7 updates 560 k
rpcbind i386 0.1.4-8.fc7 updates 47 k
ruby i386 1.8.6.111-1.fc7 updates 512 k
ruby-libs i386 1.8.6.111-1.fc7 updates 1.7 M
smolt noarch 0.9.9-1.fc7 updates 219 k
subversion i386 1.4.4-1.fc7 updates 2.3 M
tar i386 2:1.15.1-28.fc7 updates 743 k
vnc i386 4.1.2-19.fc7 updates 91 k
vnc-libs i386 4.1.2-19.fc7 updates 166 k
vnc-server i386 4.1.2-19.fc7 updates 1.8 M
Removing:
kernel i686 2.6.22.5-76.fc7 installed 47 M
kernel-devel i686 2.6.22.5-76.fc7 installed 15 M

Transaction Summary
================================================== ===========================
Install 2 Package(s)
Update 15 Package(s)
Remove 2 Package(s)

Total download size: 37 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package 4Suite needs python(abi) = 2.4, this is not available.
Package 4Suite needs python-abi = 2.4, this is not available.
Complete!


The version of 4suite is not compatible ( what did you use ? some old FC4 package :rolleyes: ) with F7 so remove it

su
yum erase 4suite
yum install python-4Suite-XML
yum update


Try this link for info on 4suite

http://fedora.kiewel-online.de/repoview/linux/releases/7/Everything/i386/repodata/repoview/python-4Suite-XML-0-1.0.2-1.html

zabolots
30th October 2007, 10:21 PM
The version of 4suite is not compatible ( what did you use ? some old FC4 package :rolleyes: ) with F7 so remove it

su
yum erase 4suite
yum install python-4Suite-XML
yum update



Thanks.

Any yes, this was originally an FC4 box that has been upgraded via FC4->FC5->FC6->FC7

Scott