PDA

View Full Version : K3b can't format DVD+RW



AlFrugal
28th October 2007, 07:51 PM
This is my first use of K3b. I'm trying to copy a folder of HTML files to a blank DVD+RW (from a shared FAT32 partition). K3b failed in the preformatting phase.

I run Fedora 7. KDE 3.5.7-22.fc7. K3b 1.0.3. My burner is a BenQ DW1655.

I started by inserting a blank Sony DVD+RW disk into the burner. Fedora responded with "Blank DVD+RW - KDE Daemon: New medium detected".

I selected the option "Create data DVD with K3b".

When K3b came up, I added files to project (703 MB worth) and then I clicked on "burn".

K3b began preformatting the dvd+rw disk. It then popped up the message "erasing failed", and the dvd+rw disk was ejected from the drive. K3b followed with the message "Found media: no media present. Please insert an empty or appendable DVD+R(W) medium into drive."

I rebooted my dual-boot PC into Windows/ME and ran Nero Express (OEM version) using the same blank DVD+RW disk. I selected the same set of files for the project and the burn was successful.

I tried K3b again using another blank Sony DVD+RW disk from the same ten-pack. K3b failed in the same way.

Why is K3b failing?

lazlow
28th October 2007, 08:03 PM
Al

I have the same problem. Just ignore it. Hopefully K3b will figure out what the problem is. Just hit ok when it fails and if another window opens (sometimes mine does, sometimes not) just hit force. My drive drawer usually(not always) opens and the force button closes it.

Good luck
Lazlow

buddha
28th October 2007, 08:07 PM
Do you have the dvd+rw-tools package installed?

In k3b, under Settings->Configure K3b->Programs, is there a check mark under dvd+rw-format?

I use DVD+RW's regularly, but it's been a long time since I've had to format a new one.

AlFrugal
28th October 2007, 10:43 PM
Thanks lazlow and buddha for your replies.

buddha: To answer your questions:

Do you have the dvd+rw-tools package installed? -> Yes. dvd+rw-tools-7.0-3.fc7.

In k3b, under Settings->Configure K3b->Programs, is there a check mark under dvd+rw-format? -> Yes.

AlFrugal
29th October 2007, 04:08 PM
A different result this day. I have no idea why.

I wanted to try Lazlow's suggestion, so I once again inserted a blank Sony DVD+RW disk into my drive. This time, there was no pop-up message from KDE saying that a new medium had been detected.

I manually started K3b and added the same files to a project as reported earlier in this thread. This time, there was no message about preformatting, and the burn completed successfully.

Unlike the burn with Nero Express (on Windows ME), there was a message reporting that because of a problem with Joliet extensions, some filenames would have to be shortened.

Dangermouse
29th October 2007, 04:21 PM
Hello K3b has problems formatting because it cant unmount the dvd first, there is two ways round this as far as i know unmount the dvd

umount /dev/dvd
or format it yourself by

su
dvd+rw-format -force /dev/dvd