PDA

View Full Version : How to Install Nvidia driver from lash drive in command line



arguspanoptes
27th October 2007, 11:17 PM
I am new to fedora and know just enough to get myself into trouble. I wanted to play WOW and the fps was bad (like 1FPS) so I decided to try to update/install a new driver through yum. Upon reboot I have no GUI (just fantastic). Being reduced to the command line I don't know how to access my flash drive (SanDisk U3 Cruzer 512 MB) which I have downloaded some .rpm files to.

I am running:
Fedora 7 (Moonshine)
Kernel 2.6.22.9-91.fc7

On a:
Dell 8100
Pentium 4
768 MB ram
FX 5700 Ultra Nvidia card

P.S. I had internet connection through wireless but apparently without the GUI madwifi does not kick in. In light of this I am using my roommates computer to download .rpm files (which one I need I am not sure of so any help there would also be appreciated) and i can put them on flash or cd storage.

leigh123linux
28th October 2007, 12:33 AM
Why do it like this ?

Just edit xorg.conf to another driver to get the GUI ;)


login as root

nano /etc/X11/xorg.conf


and change the driver from "nvidia" to "nv"


Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "G70 [GeForce 7600 GT]"
EndSection


to



Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "nVidia Corporation"
BoardName "G70 [GeForce 7600 GT]"
EndSection


save and exit nano then type


startx

arguspanoptes
28th October 2007, 02:55 AM
Ok so you are SO close to becoming my ultimate hero. This works but only under some strange conditions. I have found the area labeled device in the script but can only change the text and save it under root, which is not a problem until I try to switch users which is says I can't do (some error about poor administrative allowances, which I never set it is all default). Also, after I have rebooted the computer the script was not saved so I have to do it again. This may have something to do with me not being familiar with the nano editor.

Also I have found that If i look at the error and opt to try to fix it and do nothing when the system tries to start the GUI it works but at terrible resolution, but I can get on the internet and everything, should I try to reinstall new drivers through yum again at this point?

leigh123linux
28th October 2007, 03:04 AM
Yes reinstall the nvidia driver


su -
rpm -Uvh http://rpm.livna.org/livna-release-7.rpm
yum install kmod-nvidia
/usr/sbin/nvidia-config-display enable
/sbin/service nvidia restart


then reboot to the newest kernel


instead of startx try using



gdm-restart

leigh123linux
28th October 2007, 03:13 AM
Also can you post

su
cat /etc/inittab

arguspanoptes
28th October 2007, 03:17 AM
Alright I got more problems which equals more fun. Haha. This is how the session went:

[arguspanoptes4@localhost ~]$ su
Password:
[root@localhost arguspanoptes4]# rpm -Uvh http://rpm.livna.org/livna-release-7.rpm
Retrieving http://rpm.livna.org/livna-release-7.rpm
Preparing... ########################################### [100%]
package livna-release-7-2 is already installed
[root@localhost arguspanoptes4]# yum install kmod-nvidia
Setting up Install Process
Parsing package install arguments
Package kmod-nvidia - 100.14.19-1.2.6.22.9_91.fc7.i686 is already installed.
Resolving Dependencies
--> Running transaction check
---> Package kmod-nvidia.i686 0:100.14.19-1.2.6.22.7_85.fc7 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.22.7-85.fc7 for package: kmod-nvidia
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-i686 = 2.6.22.7-85.fc7 is needed by package kmod-nvidia

So I essentially have the wrong kernel right? So where do I update it? Is it as simple as:

yum update kernel

I will try to find directions and continue with your solution.

leigh123linux
28th October 2007, 03:23 AM
Alright I got more problems which equals more fun. Haha. This is how the session went:

[arguspanoptes4@localhost ~]$ su
Password:
[root@localhost arguspanoptes4]# rpm -Uvh http://rpm.livna.org/livna-release-7.rpm
Retrieving http://rpm.livna.org/livna-release-7.rpm
Preparing... ########################################### [100%]
package livna-release-7-2 is already installed
[root@localhost arguspanoptes4]# yum install kmod-nvidia
Setting up Install Process
Parsing package install arguments
Package kmod-nvidia - 100.14.19-1.2.6.22.9_91.fc7.i686 is already installed.
Resolving Dependencies
--> Running transaction check
---> Package kmod-nvidia.i686 0:100.14.19-1.2.6.22.7_85.fc7 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.22.7-85.fc7 for package: kmod-nvidia
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-i686 = 2.6.22.7-85.fc7 is needed by package kmod-nvidia

So I essentially have the wrong kernel right? So where do I update it? Is it as simple as:

yum update kernel

I will try to find directions and continue with your solution.

Ok ( yum is have a funny turn and is trying to install older packages :( )

try just these commands and post any errors ( you should boot up using this kernel
2.6.22.9_91 )


su -
/usr/sbin/nvidia-config-display enable
/sbin/service nvidia restart


also post the output from this command


uname -r

arguspanoptes
28th October 2007, 03:34 AM
Alright, I see what you are saying about the old packages. this is what I did:

[root@localhost arguspanoptes4]# /usr/sbin/nvidia-config-display enable
[root@localhost arguspanoptes4]# /sbin/service nvidia restart
Disabling the nvidia driver: [ OK ]
Checking for module nvidia.ko: [ OK ]
Enabling the nvidia driver: [ OK ]
[root@localhost arguspanoptes4]# uname -r
2.6.22.9-91.fc7

and this is all I have done since my previous post.

leigh123linux
28th October 2007, 03:44 AM
Alright, I see what you are saying about the old packages. this is what I did:

[root@localhost arguspanoptes4]# /usr/sbin/nvidia-config-display enable
[root@localhost arguspanoptes4]# /sbin/service nvidia restart
Disabling the nvidia driver: [ OK ]
Checking for module nvidia.ko: [ OK ]
Enabling the nvidia driver: [ OK ]
[root@localhost arguspanoptes4]# uname -r
2.6.22.9-91.fc7

and this is all I have done since my previous post.


Check xorg.conf to make sure the nvidia driver is selected

su
gedit /etc/X11/xorg.conf

and check to make sure this driver is selected


Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "G70 [GeForce 7600 GT]"
EndSection

The restartX ( Ctrl + Alt + Backspace )

arguspanoptes
28th October 2007, 04:07 AM
When the xorg.conf is checked it is the same as before:

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

BTW you are amazing

arguspanoptes
28th October 2007, 04:25 AM
The GUI was working on the Ctrl + Alt + Backspace but on a total system restart there was the same old problem again. and i had to go through the error fix thing at the beginning, which just gives me the display setting where every time I have to set it to 1024x786 resolution and then it works perfect. it says that it saves the changes to xorg.config but it never gets saved from boot to boot, just like when I changed the xorg config to say "nv" instead of "nvidia"

arguspanoptes
28th October 2007, 06:59 AM
I found the problem and now it is fixed. I accidentally ran the command "startx" when I hadn't rewritten the code and it gave me the error with something to the effect of "the power check has not returned positive for your nvidia card" and so when I turned off my computer i found upon opening the case that the card was not plugged in to a power source. This fixed ALL my problems including my WoW issues (i know it's the game of the devil). Thank you SO SO much leigh123 you are still my hero.

stry_cat
28th October 2007, 01:51 PM
I found the problem and now it is fixed. I accidentally ran the command "startx" when I hadn't rewritten the code and it gave me the error with something to the effect of "the power check has not returned positive for your nvidia card" and so when I turned off my computer i found upon opening the case that the card was not plugged in to a power source. This fixed ALL my problems including my WoW issues (i know it's the game of the devil). Thank you SO SO much leigh123 you are still my hero.

If the card wasn't plugged in how did you get any video output in order to even see the error message :eek:

arguspanoptes
31st October 2007, 06:03 AM
I meant plugged in as far as power. it was plugged in the AGP slot so it was getting low power just not enough to run the GUI (witch it actually could but because the newest graphics card update for nvidia includes a power check it shut down the process, but even though it could run the GUI the card would have never reached peak performance in my machine anyway)

EDIT: (if you guys could actually help again this is my new problem)
Alright so when I play games (WoW) on my Fedora 7 computer, kernel 2.6.22.9-91.fc7, I get horrid frame rates between 5 and 15 FPS. I think the problem is the OpenGL is not working but I don't know how to tell if it is. I have tried using "eselect opengl set nvidia" (without quotes obviously) but it returns "bash: eselect: command not found" (w/o q's). what is the eselect command and is it only a gentoo thing and therfore wrong for me?