PDA

View Full Version : Help req. accessing Windows partitions



sbjaved
27th October 2007, 01:39 PM
Hi,

I'm a new user to Fedora 7, but not to linux. My problem is that fedora doesn't pick up my Windows partitions (which are fat32). Nothing under /media nor /mnt. I read some threads on various forums suggestting "fdisk -l" command. Strangely enough the terminal gives a "bash: command not found error" when I type it (even as root, I get the same error)
Also Fedora mounts my linux partitions in an LVMGroup (which by the way I have no idea about). Other distros I've tried usually mount partitions as /media/sda* (Ubuntu) or /mnt/drive_C (PCLOS). Maybe I messed something up?
I really like Fedora and want to keep using it but not being able to access my Windows partitions is a big problem because I have all my music, pictures and videos there. Any help would be very appreciated.

Thanks.

jim
27th October 2007, 01:56 PM
I believe this will help your problem..
http://www.jplawrence.us/mywiki/MountVfat

sbjaved
27th October 2007, 05:07 PM
I believe this will help your problem..
http://www.jplawrence.us/mywiki/MountVfat

I read the guide. Here is my fstab...How do I find Windows partition?

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0

sbjaved
27th October 2007, 07:42 PM
--[Problem Solved]--

Okay I got fdisk working by typing /sbin/fdisk. I think a path should be created to that location automatically. After that it was simple modification of fstab (/dev/sda5 /media/Data vfat) and mount -a. Wallah! I get mey window partitions. This sorta thing ought to be automatic too. Here's hoping Fedora 8 "Werewolf" builds on it.

goldenbrown
27th October 2007, 10:46 PM
Get used to logging in as root by typing "su -" rather than "su", as the former runs the root's .bashrc file and thereby setting the PATH variable to point to /bin, /sbin etc. The latter does not do this, so you are stuck with the users profile.
As for LVM, you didn't mess up, you just chose the default fedora way. Learn to love it or use manual partition setup for F8.
Welcome and enjoy,
Nigel

stoat
27th October 2007, 10:48 PM
Hello sbjaved,

Here is the difference in $PATH for user, su, su - on my machine...

[user@localhost ~]$ echo $PATH
/usr/kerberos/bin:/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin:/home/user/bin

[user@localhost ~]$ su
Password:
[root@localhost user]# echo $PATH
/usr/kerberos/sbin:/usr/kerberos/bin:/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin:/home/user/bin

[user@localhost ~]$ su -
Password:
[root@localhost ~]# echo $PATH
/usr/kerberos/sbin:/usr/kerberos/bin:/usr/lib/ccache:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin