PDA

View Full Version : Fedora 7 install failure - really need help



ChrisSavery
27th October 2007, 02:35 AM
Hello,

First I have to say I'm a long term user of Centos in a server environment and familiar with many aspects of using linux. I'm now 3 days into trying to make Linux my desktop and getting seriously fatigued and ready to revert back to Windows. I'm sure it wasn't meant to be so difficult.

This is my third attempt at getting a useful Linux desktop. First I tried Centos 4 and it worked great but was quite old and so could not run the current Skype client (needed!) and has an older Firefox version. I went looking for a newer and better desktop. Tried Ubuntu Gutsy - first install failed. Repeated again and it worked. I have a dead dvd writer so cannot burn an image to install from. I managed to get Ubuntu to install from a second hard drive but it would only do so with their alternate install iso. That one doesn't install a graphical desktop. After more than a day of trying to get around buggy startups and stuff I gave up on Ubuntu.

Yesteday and today I have been trying to get Fedora 7 loaded. I was able to do a network install from another machine using NFS. First install went wonderfully right to the end. I really was impressed and thought this was going to be it and I'd have a good desktop going. BUT no when I rebooted it wouldn't boot up on the new installed system. I checked a few things and decided to reinstall again as this had fixed the issues with Ubuntu before. Second attempt went the same: perfectly. But still no boot. Damn, this is getting frustrating. Why did Centos install so easily but these newer Linux version not?

Ok. So at boot it loads the kernel fine from the boot partition. It looks for the Logical Volumes and doesn't find any. Stops after that with kernel panic.

Stange details about install - maybe... during install the system recognizes my primary drive as sdc and the boot aprtition is sdc1 and the lvm partition is sdc2. The grub parms are set to boot on hd0,0 and root is /dev/VolGroup00/LogVol00 as default install.

But at boot the primary drive is hda and boot is hda1 and root is hda2.

Asus motherboard has a Fasttrack BIOS that I have two additional drives installed on in striped format. That parition is NTFS and I've been skipping it and ignoring it during install. It was deselected during install so that it wouldn't be touched by Fedora install process.

Since I have no CD/DVD image I have been booting off the diskboot.img from a USB drive. This has been working very well. I can go completely through the boot, install from NFS with no issues except the drives all appear as sda, sdb (the ntfs partition that is ignored) and sdc (the target partition which is a single seagate drive I intend to use), and sdd (the USB boot, which Fedora install keeps wanting to wipe out but I tell it not to).

SO NOW. Have booted into NFS rescue image and it will successfully find the correct LVM partition (sdc2) and mount it in /mnt/sysimage - everything appears normal there. But once again when rebooting into grub and sdc1, sdc2 (now seen as hda1, hda2) it still reports "finding volumes" and reports NOT FOUND. Attempt to load /dev/root but fails and kernel panics.

Does any expert out there have any idea what's going on here and how to get my system up?

Thanks in advance. I'm really ready to re-install Windows and give up. I don't want to but seriously, wouldn't you?

Chris :)

marcrblevins
27th October 2007, 02:49 AM
Would been alot easier if your replace your DVD burner and go there.

ChrisSavery
27th October 2007, 02:51 AM
Nope. I'm way out in the middle of nowhere. Replacing it is not an option right now. Maybe next month. But if I have to wait for that I'll be back on Windows for good most likely. Besides, the install runs fine without the dvd - it's simply an image on my other machine and accessed with NFS. Not having any issues with getting to the install image.
Chris :)

marcrblevins
27th October 2007, 02:59 AM
Mind sharing your hardware spec?

pravuil
27th October 2007, 03:12 AM
I could be completely wrong about this so you might want to disregard this. Actually, the problem has been posted before in another thread. I'm trying to search for it. I'll post it when I find it.

Basically it's a problem with initrd at install. The problem appears with certain ide hard drives when labeled as sda instead of hda. There are more details of what caused it in the thread if I could find it. It's unfortunate because I was having the same problems. The bug has been reported and a lot of people have complained about it. I do believe there is a fix but I haven't tested personally.

Edit: The way I ended up getting fedora to run on my machine was to install xen. I needed to setup virtualization but if you don't need it you probably won't want it.

ChrisSavery
27th October 2007, 03:17 AM
P4 3GHZ
Asus P4P800E mainboard
1 Seagate 160 GB IDE drive mounted Primary IDE
2 Maxtor 80 GB IDE drives mounted Fasttrack (Promise) RAID controller
No SATA drives installed
1GB RAM
NVidia generic video card

System has been running WindowsXP for years. Ran Centos two days ago.
Boots rescue image and access to VolGroup00/LogVol00 is fine.

Something is preventing the kernel installed by Fedora from seeing the LVM volumes.
I can't hardly believe that the install would go all the way through and put all those hundreds of files on there get to the end and say congrats, and then not boot. Weird.

Chris :)

ChrisSavery
27th October 2007, 03:21 AM
pravuil - thank you if you can find info on that. I searched and didn't but didn't know any details other than "kernel panic volume not found".

There's a lot of error lines on the screen now - basically it says Attempting to read volume groups and No volume groups found. Ends finally with not synced, attempted to kill init.

Chris :)

pravuil
27th October 2007, 03:53 AM
Like I said before, I'm not sure if this is the exact problem. Kernel panic could be end up being a lot of things but from what it sounds like I doubt it's anything else. Here's a link to one of the fixes within the bug report:

https://bugzilla.redhat.com/show_bug.cgi?id=241949#c26

If using mkinitrd at install doesn't work then look for the fix for "mdadm -Es" further down within the thread.

ChrisSavery
27th October 2007, 06:45 AM
Thanks Pravuil.
I read through the entire bug thread and tried a few things including the mkinitrd command and also the patch suggested to fix it. mdadm does nothing on my system as it is not using the raid at all. The raid partition is ntfs and also hardware based. After all that it still won't go. I opened up the initrd image and looked at the init script. It would seem that the lvm vgscan command runs and returns the initial error that the vg cannot be found. SO I've given up on LVM with F7 now. I'm now re-installing with a regular ext3 partition for root. That's too bad as I'd have liked the flexibility and it certainly doesn't bode well that such a serious bug has remained even though there seems to be awareness of it many months ago. Oh well. Life goes on. I'll see if the new ext3 partition works fine.
Chris :)

ChrisSavery
27th October 2007, 08:40 AM
Final report...
Installed on etc3 partition and it still wouldn't boot. Used the rescue disk to check fstab and saw that it was using LABEL= on the partitions. Changed those to just reference the dev name like /dev/sdc2. Restarted and it all came up ok. Weird. I don't know why that is the way it installed but I have to say it ought to work on the first boot. Sad, but anyway after much work it actually boots ok. Now into figuring out this desktop stuff.
Cheers,
Chris :)

stevea
27th October 2007, 04:29 PM
1/ You seem too anxious to re-install. The fact that you report different results after a re-install sounds suspiciously like pilot error.
2/ Next time post the actual error message. LIke the kernel panic msg.
3/ It is completely impossible that changing fstab had any impact on the kernel panic'ing on not finding root. The kernel doesn't use fstab to find root, that comes much later. I believe pravuil is right and the mkinitrd was the solution to the original problem.

If I were you I'd check the labels on the partitions

e2label /dev/sda1
for example, and re-introduce labels to the /etc/fstab

ChrisSavery
27th October 2007, 05:20 PM
Hmmm. Anxious to reinstall, not at all. I had spent 3 days on trying to get a properly booting system. Long days, not just a few hours each day. And you must be wrong about fstab not mattering because it very much did matter. But after changing fstab you do have to mkinitrd again so that the info is stored in the initrd image. I'll tell you that during the last install I changed the default root partition to be an ext3 instead of lvm. And manually added a swap partiion just above it. Upon booting it had a message saying that it was looking for and could not find the partition "LABEL=root". I saw that in the fstab file it had a "LABEL=/" instead and presumed that it was getting buggered up on how it was trying to find the partition. I changed 3 lines in fstab to use /dev/sdc1, 2, and 3 instead and did mkinitrd again. Then rebooted and it came up fine. Theorize about what you think happened but if you were not here then you're doing just that. Also I did extract and look at the initrd image that was built on the previous install. The init script contained in it that runs after the kernel is loaded and goes through the process of changing to the new root partition. It has near the end a line that reads "lvm vgscan...etc". It was at that point that vgscan could not find the lvm partition. It may have also had to do with a LABEL not matching the correct name. That is related to the bug reported regarding mkinitrd not working correctly. Something in there is not right.

I've put together quite a few Linux servers over the last few years using Centos. Haven't had such behaviour and would have stuck with Centos if it wasn't that the libraries included are too old to successfully install Skype.

What gets me, coming from a Windows desktop to Linux is how people get so bent on spouting off that this is better over here on Linux. So far I just haven't seen it at all. There's all sorts of glitchy behaviour and even now I'm really thinking it's subpar. Just a small example - I'm using some file browser (like explorer, whatever the default one in F7 is) and every time I change folders it loses the widths of the columns I've set. I have to reposition them again every time. Thats' lame. Is there some way to make them stick where I put them? And why do windows keep opening in the top left corner. Thats' Lame too. They should remember their positions. They don't. Is there some hidden littel geek trick you have to do to make these things behave nicely? So far I haven't seen anything that this desktop does better than Windows. Well, other than at the command line. Thats nice, very nice compared to the DOS type one under Windows. But working on servers I have gotten comfrtable with that for some time now. I've made an investment now in getting this far and intend to stick it out for some time. I guess that's how people get so wrapped up in this - they invest far too much time and then feel they have to evangelize their position.

Also, BTW, how do I grab the error message from the boot screen and paste it into my windows machine downstairs? I'd have loved to do that. But I wasn't going to hand write and type it in.

pravuil
27th October 2007, 09:01 PM
What gets me, coming from a Windows desktop to Linux is how people get so bent on spouting off that this is better over here on Linux.

Yeah, once everything is configured properly, it runs great. Even better than Windows because it suits the individual's needs instead of having a company tell you what needs you have. The problem is getting there and either having the patience to do it yourself or having the money to have someone do it for you.


I've made an investment now in getting this far and intend to stick it out for some time. I guess that's how people get so wrapped up in this - they invest far too much time and then feel they have to evangelize their position.

Yeah, when you can honestly say you can do a clean install of Linux with all the programs you need and configure everything all under 1 hour it's better than sex.


If I were you I'd check the labels on the partitions

Unfortunately, if you didn't know the bug was there, no one would've bothered to check the labels because they would've appeared to look fine. That's not to mention that all other alternatives would've been exhausted before finding the real problem. I've been there and it wastes everybody's time. He provided enough information in the OP. It's a common bug, and the fix is using a technique the installation procedure uses anyways.

Hopefully they fix this in the next upgrade. 12 more days until it comes out. ChrisSavery, think of f7 as a testing ground to help you get started. Hopefully, Fedora 8 should patch up this problem and make things easier.

About Nautilus, there is a patch here:

http://bugzilla.gnome.org/show_bug.cgi?id=410361#c6

But it's not a complete patch. Nautilus is supposed to have the column sizes fixed and reset by default. I think its dumb myself but for me it's something minor. Thunar can do this but it's for XCFE. You can install it in gnome but Nautilus is by far the better file manager.

ChrisSavery
28th October 2007, 06:30 AM
Thanks Pravuil. I'm not in the mood right now for recompiling Nautilus but it's good to know someday when I have time I can sit down and at least make it a bit better. I hope they do persist the column sizes someday, not just globally but per directory. And columns visible as well.

Right now I have more pressing work. Can you suggest a good editor for working with php, html, css files? I've used UltraEdit on WinXP and it's ok though not as good as some others (VC 6) I have used in the past. Ideally a good dev environment for doing C coding when I decide to do some programming under linux but for now just for some web dev work I need to get on with.

Well, onward. Installed VLC and watched a movie. That worked well.
Chris :)

pravuil
28th October 2007, 07:48 AM
It's hard to say which one would be better. I can give you a list.

VIM (vim-x11) /Xemacs has all the same features as UltraEdit but without a sleek ui. (VIM has a learning curve. vimtutor helps a bit)
Bluefish is more user friendly but lacks some features. It will work with php/css/html.
Eclipse is bloated (61 dependencies) but can handle pretty much anything. Just have to make sure you install the appropriate plugin. (eclipse-phpeclipse)

I use monodevelop, elcipse, text editors (vim, gedit, nano) and bluefish. Some work better for development while others work for general administrative tasks/updating. In the end I'd stick to bluefish.

ChrisSavery
28th October 2007, 08:09 AM
Thanks once again. I have some more questions about programming Linux but this isn't the place to start a new thread so I'll post in some other area.
Chris :)

fmartinez
30th October 2007, 03:21 AM
I've been using Quamtra Plus. Ii works similar to Dreamweaver. Hope this helps.