PDA

View Full Version : mount cdrom in linux rescue mode



jpcozar
26th October 2007, 05:30 PM
Hello everybody,
I got a Fedore Core 4, with a 2.6.11 x86_64 kernel.

I made an update of the kernel (rpm -ivh kernel-*) , with pre-compiled kernel (rpms packages: from http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/x86_64/)

kernel-2.6.17-1.2142_FC4.x86_64.rpm
kernel-devel-2.6.17-1.2142_FC4.x86_64.rpm
kernel-smp-2.6.17-1.2142_FC4.x86_64.rpm
kernel-smp-devel-2.6.17-1.2142_FC4.x86_64.rpm

so when I rebooted computer, FC4 doesn't start with no one new kernel (2.6.17 single and smp).
And naturally, old kernel (2.6.11) has vanished in /boot.

So I booted with FC4 DVD's and started in linux rescue mode. My partition was mounted in /mnt/sysimage, so I can access it.

I want to reinstall old kernel, via rpm, but I can't access to DVD-ROM (Fedora/RPMS/kernel-2.6.11)............

What can I do to no reinstall again FC4 and back to old kernel?
Thy in advance

daverj
26th October 2007, 06:52 PM
when you get to the partition mounted on /mnt/sysimage message, do this:


chroot /mnt/sysimage

then pop out the rescue disk and put the dvd in the cd drive. You should then be able to mount the cd drive and and install the kernal using rpm.


mount /dev/cdrom /mnt (hopefully this will work)
cd (to the directories with the kernal rpms you want)
rpm -Ivh (the packages you want)

after the kernal is installed, edit /boot/grub/grub.conf to add the new kernal

good luck,

davidj

edit:

when mounting you might have to specify the filesystem type:


mount -t iso9660 /dev/cdrom /mnt

jpcozar
27th October 2007, 12:17 PM
Thy daverj for your answer. It's the answer that everybody thinks when having to mount a cdrom, and I tried it before opening this thread :-). I have to tell you too, that it's the same DVD that I use to rescue, which has kernel files.

It's necessary to change two things in your answer:

1) There's no /dev/cdrom file when you boot in rescue mode. This sentence gives the following error:
mount /dev/cdrom /mnt => No such file or directory.

We must use: /dev/scd0

2) If you mount directly, in /mnt, you lose command shell. So we have to create a new directory, for instance:
mkdir /mnt/cdrom

So, it worked for me:

mount /dev/scd0 /mnt/cdrom

(without iso9660, no type of file to mount).