PDA

View Full Version : i got a error while i was installing update on myy fedora 7 please hlep



$Linux
26th October 2007, 02:18 AM
well i updateing my fedora 7

an i came across this error please help me

Missing Dependency: rpm = 4.4.2.1-1.fc7 is needed by package rpm-devel
Missing Dependency: rpm = 4.4.2.1-1.fc7 is needed by package rpm-libs

what can i do ??? :confused: :confused: :confused: :confused: :confused: :confused: hellp

JN4OldSchool
26th October 2007, 02:42 AM
either find package rpm.4.4.2-1.fc7 or skip updating rpm-devl and rpm-libs for now. No sweat either way.

JN4OldSchool
26th October 2007, 02:52 AM
just tried an update myself. rpm-4.4.2-2-fc7 is out now. Ironically I ran into a snag with the Firefox packages. I just unchecked FF and Epiphany and everything took for me. Just wait till morning to update if you cant figure it out. It will work itself out once all the updated packages hit the repos.

edit: BTW, I am backwards above. The problem is it doesnt want you to update rpm.4.4.2-2 because your older rpm-devl and rpm-libs rely on 4.4.2.1. Just uncheck any packages dealing with rpm and the rest should update fine.

$Linux
26th October 2007, 02:52 AM
either find package rpm.4.4.2-1.fc7 or skip updating rpm-devl and rpm-libs for now. No sweat either way.
so what can i do just do not update it an cancle it or something else to avoide the error

$Linux
26th October 2007, 02:54 AM
just tried an update myself. rpm-4.4.2-2-fc7 is out now. Ironically I ran into a snag with the Firefox packages. I just unchecked FF and Epiphany and everything took for me. Just wait till morning to update if you cant figure it out. It will work itself out once all the updated packages hit the repos.
ok i will take it to a simple way i will wait untill morning