PDA

View Full Version : Anaconda crash FC7: NEED HELP!!



bak16
25th October 2007, 10:23 PM
Hi guys!
I'm having a problem installing Fedora 7 on my pc...
I insert the DVD (x86 64) downloaded from official website.
I select the graphical mode (tried also the text mode) and it loads some drivers: fw_ohci ( :confused: ), nvidia_sata and pata_amd.
Everything is ok until Anaconda checks for previously installed distributions: Black screen (to main terminal) - it says:

(anaconda:822): HtmlUtil-CRITICAL **: html_stream_cancel: assertion 'stream->cancel_func != null' failed
install exited abnormally [1/1]
sending termination signals... etc...

I've absolutely no idea what's causing the error... I've just bought this new pc (on the old one I had FC6 working great, apart from the 800mhz cpu) here are the specs:

CPU AMD Athlon 64 X2 5600 (2 cores clocked 2800Mhz)
RAM 2GB DDR-2 800Mhz
1 SATA HDD 250GB
1 IDE HDD 40GB M
1 IDE DVD Burner drive
2 integrated NICs on ASUS MB M2N-SLI DELUXE
nVidia GeForce 8600GT

I've partitioned the 250GB HD into 4 pieces: 1 ntfs for XP; 2 250MB ext2 for GRUB; 3 3GB SWAP; 4 10GB ext3 for FC7...

...that's it... I need some help :D

brr872002
26th October 2007, 09:25 AM
Hi guys!
I'm having a problem installing Fedora 7 on my pc...
I insert the DVD (x86 64) downloaded from official website.
I select the graphical mode (tried also the text mode) and it loads some drivers: fw_ohci ( :confused: ), nvidia_sata and pata_amd.
Everything is ok until Anaconda checks for previously installed distributions: Black screen (to main terminal) - it says:

(anaconda:822): HtmlUtil-CRITICAL **: html_stream_cancel: assertion 'stream->cancel_func != null' failed
install exited abnormally [1/1]
sending termination signals... etc...

I've absolutely no idea what's causing the error... I've just bought this new pc (on the old one I had FC6 working great, apart from the 800mhz cpu) here are the specs:

CPU AMD Athlon 64 X2 5600 (2 cores clocked 2800Mhz)
RAM 2GB DDR-2 800Mhz
1 SATA HDD 250GB
1 IDE HDD 40GB M
1 IDE DVD Burner drive
2 integrated NICs on ASUS MB M2N-SLI DELUXE
nVidia GeForce 8600GT

I've partitioned the 250GB HD into 4 pieces: 1 ntfs for XP; 2 250MB ext2 for GRUB; 3 3GB SWAP; 4 10GB ext3 for FC7...

...that's it... I need some help :D

Try 32 bit version.

Post details of errors of other terminals.

Ctl+Atl+ F2
Ctl+Atl+ F3
Ctl+Atl+ F4
Ctl+Atl+ F5

bak16
30th October 2007, 08:35 PM
Is there a way to log and save the other terminals?? (the problem is that the system hangs and doesn't let you interact with terminals) Otherwise tell me and I'll post photos (how I reduce the character size on terminals?).

Haven't tried the 32bit version yet, but I'll prefer to have the 64.
Trying FC6 64 no X starts, in text mode same error as in F7.
Fedora 7.9 64 (8 beta1) same problem.
As I read on other forums that some people had same error message because of raid controllers' drivers, I tried the noprobe mode and used only the pata_amd driver (which includes IDE channels :confused: ) to get the DVD working: same problem.

I'm stuck