PDA

View Full Version : need help on playing avi files



too_pac
25th October 2007, 07:50 PM
i've tried playing avi files on vlc player which i have downloaded all the required files and the player immediately shuts down before playing the avi file
the same thing happened with xine and mplayer
when i try playing the video using terminal
audio can be heard but no video available
below is the message displayed after running the player through terminal



Playing [DB]_Bleach_144_[BD8CEA9A].avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
AVI: ODML: Building ODML index (2 superindexchunks).
VIDEO: [XVID] 640x480 12bpp 23.976 fps 855.4 kbps (104.4 kbyte/s)
Clip info:
Software: Windows Movie Maker 2.1
================================================== ========================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
================================================== ========================
================================================== ========================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
================================================== ========================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 640 x 480 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 640x480 => 640x480 Planar YV12
X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0
X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0
X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0
X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0
X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0
X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0
X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0
X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0
X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0
X11 error: BadAlloc (insufficient resources for operation)0.9% 0 0
X11 error: BadAlloc (insufficient resources for operation)
X11 error: BadAlloc (insufficient resources for operation)0.9% 0 0
X11 error: BadAlloc (insufficient resources for operation)0.8% 0 0

Gnafu the Great
25th October 2007, 09:20 PM
What graphics card are you running? Could you post the contents of your /etc/X11/xorg.conf file?

too_pac
26th October 2007, 02:43 AM
i'm currently using Intel Graphics Media Accelerator 900 on my fedora 7 and here is the content of my xorg.conf file


# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "intel"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

newprice
1st November 2007, 01:43 AM
yeah i seem to have the same problem! no matter what player i try it just shut down!


If anyone could help me with this it would be great!

Thanks!

Iron_Mike
1st November 2007, 01:56 AM
Seems you don't have the Codecs installed, do a search here for Codecs....

too_pac
21st January 2008, 11:15 AM
i dont think that codec is the problem because i've tried downloaded several codecs but the result would still be the same :(

daneel971
21st January 2008, 02:00 PM
It seems that compiz/beryl could be at fault for this.
Take a look at this:
http://readlist.com/lists/gentoo.org/gentoo-user/18/94232.html

leigh123linux
21st January 2008, 02:55 PM
Try changing the default depth to 16




Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

too_pac
22nd January 2008, 08:01 AM
can anyone teach me how to change the default deph since i am not that good in using terminal and i cant change it with the file browser

leigh123linux
22nd January 2008, 08:12 AM
Try changing the default depth to 16




Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

To edit xorg.conf try ( This will open a gedit gui with root permissions so you can edit the file )



su
gedit /etc/X11/xorg.conf

too_pac
23rd January 2008, 05:06 AM
i've tried changing the default depth but the output is still the same :(