View Full Version : Problem with latest F 8 test 3 update

25th October 2007, 02:49 AM
Been running F 8 test 3 for some weeks now with no major issues I couldn't deal with until now ...

Latest update resulted in the following message which prevented the update completing :

Package python-2.5.1-13.fc8.i386.rpm is not signed

No problem me thinks - I'll just not update the package, so I deleted it from the list and hit update again.

This resulted in the following message:

Package kernel-devel- is not signed

Any suggestions ?

Thanks Tim

25th October 2007, 03:05 AM
I've seen at least two other posts asking the same thing and one included the work-around. I'm too lazy to find them again, so I'll leave it to you. I'd also report it to the developers to sort out. To be honest, if you are not able to work out how to 'fix' this then you really shouldn't be using beta software.


25th October 2007, 03:06 AM
Yes, I think the ywere f'ing with the repos this afternoon. I had a long list of packages which were failing due to erroneous interdependencies inncluding some circular dependencies that included firefox. Suddenly, on a retry I got a much shorter list from 'yum check-update' and many items were unsigned. 'yum -y --nogpgcheck update' suddenly worked tho.

I'm beginning to believe that yum dependency problems in the repos will be the death of fedora. I get regular problems, esp on the -devel packages, on f7 and f8.t3.

25th October 2007, 03:09 AM
I'm having a missing dependency (Fedora 7) I'll just wait for a while, no biggie.


25th October 2007, 03:14 AM
Hi Wayne,
Thanks for the prompt response - shame it wasn't a little more friendly :-(
I had performed a search and tried the usual fixes such as excluding the offending packages / repos.

I've been using Fedora since FC2 and enjoy the challenge of using beta releases with all of its attendant problems - more fun than just simply installing a proven package. If I'd wanted to that then M$ would be my preference.

Further even though I'm no expert, I'd like to think that even beginners like myself can add value as surely the goal is to have a wide base of users not just experts ?

None the less I'll push on and fix this one myself, like I've done many times in the past - and report back for the benefit of others like myself who shouldn't be using beta releases !

25th October 2007, 03:16 AM
I'm having a bad hair day :) Try this:

yum update --nogpgcheck

No guarantees


25th October 2007, 03:26 AM
Hello timf911:
You should ease off on the harsh comments. :)
Since you have been using Fedora from FC2, hopefully you should know, that this is just a users helping users forum.

That being said, any Rawhide or Test version that is available for download [which many do] requires some onus upon the user to communicate the issues with the developers.
Communicating and Getting Help (http://fedoraproject.org/wiki/Communicate)
The Developers do not monitor this forum.
You may or may not get some assistance here, however, the best place to solve Beta issues is following the instructions provided in the above link.

If you run into bugs / issues with Rawhide or a Test, please file a bug, as that way it will be at least on the developers agenda.


25th October 2007, 03:30 AM
Nah, he's right, I'm a bit testy this morning. The pint of caffeine hasn't kicked in yet and I'm not my usual cheery self :) Lovely Autumn morning though.


25th October 2007, 03:40 AM
Hi Wayne, Seve

Yeah and I'm tired / lazy hence my original question - just got home after being evacuated due to wild fires and thought I'd relax by updating my linux box.

Either way I know it'll come right after a good nights rest.

FYI being a novice I prefer forums like this rather than more advanced groups - although to date I've been a lurker, suspect my first post should have been a little more challenging to the assembled brain power here.

Regards Tim

25th October 2007, 03:45 AM
I've been looking at that on the goggle box! I don't envy you one bit! I can't begin to imagine what it would be like to lose your home to fire, or any other disaster (Here it's quakes) :eek:

Back on topic, how did that command go?

As for challenging, I'd prefer you keep it simple, brain isn't in gear yet :)


25th October 2007, 03:50 AM
Hello timf911:

Wayne has all the brain power.. I have none :)

Sorry to hear about the fires, from what I've see on the TV it's really bad. Some of my relatives have already lost all their property and had to flee.
Hope everyone gets through it unharmed.

And if you have issues or problems, don't be hesitant to post and ask. There is such a wealth of knowledge here, thanks to all the members that pitch in. :)


26th October 2007, 06:31 AM
They released an RPM that enabled the Fedora and the updates repo. you just need o disable these and enable the development repo than your back in business.