PDA

View Full Version : making compiz-fusion work



indietrash
16th October 2007, 05:40 PM
I was trying to follow the "official" way, recommended by compiz-fusion.org - http://wiki.kagesenshi.org/moin.fcgi/CategoryPackages/CompizFusion

I was able to install compiz-kde, compiz-fusion-plugins-main and compiz-fusion-plugins-extra.
however - compizconfig-settings-manager and fusion-icon-qt would not install.
when I start it via "Compiz Fusion Icon", the toolbar disappears, like I'm used to with compiz. other than that nothing really happens. and what I in fact want is to be able to customize compiz-fusion, and I am under the impression that I am supposed to be able to do this. of course, I don't know for 100% as I have never used compiz-fusion; only beryl on FC6.

so, what I want to know is - how do I get this working? and perhaps even more importantly, what am I to do with my graphics card? I am sure I have to install some drivers, but which? I have a Asus GeForce 7600, and I am using the livna.org rpm in addition to the usual.

please help. I am indeed a newbie both when it comes to Fedora 7, compiz-fusion and graphics cards with nVidia chipset. it's actually only used any of the beforehand mentioned for two days now.



p.s.
I don't know if this is relevant or not, but I installed the beryl manager, and errr... whenever I try to start it everything freezes up, and the screen gets this nice very light greyish colour, and I have to restart X.

FriedChips
16th October 2007, 06:05 PM
su -
yum install kmod-nvidia
should take care of graphics card drivers, also you cannot use beryl with compiz-fusion they are not compatible, you must remove any compiz or beryl you may have previously had installed. Usually fedora ships with compiz by default. You see it in your menu as "Desktop Effects"

indietrash
16th October 2007, 06:22 PM
I don't use GNOME (I have KDE, XFCE and hackedbox, but mostly use KDE), so I don't think I have that in the menu. I did not install any compiz by default (I chose not too, knowing I would like to have compiz-fusion), only the beryl-manager. this I can remove, no problem.

and as mentioned - I can't install the manager.

thanks for your help so far.

jbkt23
16th October 2007, 06:35 PM
You need the emerald theme for compiz-fusion also available from the kagensenshi repo. Go to firewings blog for a good howto on getting things working. There is a link from the howto's forum on this forum. If you do a search at the top level for compiz-fusion you should get a result that includes it.

indietrash
16th October 2007, 06:58 PM
thank you ever so much. I will look into that asap, and let you know how it went. but first, I'm off to cut my hair ;)
once again - thanks heaps :)

leigh123linux
16th October 2007, 07:54 PM
I was trying to follow the "official" way, recommended by compiz-fusion.org - http://wiki.kagesenshi.org/moin.fcgi/CategoryPackages/CompizFusion

I was able to install compiz-kde, compiz-fusion-plugins-main and compiz-fusion-plugins-extra.
however - compizconfig-settings-manager and fusion-icon-qt would not install.
when I start it via "Compiz Fusion Icon", the toolbar disappears, like I'm used to with compiz. other than that nothing really happens. and what I in fact want is to be able to customize compiz-fusion, and I am under the impression that I am supposed to be able to do this. of course, I don't know for 100% as I have never used compiz-fusion; only beryl on FC6.

so, what I want to know is - how do I get this working? and perhaps even more importantly, what am I to do with my graphics card? I am sure I have to install some drivers, but which? I have a Asus GeForce 7600, and I am using the livna.org rpm in addition to the usual.

please help. I am indeed a newbie both when it comes to Fedora 7, compiz-fusion and graphics cards with nVidia chipset. it's actually only used any of the beforehand mentioned for two days now.



p.s.
I don't know if this is relevant or not, but I installed the beryl manager, and errr... whenever I try to start it everything freezes up, and the screen gets this nice very light greyish colour, and I have to restart X.


"compizconfig-settings-manager" was replaced by the package "ccsm"


Installed Packages
ccsm.noarch 0.6.0-99.fc8 installed
compiz.x86_64 0.6.0-99.fc8 installed
compiz-all.x86_64 0.6.0-99.fc8 installed
compiz-bcop.noarch 0.6.0-99.fc8 installed
compiz-devel.x86_64 0.6.0-99.fc8 installed
compiz-fusion-plugins-extra.x86_64 0.6.0-99.fc8 installed
compiz-fusion-plugins-main.x86_64 0.6.0-99.fc8 installed
compiz-fusion-plugins-main-devel.x86_64 0.6.0-99.fc8 installed
compiz-fusion-plugins-unsupported.x86_64 0.6.0-99.fc8 installed
compiz-gnome.x86_64 0.6.0-99.fc8 installed
compiz-kde.x86_64 0.6.0-99.fc8 installed
compizconfig-backend-gconf.x86_64 0.6.0-99.fc8 installed
compizconfig-backend-kconfig.x86_64 0.6.0-99.fc8 installed
compizconfig-python.x86_64 0.6.0-99.fc8 installed
compizconfig-python-devel.x86_64 0.6.0-99.fc8 installed
emerald.x86_64 0.6.0-99.fc8 installed
emerald-devel.x86_64 0.6.0-99.fc8 installed
emerald-themes.noarch 0.6.0-99.fc8 installed
fusion-icon.noarch 0.1-99.fc8 installed
fusion-icon-all.noarch 0.1-99.fc8 installed
fusion-icon-gtk.noarch 0.1-99.fc8 installed
fusion-icon-qt.noarch 0.1-99.fc8 installed
libcompizconfig.x86_64 0.6.0-99.fc8 installed
libcompizconfig-devel.x86_64 0.6.0-99.fc8 installed

indietrash
16th October 2007, 09:20 PM
thank you all for your help. I have no installed everything. I am reluctant to test it right now because I'm running a hackedbox session with the root user, where I'm copying some files off of my old computer via sftp, and I don't wanna risk crashing the computer, heh.
but I'll test this asap and get back to you once again.

really, thanks heaps people :)

indietrash
16th October 2007, 10:51 PM
two questions.

1. isn't there any way to start ccsm other than via the terminal/run program
2. is there any way to autostart it, when logging on, except making shellscripts and placing in my KDE autostart folder? and if I have to make shellscripts, what would they look like? one for emerald and one for compiz?

sorry if these questions come across as stupid :p
thanks for all your help thus far though. at least it's working, eh?

hiberphoptik
16th October 2007, 10:54 PM
hmmm i still have yet to see anyone actually put the RPMs for .6 in a repo where lazy people like me can just do an update without fuss....

indietrash
17th October 2007, 11:20 AM
right, I fixed symbolic links to make'em autostart. no problem really.

indietrash
18th October 2007, 09:59 PM
NEW PROBLEM:
trailfocus.
it seems to be disabling itself automatically or something. I enter ccsm, activate it - voila, all the windows go 39% (brightness, opacity and saturation). I click the semi-transparent windows. they don't ever get transparent again. I enter ccsm again, and it says 60% opacity, 100% brightness and 40% saturation (this was default), but not even this does anything until I deselect trailfocus and enable it again. but whenever I click the semi-transparent windows, trailfocus seems to be disabled.