PDA

View Full Version : Changes to FAT32 aren't seen by Windows



dunk
15th October 2007, 09:17 PM
I've mounted a FAT32 partition on a multiboot system that has Fedora Linux and various versions of Windows. I can make changes to the data on the FAT partition under Linux and they are retained when I unmount and remount the volume but they don't show up under Windows. Changes to existing files don't show up and new files don't appear. Changes that I make under Windows do show up when I boot into Linux. I've used other versions of Linux before and never observed this behaviour. I'm using a simple mount line:

mount /dev/sda1 /mnt/tmp

This succeeds. I've also tried:

mount -t vfat /dev/sda1 /mnt/tmp

but the results are the same. Any idea what the problem is? Thanks

tashirosgt
15th October 2007, 11:19 PM
Could you give an example of a change that you make under Windows that doesn't show up in Windows but does show up when you boot into Linux?

dunk
16th October 2007, 12:19 AM
I do:

mount /dev/sda1 /mnt/tmp
ls /boot > /mnt/tmp/boot/grub/ls.txt


this shows the expected result under Linux: a file in the boot/grub directory on the FAT32 filesystem. The file doesn't show up under Windows. I also tried:

ls /boot >> /mnt/tmp/boot/grub/grub.conf

which appended the directory listing to the grub.conf file as viewed under Linux. But under Windows the file remains unaltered. To thicken the plot, when I edit the grub.conf file using vi under Linux, grub sees the changes but Windows does not.

tashirosgt
16th October 2007, 04:31 PM
Could Windows be seeing some filesystem that is a duplicate of the one you are using in Linux?

dunk
16th October 2007, 04:53 PM
It's definitely looking at the same filesystem. I checked this by creating files under Windows and checking to see if they're there under Linux. They are. The failure happens when I create or alter files under Linux. The changes don't show up under Windows.

tashirosgt
16th October 2007, 06:09 PM
This is a very strange problem, I can only make some random guesses about it.
Does the windows implementation of FAT refuse to display file names with lower case letters or more than three character extensions? Do the files created under Linux have unusual permissions or attributes? Could they be "hidden" files when Windows looks at them? (Which version of Windows are you using, by the way?)

dunk
16th October 2007, 10:17 PM
Problem solved! Turned out it's not a good idea to hibernate XP and then expect new files to show up when you boot back into it. The same problem happened when I tried creating files under Windows 98 and then going back into XP. Must be a disk caching thing. Thanks for your help.