PDA

View Full Version : Another Wireless Issue



sddmack
14th October 2007, 10:34 PM
Toshiba Satellite M55
Fedora 7

trying to setup a wireless connection to a Lynksys Wireless G Router. It worked fine on my home one which is not secure. This router however is secured using WEP 128. I used Netork Manager to set it up (entered the encryption key data) but there's no entry for the Linksys passphrase and I cannot get a connection.

Any ideas? Thanks

PhillyFloyd
14th October 2007, 11:15 PM
You can set it up manually by editing the pertinent files (/etc/modprobe.conf, /etc/sysconfig/network-scripts/ifcfg-eth#, /etc/sysconfig/network-scripts/keys-eth#) I find it easier to have my home wireless as ifcfg-eth1, then when I am on the road, I just launch network-manager manually .... the only thing you need to watch for is how network-manager overwrites your resolv.conf, make sure it has the IP of your router, otherwise you won't be able to resolve names, i.e. www.yahoo.com won't work, you would have to enter the IPADDR

sddmack
14th October 2007, 11:25 PM
Thankyou for the quick response. I can only find the modprobe.conf file and it reads:

alias scsi_hostadapter ata_piix
alias scsi_hostadapter1 usb-storage
remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-hda-intel
alias eth1 sky2
alias eth0 sky2
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
options snd cards_limit=8
alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0
alias snd-card-1 snd-intel8x0m
options snd-intel8x0m index=1
alias snd-card-7 snd-usb-audio
options snd-usb-audio index=7


Not sure what it should say as I usually just use Network Manager. That and it's been 4 months since I set it up on a unsecure router and forgot the file the listed the router data.

stevea
14th October 2007, 11:42 PM
Don't touch modeprobe.cof - it's for kernel module installation.

Left click the NM icon, click "connect to other wireless network", select the network name (preferrable the ESSID) and the "WEP 128 bit passphrase. Fill in the passphrase and select "shared key". No there is not a separate passphase & key from the client. Some servers ise the passphrase to generate keys.

sddmack
14th October 2007, 11:58 PM
I guess I was wrong earlier...I was using the Network Configuration under system/administration/Network. I don't have an NM icon. Do I need to go get Network Manager or is it the same thing?

PhillyFloyd
15th October 2007, 12:12 AM
Don't touch modeprobe.cof - it's for kernel module installation.

Left click the NM icon, click "connect to other wireless network", select the network name (preferrable the ESSID) and the "WEP 128 bit passphrase. Fill in the passphrase and select "shared key". No there is not a separate passphase & key from the client. Some servers ise the passphrase to generate keys.


And if s/he didn't have the kernel module configured to the correct interface it wouldn't work no matter how many times you enter the WEP passphrase into Network-Manager -- was trying to troubleshoot from the beginning, rather than jumping to a frontend application without knowing what the problem is....

Glad you got it working though ;-)

sddmack
15th October 2007, 12:28 AM
Thanks for all the help from both of you. I just enabled Network Manager.

# su -c '/sbin/chkconfig --level 345 NetworkManager on'

#su -c '/sbin/chkconfig --level 345 NetworkManagerDispatcher on'

#su -c '/sbin/service NetworkManager start ; /sbin/service NetworkManagerDispatcher start'

Then just added the "other wireless network.

I am still new at this.