PDA

View Full Version : GCC, is it necessary?



exutable
14th October 2007, 09:55 PM
Hey I am making my own server on a Linux Fedora 7 box. I am installing VSFTPD and following the installation documentation when I get to this:

[root@localhost vsftpd-2.0.5]# make
gcc -c main.c -O2 -Wall -W -Wshadow -idirafter dummyinc
make: gcc: Command not found
make: *** [main.o] Error 127
[root@localhost vsftpd-2.0.5]#


So I think "oh it is probably an easy fix", well the documentation on how to install GCC is impossible and is completely out of the way.

Is there anyway to avoid using gcc or any way I can bypass it?

spartas
14th October 2007, 10:01 PM
Any reason you aren't just installing vsftpd from the yum repo?
# yum install vsftpd

exutable
14th October 2007, 10:29 PM
Alright I tried that.

[root@localhost vsftpd-2.0.5]# yum install vsftpd
Loading "installonlyn" plugin
Setting up Install Process
Parsing package install arguments
fedora 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 3.8 MB 00:02
updates 100% |=========================| 2.3 kB 00:00
Nothing to do
[root@localhost vsftpd-2.0.5]#


what does this mean? Where is it installed? Sorry I am normally a windows user so I get really confused with this.

stevea
14th October 2007, 11:16 PM
type
rpm -ql vsftpd
to see where

PhillyFloyd
14th October 2007, 11:17 PM
try:

yum search vsftp

if it returns something, then your repos are setup ok and try:

yum install vsftp*

PilotJLR
14th October 2007, 11:17 PM
It's probably already installed then...
To check, do this as root:


rpm -qa | grep vsftpd

If you get output from this command, then it's installed.
You can start it with:


service vsftpd start

vinbob
14th October 2007, 11:27 PM
By the way GCC is the GNU C Compiler so if you want to compile any C source code or install anything that needs to compile a kernel module (e.g Virtualbox, VMWare) you need GCC installed.

If you're setting up a server I'd recommend installing gcc & the kernel source packages, you'll probably need them at some point.
To install these do the following as root in a terminal...

yum install gcc kernel-devel
Also a tip... the whereis command can be very handy and is available on all Unix systems.

exutable
15th October 2007, 04:00 AM
Ok sorry I got past the issue with it not registering the config file, but now I have yet another problem. I can finally see the light at the end of the tunnel but this is standing in the way.

Starting vsftpd for vsftpd: [ OK ]
[root@localhost ~]# ftp 192.168.1.115
Connected to 192.168.1.115 (192.168.1.115).
220 (vsFTPd 2.0.5)
Name (192.168.1.115:SRCDS): anonymous
331 Please specify the password.
Password:
500 OOPS: cannot change directory:/home/SRCDS/srcds/cstrike/logs
Login failed.
ftp>


Once I get this working will other computers connect to it via my external ip?

clearer
15th October 2007, 04:49 AM
The short answer to that is: maybe. It all depends on how your network is setup. Stuff like firewalls, routers and NATs can prevent this -- some of them may not be under your control and in such cases there is very little you can do about it, except yell really loud at the people who do control them.

exutable
15th October 2007, 11:08 PM
Hmm you sure I would think it has something to do with the settings?

If so is there anything I should do with the router? I have already turned off all firewall stuf!

To Clearer: Hvad sker der i Odense? Boede engang i Danmark! Hvad arbejder du som?

airtonarantes
25th October 2007, 05:18 PM
exutable, yum install gcc.i386 gcc-c++.i386 command probably will go to resolve your problem with gcc.

and vinbob, GCC means GNU Compiler Collection

thanks.