PDA

View Full Version : Error updating rpm using yum



bwithers
13th October 2007, 04:34 AM
yum update
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package hplip.x86_64 0:1.7.4a-6.fc7 set to be updated
---> Package rpm-build.x86_64 0:4.4.2.1-1.fc7 set to be updated
---> Package libsane-hpaio.x86_64 0:1.7.4a-6.fc7 set to be updated
---> Package popt.i386 0:1.10.2.1-1.fc7 set to be updated
---> Package rpm-devel.i386 0:4.4.2.1-1.fc7 set to be updated
---> Package rpm-devel.x86_64 0:4.4.2.1-1.fc7 set to be updated
---> Package rpm-python.x86_64 0:4.4.2.1-1.fc7 set to be updated
---> Package hpijs.x86_64 1:1.7.4a-6.fc7 set to be updated
---> Package rpm.x86_64 0:4.4.2.1-1.fc7 set to be updated
---> Package rpm-libs.x86_64 0:4.4.2.1-1.fc7 set to be updated
---> Package rpm-libs.i386 0:4.4.2.1-1.fc7 set to be updated
---> Package hpijs.i386 1:1.7.4a-6.fc7 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Updating:
hplip x86_64 1.7.4a-6.fc7 updates 9.7 M
libsane-hpaio x86_64 1.7.4a-6.fc7 updates 64 k
rpm-build x86_64 4.4.2.1-1.fc7 updates 623 k
rpm-devel i386 4.4.2.1-1.fc7 updates 5.4 M
rpm-devel x86_64 4.4.2.1-1.fc7 updates 5.5 M
rpm-libs x86_64 4.4.2.1-1.fc7 updates 920 k
rpm-libs i386 4.4.2.1-1.fc7 updates 930 k
rpm-python x86_64 4.4.2.1-1.fc7 updates 58 k
Updating for dependencies:
hpijs x86_64 1:1.7.4a-6.fc7 updates 291 k
hpijs i386 1:1.7.4a-6.fc7 updates 293 k
popt i386 1.10.2.1-1.fc7 updates 70 k
rpm x86_64 4.4.2.1-1.fc7 updates 1.1 M

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 12 Package(s)
Remove 0 Package(s)

Total download size: 25 M
Is this ok [y/N]: y
Downloading Packages:
(1/4): hpijs-1.7.4a-6.fc7 100% |=========================| 293 kB 00:00
(2/4): hpijs-1.7.4a-6.fc7 100% |=========================| 291 kB 00:00
(3/4): libsane-hpaio-1.7. 100% |=========================| 64 kB 00:00
(4/4): hplip-1.7.4a-6.fc7 100% |=========================| 9.7 MB 00:08
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
file /usr/include/popt.h from install of popt-1.10.2.1-1.fc7 conflicts with file from package popt-1.10.2-46.fc7

Error Summary
-------------

Zotter
13th October 2007, 04:36 AM
rpm -e popt

Re-run the update, then when done

yum install popt

That should do ya.

bwithers
13th October 2007, 05:07 AM
That is a good suggestion. I just tried that command (with the --allmatches flag)
I'm worried that if I do a force erase, that this could cause rpm and hence yum to longer be able to install anything. Should I just leave it alone and not update it? Here is the error message btw:

rpm -e popt --allmatches
error: Failed dependencies:
libpopt.so.0()(64bit) is needed by (installed) rpm-4.4.2-46.fc7.x86_64
libpopt.so.0()(64bit) is needed by (installed) gphoto2-2.3.1-5.fc7.x86_64
libpopt.so.0()(64bit) is needed by (installed) rpm-libs-4.4.2-46.fc7.x86_64
...