PDA

View Full Version : RhythmBox no m4a but I have plugins installed



mckechan
12th October 2007, 12:52 PM
Hi,

I run FC6. I think I have all the required plugins for m4a but Rhythm Box won't play them.

Any help much appreciated.

Cheers

$Linux
12th October 2007, 05:22 PM
Hi,

I run FC6. I think I have all the required plugins for m4a but Rhythm Box won't play them.

Any help much appreciated.

Cheers


well if you want some good plugins then go to this link i am giving
you

http://www.freewebs.com/dnmouse/index.htm

have fun if you need help then tell me . ;)

hammel
12th October 2007, 05:28 PM
if livna-repo enabled run as root:

# yum -y install gstreamer-ffmpeg gstreamer-plugins-ugly gstreamer-plugins-bad

mckechan
15th October 2007, 11:22 AM
Well I already have these packages installed but I think not the right versions.

This is the output I get:


[root@compubot ~]# yum -y install gstreamer-ffmpeg gstreamer-plugins-ugly gstreamer-plugins-bad --enablerepo=livna
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages from Livna for Fedora Core 6 - i386 - Base
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gstreamer-ffmpeg.i386 0:0.10.2-2.lvn6 set to be updated
--> Running transaction check
--> Processing Dependency: libpostproc.so.51 for package: gstreamer-ffmpeg
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package ffmpeg-libs.i386 0:0.4.9-0.37.20070503.lvn6 set to be updated
--> Running transaction check
--> Processing Dependency: faad2 < 2.5 for package: ffmpeg-libs
--> Finished Dependency Resolution
Error: Missing Dependency: faad2 < 2.5 is needed by package ffmpeg-libs
[root@compubot ~]#

hammel
15th October 2007, 11:37 AM
hmmm? maybe try to install each package manually and see what remains? or thake the faad2 frome elsewhere, maybe here: http://dries.ulyssis.org/rpm/packages/faad2/info.html

mckechan
15th October 2007, 11:46 AM
[root@compubot ~]# yum -y install gstreamer-plugins-ugly gstreamer-plugins-bad --enablerepo=livna
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages from Livna for Fedora Core 6 - i386 - Base
Finished
Parsing package install arguments
Nothing to do
[root@compubot ~]#




[root@compubot ~]# yum -y install gstreamer-ffmpeg --enablerepo=livna
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages from Livna for Fedora Core 6 - i386 - Base
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gstreamer-ffmpeg.i386 0:0.10.2-2.lvn6 set to be updated
--> Running transaction check
--> Processing Dependency: libpostproc.so.51 for package: gstreamer-ffmpeg
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package ffmpeg-libs.i386 0:0.4.9-0.37.20070503.lvn6 set to be updated
--> Running transaction check
--> Processing Dependency: faad2 < 2.5 for package: ffmpeg-libs
--> Finished Dependency Resolution
Error: Missing Dependency: faad2 < 2.5 is needed by package ffmpeg-libs


I can't find a version on that page for fc6 that is less than ver 2.5

leigh123linux
15th October 2007, 11:51 AM
Someones mixed there repos :(

Try removing faad2 first then try again

mckechan
15th October 2007, 12:04 PM
Er, so when should i enable livna-repo



[root@compubot ~]# yum remove faad2
Loading "installonlyn" plugin
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package faad2.i386 0:2.5-2.fc6 set to be erased
--> Running transaction check
Setting up repositories
adobe-linux-i386 100% |=========================| 951 B 00:00
updates 100% |=========================| 1.2 kB 00:00
core 100% |=========================| 1.1 kB 00:00
freshrpms 100% |=========================| 2.1 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
--> Processing Dependency: faad2 = 2.5 for package: xmms-aac
--> Processing Dependency: libfaad.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libfaad.so.0 for package: xmms-aac
--> Processing Dependency: libfaad.so.0 for package: ffmpeg
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package xmms-aac.i386 0:2.5-1.fc6 set to be erased
---> Package ffmpeg.i386 0:0.4.9-0.8.20070109.fc6 set to be erased
---> Package gstreamer-plugins-bad.i386 0:0.10.3-3.lvn6 set to be erased
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Removing:
faad2 i386 2.5-2.fc6 installed 315 k
Removing for dependencies:
ffmpeg i386 0.4.9-0.8.20070109.fc6 installed 5.6 M
gstreamer-plugins-bad i386 0.10.3-3.lvn6 installed 730 k
xmms-aac i386 2.5-1.fc6 installed 46 k

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 0 Package(s)
Remove 4 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Removing : xmms-aac ######################### [1/4]
Removing : ffmpeg ######################### [2/4]
Removing : faad2 ######################### [3/4]
Removing : gstreamer-plugins-bad ######################### [4/4]

Removed: faad2.i386 0:2.5-2.fc6
Dependency Removed: ffmpeg.i386 0:0.4.9-0.8.20070109.fc6 gstreamer-plugins-bad.i386 0:0.10.3-3.lvn6 xmms-aac.i386 0:2.5-1.fc6
Complete!




[root@compubot ~]# yum -y install gstreamer-ffmpeg gstreamer-plugins-ugly gstreamer-plugins-bad --enablerepo=livna
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
livna 100% |=========================| 2.1 kB 00:00
Reading repository metadata in from local files
Excluding Packages from Livna for Fedora Core 6 - i386 - Base
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gstreamer-ffmpeg.i386 0:0.10.2-2.lvn6 set to be updated
---> Downloading header for gstreamer-plugins-bad to pack into transaction set.
gstreamer-plugins-bad-0.1 100% |=========================| 12 kB 00:00
---> Package gstreamer-plugins-bad.i386 0:0.10.3-3.lvn6 set to be updated
--> Running transaction check
--> Processing Dependency: libavcodec.so.51 for package: gstreamer-ffmpeg
--> Processing Dependency: libfaad.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libpostproc.so.51 for package: gstreamer-ffmpeg
--> Processing Dependency: libavformat.so.51 for package: gstreamer-ffmpeg
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for ffmpeg to pack into transaction set.
ffmpeg-0.4.9-0.8.20070109 100% |=========================| 13 kB 00:00
---> Package ffmpeg.i386 0:0.4.9-0.8.20070109.fc6 set to be updated
---> Package ffmpeg-libs.i386 0:0.4.9-0.37.20070503.lvn6 set to be updated
---> Downloading header for faad2 to pack into transaction set.
faad2-2.5-2.fc6.i386.rpm 100% |=========================| 6.3 kB 00:00
---> Package faad2.i386 0:2.5-2.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: faad2 < 2.5 for package: ffmpeg-libs
--> Finished Dependency Resolution
Error: Missing Dependency: faad2 < 2.5 is needed by package ffmpeg-libs
[root@compubot ~]#

leigh123linux
15th October 2007, 12:28 PM
Try this


su
wget http://livna-dl.reloumirrors.net/fedora/6/i386/faad2-2.0-19.20050131.lvn6.i386.rpm
rpm -ivh faad2-2.0-19.20050131.lvn6.i386.rpm


and post any errors

mckechan
15th October 2007, 12:32 PM
That installed faad2 fine then:



[root@compubot ~]# yum -y install gstreamer-ffmpeg gstreamer-plugins-ugly gstreamer-plugins-bad --enablerepo=livna
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
livna 100% |=========================| 2.1 kB 00:00
adobe-linux-i386 100% |=========================| 951 B 00:00
updates 100% |=========================| 1.2 kB 00:00
core 100% |=========================| 1.1 kB 00:00
freshrpms 100% |=========================| 2.1 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Excluding Packages from Livna for Fedora Core 6 - i386 - Base
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gstreamer-ffmpeg.i386 0:0.10.2-2.lvn6 set to be updated
---> Package gstreamer-plugins-bad.i386 0:0.10.3-3.lvn6 set to be updated
--> Running transaction check
--> Processing Dependency: libavcodec.so.51 for package: gstreamer-ffmpeg
--> Processing Dependency: libpostproc.so.51 for package: gstreamer-ffmpeg
--> Processing Dependency: libavformat.so.51 for package: gstreamer-ffmpeg
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package ffmpeg.i386 0:0.4.9-0.8.20070109.fc6 set to be updated
---> Package ffmpeg-libs.i386 0:0.4.9-0.37.20070503.lvn6 set to be updated
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
gstreamer-plugins-bad i386 0.10.3-3.lvn6 livna 323 k
Updating:
gstreamer-ffmpeg i386 0.10.2-2.lvn6 livna 110 k
Installing for dependencies:
ffmpeg i386 0.4.9-0.8.20070109.fc6 freshrpms 2.0 M
ffmpeg-libs i386 0.4.9-0.37.20070503.lvn6 livna 1.6 M

Transaction Summary
================================================== ===========================
Install 3 Package(s)
Update 1 Package(s)
Remove 0 Package(s)

Total download size: 4.0 M
Downloading Packages:
(1/4): ffmpeg-0.4.9-0.8.2 100% |=========================| 2.0 MB 00:05
(2/4): ffmpeg-libs-0.4.9- 100% |=========================| 1.6 MB 00:02
(3/4): gstreamer-ffmpeg-0 100% |=========================| 110 kB 00:00
(4/4): gstreamer-plugins- 100% |=========================| 323 kB 00:00
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
file /usr/lib/libavcodec.so.51 conflicts between attempted installs of ffmpeg-libs-0.4.9-0.37.20070503.lvn6 and ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/libavformat.so.51 conflicts between attempted installs of ffmpeg-libs-0.4.9-0.37.20070503.lvn6 and ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/libavutil.so.49 conflicts between attempted installs of ffmpeg-libs-0.4.9-0.37.20070503.lvn6 and ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/vhook/drawtext.so conflicts between attempted installs of ffmpeg-libs-0.4.9-0.37.20070503.lvn6 and ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/vhook/fish.so conflicts between attempted installs of ffmpeg-libs-0.4.9-0.37.20070503.lvn6 and ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/vhook/imlib2.so conflicts between attempted installs of ffmpeg-libs-0.4.9-0.37.20070503.lvn6 and ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/vhook/null.so conflicts between attempted installs of ffmpeg-libs-0.4.9-0.37.20070503.lvn6 and ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/vhook/ppm.so conflicts between attempted installs of ffmpeg-libs-0.4.9-0.37.20070503.lvn6 and ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/vhook/watermark.so conflicts between attempted installs of ffmpeg-libs-0.4.9-0.37.20070503.lvn6 and ffmpeg-0.4.9-0.8.20070109.fc6

Error Summary
-------------

mckechan
15th October 2007, 12:34 PM
So do I need to disable fc6 repo to get this to work?

leigh123linux
15th October 2007, 12:43 PM
Ok try



su
wget http://livna-dl.reloumirrors.net/fedora/6/i386/ffmpeg-0.4.9-0.37.20070503.lvn6.i386.rpm
rpm -U --oldpackage ffmpeg-0.4.9-0.37.20070503.lvn6.i386.rpm

then try again

leigh123linux
15th October 2007, 12:44 PM
So do I need to disable fc6 repo to get this to work?


What repo's are you using ?

mckechan
15th October 2007, 02:02 PM
I don't know which ones are enabled by defuult but it looks like this is a problem between freshrpms and livna right?

These are the repos I have:

adobe-linux-i386.repo fedora-development.repo fedora-extras.repo fedora-updates.repo freshrpms.repo livna.repo
fedora-core.repo fedora-extras-development.repo fedora-legacy.repo fedora-updates-testing.repo livna-devel.repo livna-testing.repo

I think I disabled livna when I first had the faad2 problem.

leigh123linux
15th October 2007, 02:07 PM
I don't know which ones are enabled by defuult but it looks like this is a problem between freshrpms and livna right?

These are the repos I have:


I think I disabled livna when I first had the faad2 problem.

I not sure if FC6 had protectbase but give it a go ( you will need to activate both the livna and freshrpms repo's )



su -
yum install yum-protectbase
su -c 'perl -i -pe "s/(\[.*\])/\1\nprotect=yes/" /etc/yum.repos.d/{fedora*,livna*}'


Did you get gstreamer installed ?

mckechan
16th October 2007, 11:18 AM
Awesome! thanks.

I don't remember adding freshrpms but this is a nice fix!

mckechan
26th October 2007, 12:11 PM
On a system update I get the problem:


Missing Dependency: faad2 < 2.5 is needed by package ffmpeg-libs

AAAH!

mckechan
26th October 2007, 12:15 PM
I can just continue to ignore the faad2 update forever yeah?

leigh123linux
26th October 2007, 12:48 PM
I can just continue to ignore the faad2 update forever yeah?

Can you post the outputs from

su
yum update


and


rpm -qa --queryformat "%{NAME}-%{VERSION}-%{VENDOR}\n"|grep Freshrpms.net|sort


and


rpm -qa --queryformat "%{NAME}-%{VERSION}-%{VENDOR}\n"|grep livna|sort

mckechan
26th October 2007, 01:33 PM
It's my work computer that has the issue and I am at home now. I can't log in remotely either as they're switching off the power this wknd. I'll look on Monday.

Cheers

mckechan
29th October 2007, 03:59 PM
here you go:


yum update
Loading "installonlyn" plugin
Loading "protectbase" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
6 packages excluded due to repository protections
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package faad2.i386 0:2.5-2.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: faad2 < 2.5 for package: ffmpeg-libs
--> Finished Dependency Resolution
Error: Missing Dependency: faad2 < 2.5 is needed by package ffmpeg-libs


rpm -qa --queryformat "%{NAME}-%{VERSION}-%{VENDOR}\n"|grep Freshrpms.net|sort
amrnb-0.0.1-Freshrpms.net
audacious-plugins-extras-1.3.3-Freshrpms.net
freshrpms-release-1.1-Freshrpms.net
gstreamer-pitfdll-0.9.1.1-Freshrpms.net
gtkpod-0.99.8-Freshrpms.net
libfame-0.9.1-Freshrpms.net
libmp4v2-1.5.0.1-Freshrpms.net
libopendaap-0.4.0-Freshrpms.net
mplayer-1.0-Freshrpms.net
mplayer-docs-1.0-Freshrpms.net
mplayer-fonts-1.1-Freshrpms.net
mplayerplug-in-3.35-Freshrpms.net
mplayer-skins-1.8-Freshrpms.net
vcdimager-0.7.23-Freshrpms.net
x264-0.0.0-Freshrpms.net
xine-0.99.5-Freshrpms.net
xine-lib-moles-1.1.6-Freshrpms.net
xine-skins-1.10-Freshrpms.net
xmms-mp3-1.2.10-Freshrpms.net
xvidcore-1.1.3-Freshrpms.net



rpm -qa --queryformat "%{NAME}-%{VERSION}-%{VENDOR}\n"|grep livna|sort
audacity-nonfree-1.3.2-rpm.livna.org
ffmpeg-libs-0.4.9-rpm.livna.org
gstreamer-ffmpeg-0.10.2-rpm.livna.org
gstreamer-plugins-bad-0.10.3-rpm.livna.org
gstreamer-plugins-ugly-0.10.5-rpm.livna.org
lame-3.97-rpm.livna.org
lame-libs-3.97-rpm.livna.org
libdvdnav-0.1.10-rpm.livna.org
libmms-0.3-rpm.livna.org
livna-release-6-(none)


Cheers

leigh123linux
29th October 2007, 04:34 PM
here you go:







Cheers

Can you post

su
yum list faad2

mckechan
29th October 2007, 04:44 PM
Here it is:


yum list faad2
Loading "installonlyn" plugin
Loading "protectbase" plugin
Setting up repositories
adobe-linux-i386 100% |=========================| 951 B 00:00
updates 100% |=========================| 1.2 kB 00:00
core 100% |=========================| 1.1 kB 00:00
freshrpms 100% |=========================| 2.1 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
6 packages excluded due to repository protections
Installed Packages
faad2.i386 2.0-19.20050131.lvn6 installed
Available Packages
faad2.i386 2.5-2.fc6 freshrpms

leigh123linux
29th October 2007, 04:54 PM
Ok can you also post

su
yum list ffmpeg-libs

mckechan
29th October 2007, 05:03 PM
And here it is:


yum list ffmpeg-libs
Loading "installonlyn" plugin
Loading "protectbase" plugin
Setting up repositories
Reading repository metadata in from local files
6 packages excluded due to repository protections
Installed Packages
ffmpeg-libs.i386 0.4.9-0.37.20070503.lv installed

leigh123linux
29th October 2007, 05:34 PM
try

su
gedit /etc/yum.repos.d/*fresh*repo

and add this line

excludepkgs=faad2

i.e ( I haven't got the freshrpms.repo so I used livna just to show you where the line goes )


[livna]
name=Livna for Fedora Core $releasever - $basearch - Base
baseurl=
http://rpm.livna.org/fedora/$releasever/$basearch/
http://livna.cat.pdx.edu/fedora/$releasever/$basearch/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/
http://mirror.atrpms.net/livna/fedora/$releasever/$basearch/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/$basearch/
failovermethod=priority
#mirrorlist=http://rpm.livna.org/mirrorlist-7
enabled=0
excludepkgs=faad2
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna

mckechan
30th October 2007, 11:30 AM
Unfortunatley that doesn't work. Do i need to resource yum.repos.d somehow?


yum update
Loading "installonlyn" plugin
Loading "protectbase" plugin
Setting up Update Process
Setting up repositories
adobe-linux-i386 100% |=========================| 951 B 00:00
updates 100% |=========================| 1.2 kB 00:00
core 100% |=========================| 1.1 kB 00:00
freshrpms 100% |=========================| 2.1 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 1.7 MB 00:03
extras : ################################################## 5290/5290
6 packages excluded due to repository protections
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package faad2.i386 0:2.5-2.fc6 set to be updated
---> Downloading header for SILLY to pack into transaction set.
SILLY-0.1.0-4.fc6.i386.rp 100% |=========================| 3.6 kB 00:00
---> Package SILLY.i386 0:0.1.0-4.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: faad2 < 2.5 for package: ffmpeg-libs
--> Finished Dependency Resolution
Error: Missing Dependency: faad2 < 2.5 is needed by package ffmpeg-libs

leigh123linux
30th October 2007, 12:02 PM
Unfortunatley that doesn't work. Do i need to resource yum.repos.d somehow?


Try changing the line to

exclude=faad2