PDA

View Full Version : PCM Volume Won't Stick



dmbrown00
11th October 2007, 11:15 PM
When I change the volumes in GNOME's mixer, the PCM volume doesn't stay after I reboot. How can I make it stick?

Brian1
11th October 2007, 11:37 PM
I would open a terminal console and run the command ' alsamixer '. Then adjust to your perference. Exit and run this command as root. ' /sbin/alsactl store ' Common bug in Fedora and some sound cards.

Brian

dmbrown00
13th October 2007, 03:48 PM
No, that doesn't do it. It still resets.

RJFUatHOME
13th October 2007, 10:14 PM
Is this a new install? I ran into the same thing with a Fedora 7 test version but it was fixed after an install of the final version and running all the updates.

Make sure you install all the updates and see if the problem doesn't resolve itself.

dmbrown00
14th October 2007, 01:23 AM
I have all the updates. lspci identifies the card as an nVidia Corporation CK804 AC'97 Audio Controller (rev a2). It is on an ASUS motherboard.

RJFUatHOME
14th October 2007, 04:14 AM
There was a fix for this that worked in FC6, take a look in this thread towards the bottom.

http://forums.fedoraforum.org/forum/showthread.php?t=155002&highlight=PCM+volume

It's worth a shot.

Like I said updating fixed the issue for me or it plan disappeared when I installed the final release of Fedora 7 and updated including kernels.

Hope it helps.

robatino
14th October 2007, 02:51 PM
https://bugzilla.redhat.com/show_bug.cgi?id=247468

Try disabling nasd in System/Administration/Services.

Brian1
14th October 2007, 03:37 PM
That was my only fix. Worked for me for every Fedora install up to 6. not tried F7 yet.

Brian

RJFUatHOME
14th October 2007, 08:02 PM
robatino, what a long debug process!

I guess maybe it really didn't get fixed here, I simply disabled the NASD service after installing while disabling unneeded services. But disabling NASD did appear to stop the problem at least here.