PDA

View Full Version : RealPlayer Sound



sutra
8th October 2007, 08:03 AM
I have got Realplayer 10.0.9.809 working on F7 to deal with streaming audio/video from bbc.co.uk.
Curiously though I only get the sound when logged in as root. When not in root mode the player comes up and behaves normally except that there is no sound. Surely, there can't be a need for root privileges for simple player sound?
I've copied the Realplayer plugins across to Firefox and needed su access to do that, but then these changes should apply system-wide, should they not?
Suggestions much appreciated.

Wayne
8th October 2007, 08:29 AM
Same here (although I've never tried it as root) I never saw it as big enough of a problem so never investigated it :) If there's a cure, I suppose I'd maybe watch the BBC news too.

Edit: I edited the thread title to make the subject clearer.

Wayne

TheMatt
9th October 2007, 05:13 PM
OK, I think I have a workaround for this, but it wasn't fun. I too encountered this problem, which was compounded by my running an x86_64 box. So, what I did was after installing and the nspluginwrapper junk (not needed by a i386 user) was install alsa-oss. Then, if you edit line 73 of /usr/bin/realplay from:

$REALPLAYBIN "$@"
to:

aoss $REALPLAYBIN "$@" You should get audio now along with video.

But, on an x86_64 box, you must install alsa-oss as "yum install alsa-oss-libs.i386" since realplay doesn't like the 64bit one. I think. I have no idea. But, it works. Doing this will probably break aoss for everything else, but most software likes ALSA so it's no problem I think.

I'm hoping someone smarterer than I will figure out a less kludge-y way of doing this.

fyny
9th October 2007, 05:24 PM
i also faced same. i just went to hardware option frm preferances. and changed the pcm device option. prob solved.
u can try it also. dont forget to reply after test.
thanx.

sutra
9th October 2007, 09:35 PM
Thanks for the suggestions so far - I'll post results once I've had time to fiddle with it.

Wayne
10th October 2007, 02:05 AM
There's no option to change the PCM device on my 'Hardware' tab of RealPlayer preferences. Just 'Disable 16-bit sound' and 'Disable Custom Sampling Rates'

Wayne

Wayne
10th October 2007, 02:19 AM
That worked, thanks!

Wayne

sutra
10th October 2007, 11:06 PM
Not having much luck - maybe something I've overlooked to do with user-specific settings, unlikely though it sounds.
Editing that line results in the player not coming up at all...

TheMatt
10th October 2007, 11:14 PM
Not having much luck - maybe something I've overlooked to do with user-specific settings, unlikely though it sounds.
Editing that line results in the player not coming up at all...

Do you actually have aoss? If so, try doing an "aoss realplay somefile.ram" on the command line. What errors do you get?

sutra
11th October 2007, 07:36 AM
:)
Ah, yes.
Messrs Seagoon, Eccles, and Bluebottle are most grateful.

sutra
13th November 2007, 08:32 PM
Have just re-installed F7 along with RealPlayer 10.1.0.3707 (experimental)
Works with Firefox 2.0.0.9 without a hitch - no need to even fiddle with plugins.

theforest
13th November 2007, 09:25 PM
My Realplayer 10 Gold always sounded distorted, like it had an echo. I just downloaded the nightly 10.1.0.3710 and its working perfect. First time I have had RealPlayer working properly in Fedora 7.

stardust2008
25th January 2008, 05:00 PM
download the right package for your Fedora here.
http://rpm.livna.org/rlowiki/
install the rpm package.
restart your system, everything is ok
by the way you must install oss first.

hope this method works for you

fatpapa
28th February 2008, 10:54 AM
I have the same problem. I would like to use real player for the bbc web site.

When i open a terminal and type in aoss realplay somefile.ram realplayer opens the file no problem.

i get the message:

Warning: LD_PRELOAD="/usr/lib/libaoss.so.0"

Is there anyway i can get the bbc iplayer to work?

I use Ferdora 7

Thanks.