PDA

View Full Version : vsftpd/Samba and mounted partitions



sidd-ua
6th October 2007, 08:53 PM
I mount two partitions in "/mnt/Data1" and "/mnt/Data2". But vsftpd and Samba doesn't see there are directories. When I enter to directory "/mnt" via local network or FTP there empty. SELinux is disabled. What a problem is in?
Sorry for my bad English :)

scottro
6th October 2007, 10:16 PM
For samba, you would have to define it in /etc/smb.conf. That means in the share section, adding something like
[myshare]

path = /mnt/Data1

For vsftp, I don't remember its defaults--if you have local users and no chroot, you would do something like, if your user name was sidd

ftp localhost
It will ask for your user name, you give it, then it asks for your password--if you've done no special configuration, it should accept your local user password. (I think--I haven't used vsftpd in awhile, and there might be something you have to do with its config files.)

Then, you could do, at the ftp prompt

cd /mnt/Data1

sidd-ua
7th October 2007, 03:03 PM
This is my smb.conf:

[global]

workgroup = WORKGROUP
server string = Home Server
bind interfaces only = yes
interfaces = eth0 192.168.0.121 127.0.0.1
hosts deny = ALL
hosts allow = 192.168.0.121 127.0.0.1
printcap name = /etc/printcap
printing = cups
cups options = raw
log file = /var/log/samba/log.smbd
max log size = 50
security = share
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192
local master = yes
preferred master = yes
domain master = no
wins support = no
dns proxy = no
guest ok = yes
guest account = nobody
unix charset = utf8
dos charset = cp1251
display charset = cp1251

[mnt]
comment = Data
path = /mnt
writeable = yes
guest ok = yes
create mask = 0666
directory mask = 0777
read only = no

But when I go to "//my_ip/mnt" there empty. Why?

scottro
7th October 2007, 04:40 PM
I think it has to be the whole path, that is /mnt/Data1. I'm not sure of that and don't have a machine here running samba to check, but see if that works.

sidd-ua
8th October 2007, 01:51 PM
Ok. Thank for reply.