PDA

View Full Version : VNC problem



mrdagz
6th October 2007, 04:36 PM
Hi all,

I have installed Fedora 7 and i want to connect to it Via VNC, i can start the vncserver but when i connect to it i do not get X session. i get a gray screen with a while command line window in it.

i tried to start X with the startX command but i got the following error

[root@Babel ~]# startx
xauth: creating new authority file /root/.serverauth.3216

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up.
xinit: unable to connect to X server
xinit: No such process (errno 3): Server error.

any one what is going wrong and how i can fix this ?
Cheers.

hermouche
6th October 2007, 04:50 PM
hy,

You should go to:
System-Preferences-Internet and Network-Remote Desktop

and configure the Remote Desktop Preferences window by allowing users........etc

From where are you trying to connect to Fedora?
which command are you typing?

red

mrdagz
6th October 2007, 05:22 PM
I am connecting from a windows PC with real VNC, i just connect to systemIP:1
I have KDE installed, can not find the remote Desktop Preferences in X windows.
under system i have a network configuration tool but nothing else to do with network or internet. ?

hermouche
6th October 2007, 05:38 PM
Oooops, i am in Fedora 7 (GNOME), so i don't know really the KDE case.

However i guess you can install it using yum command:

code:
yum install rdesktop tsclient

tsclient: Terminal Server Client

red

anonymouse
6th October 2007, 05:52 PM
There is an X session running - it's just a lot more basic than you're used to. This is what UNIX was like 20 years ago. :-) You can run things from the command line that you see, e.g. type "firefox" for Firefox, etc.

The window manager run by default is "twm". You can change this by editing the file .vnc/xstartup - the command to start twm is at the end of the file - change this to something more modern.

mrdagz
6th October 2007, 06:26 PM
Hi and thanks for the replys.
this makes sens and when i look at the xstartup file it did say twm in it
how ever i have changed this to the follwing and it does the same thing even after a reboot.

my xstart file now looks like this

[dagz@Babel ~]$ vi .vnc/xstartup
#!/bin/sh

# Uncomment the following two lines for normal desktop:
# unset SESSION_MANAGER
# exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
amule &
fluxbox &

mrdagz
6th October 2007, 06:38 PM
sorry, should have read the comment at the top of the file, uncommented the top two lines and it worked
thanks for the help.

anonymouse
6th October 2007, 06:40 PM
I should have read that too - not sure why your first edit didn't work but I guess it doesn't matter. :-)

Good luck!