PDA

View Full Version : Question for anyone who has installed with Japanese support



scottro
5th October 2007, 05:59 PM
Firstly, I apologize for asking others to do my work for me, but I don't have a test machine available.
Has anyone installed Fedora 6 or up and chosen Japanese support at installation? If so, did it still install canna and kinput2 or just scim, anthy and scim-anthy.

Secondly, has anyone had the issue that the usual ctl+space wouldn't start scim? (Fixed by adding the combo to $HOME/.scim/config).

The reason I ask is that I maintain a moderately well-known page on Japanese input in Linux, (it's actually mentioned in the scim-anthy README) and I'm trying to keep it up to date. When I install, I don't use Japanese support as it installs too many extras for my taste--I just do yum -y install scim-anthy fonts-ja which pulls in the other things I need.

Again apologies for asking others to do my research for me as well as thanks for any input <snicker--get it? Input?>

Wayne
6th October 2007, 01:35 AM
That would be me :) It installs scim/scim-anthy. I also had the problem of being unable to switch input method with ctl-space but cured that by going to:

System > Preferences > Personal > Input Method

and changing it from the default 'Follow the system-wide configuration [SCIM]' to 'Use custom input method' 'scim' (in the drop-down box it was the only choice)

Edit: That problem was in F7, it was fine in FC5 to 6. I normally do a clean install but retain my /home on a separate partition.

Wayne

scottro
6th October 2007, 03:11 AM
Great thanks. I thought so (a Tokyo Linux group member confirmed it on CentOS) but wasn't sure.

As for scim, I had the same problem either on 7 or 8, I've forgotten if it was last week or a few weeks ago. For whatever reason, the .scim/config didn't have the hot key trigger thingie--it was blank. (Actually, that was when I looked at the scim-anthy README and found that they reference my page.)

Thanks very much for taking the time to answer. kansha ****e orimasu.
(Too lazy to open scim and type it in Japanese.) :)