PDA

View Full Version : NOMACHINE with Gnome applet problems (also with FREENX)



rollingsr
5th October 2007, 05:51 PM
Often when I log into a nomachine nx server I get applet errors like:

OAFIID:GNOME_SystemTrayApplet
OAFIID:GNOME_FastUserSwitchApplet
OAFIID:GNOME_ClockApplet
OAFIID:GNOME_MixerApplet
OAFIID:GNOME_WorkspaceSwitcherApplet
OAFIID:GNOME_TrashApplet
OAFIID:GNOME_WindowListApplet
OAFIID:GNOME_ShowDesktopApplet

all with an option to delete the applet from the tray

the weird part is that I might log out and log right back in not get the same errors. I have tried creating a designated users for remote purposes thinking it was a shared memory type problem but that did not work. I have also tried using the FREENX server and I have similar results.

leif81
15th October 2007, 04:26 PM
I've had that issue too. I think it was because I had a freenx session open that I did not properly logout of. Try running the Nx Session Administrator program and checking if there is a session still active. If so, delete it and then try logging in.

rollingsr
16th October 2007, 07:56 PM
Tried your idea with no success. The problem is random and the times that I don't get the above errors sometimes the applet area is just blank but then sometimes everything is just fine. So close to having a decent RDP for linux and yet miles away.

Billy Bob
11th January 2008, 08:07 AM
To that list of problems add an unresponsive gnome-panel (ie not possible to select a menu pulldown). Desktop items work ok (ie I've added a Terminal shortcut).

hfschwing
16th March 2008, 02:31 AM
I have the same problem and posted a post before double checking if any one else had the same problem. I also have a machine running Ubuntu with Gnome and the NoMachine remote access work perfect.

jlc
28th March 2008, 03:46 PM
I have the same problem with CentOS 5. The current work around is to install KDE. If I'm logged in locally to Gnome, then in NX Client I use KDE.

Kind of weak work around but at least I don't get the pop ups and destroy my pannel locally....

decot
3rd April 2008, 12:39 PM
Clean /tmp folder before creating a new NX session and the panel errors will go away

hfschwing
3rd May 2008, 03:51 AM
I tried cleaning the .nx/temp folder on the client and still the same error.
As an aside I did also update both server and client to NX version: 3.20-9

Using KDE is a work around but not a really acceptable one. Any other ideas why this is happening on Fedora? I have no problem with an Ubuntu NoMachine NXserver.

decot
3rd May 2008, 07:53 PM
You must delete the /tmp folder on the server side (it's normal that you cannot delete all files in this folder because they are used by running applications...).

BUT I have seen that I don't have this problem if there is no opened session (on server side) when I'm trying to connect with NX. That means that I do a "log off" before to work with NX.

sionut
30th May 2008, 11:56 AM
I'm having the same problem, also with FC9. I'm getting the same errors and in the end I'm left with no applets on the screen - I have to add them manually.

Did anybody find a solution to this problem ?