PDA

View Full Version : another yum.repos.d problem



mrfisho
1st October 2007, 10:18 PM
Okay I have read and read the replys and nothing seems to work for me..

Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again
I have tried the clean and other commands but seem to keep getting the same error.. Help needed..
cheers

SlowJet
1st October 2007, 10:47 PM
Are you running F7?
rpm -qa fedora-*

How did you install F7?
32 or 64?
do you have other repos enabled?


List
dir /etc/yum.repos.d

cat /etc/yum.conf

cat /etc/yum.repos.d/fedora.repo

SJ

mrfisho
2nd October 2007, 10:57 AM
Are you running F7?
rpm -qa fedora-*
fedora-release-7.91-2
-----------------------------
How did you install F7?
Installed using Live Cd Install.
---------------------------------------
32 or 64?
32bit
-------------------------------------------
do you have other repos enabled?
no
------------------------------------------------

List
dir /etc/yum.repos.d
fedora-development.repo fedora.repo fedora-updates.repo fedora-updates-testing.repo
--------------------------------------------------------------------------------------------------------------------

cat /etc/yum.conf
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
metadata_expire=1800
installonly_limit=2

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
----------------------------------------------------------------------------------------

cat /etc/yum.repos.d/fedora.repo
[fedora]
name=Fedora $releasever - $basearch
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

[fedora-debuginfo]
name=Fedora $releasever - $basearch - Debug
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-debug-$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

[fedora-source]
name=Fedora $releasever - Source
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-source-$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY
---------------------------------------------------------------------------------------------------------------------------

Okay hope thats everything you asked for..
cheers

markkuk
2nd October 2007, 11:28 AM
Are you running F7?
rpm -qa fedora-*
fedora-release-7.91-2
You're running Fedora 8 test 2. There's no "fedora" or "updates" repos for test releases, you must use the fedora-development repo.



cat /etc/yum.repos.d/fedora.repo
[fedora]
name=Fedora $releasever - $basearch
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch
enabled=1

Change the above line to enabled=0.

mrfisho
2nd October 2007, 11:48 AM
looks like that did the trick thanks markkuk :)