View Full Version : Need Help with Fedora 7 install

25th September 2007, 06:48 PM
Sorry if this is on the long side, but I feel the need to explain thoroughly.

Had the following system working, till mb died.
MB Asus A8N5X 2 gig ram Opteron 165
IDE 0 Fedora 7 x86_64
SATA 1 Vista 64
SATA 2 XP Professional
SATA 3 Samsung dvd recorder
SATA 4 Pioneer dvd recorder
ATI x1950 video adapter
939 Board died so purchased ASUS M2N-E SLI board 4 gig ram (2x2gig) 5600+ CPU.

XP ran a repair and all was good. Vista needed a re-install, all good. FC7 came up, but it would not go into graphical mode. Kept trying system-config-display, and kept getting messages that "cannot open display :0" "cannot open display :1". Something about xorg.conf not being any good, and will create a new one. The system still cannot come up in graphical mode.

Decided to re-install FC7. The DVD would read, and let me choose the install, but then it kept asking for the drive the image was on. I kept choosing the CDROM, but nothing. Finally got FC7 installed, by putting an IDE DVD-ROM on the second IDE controller. Still has no graphical interface. Tried the FC7 Drive on my sons SLI system with two video cards. No problem. System comes up in graphical mode.

From my limited knowlegde of linux, I've come to the conclusion that it does not like only having one video card. Any ideas, how I can get this to work. According to http://www.linux-tested.com/results/asus_m2n-e_sli.html this board works with Linux.

Thank you all for your time.

25th September 2007, 07:04 PM
Hallo pommard

may you need to install the video card driver of the manufaturar. But do not downlaod it from the home page of the manufaturar. See: http://www.fedorafaq.org/#radeon

To be able to do it you need to start fedora in runlavel 3. It means to start fedora without graphical surface. Linux is without grafical surface full usabel:

1. boot
2. press e with selecets fedora in the grub menu.

you will see sonething like:
title Fedora Core (
root (hd0,0)
kernel /boot/vmlinuz- ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-

3. go to the line beginnig with kernel and press e again.
4. add at the end of the kernel line a Space and a 3
6. press enter
7. press enter
8. press b
9. login as root afert the system is up.

25th September 2007, 07:36 PM
Hello tho.mei,

Sorry I forgot to mention that I already tried to install the livna fglrx drivers. I got the same thing. It's like Fedora isn't picking up that I have only one video card installed. I will try and prove that out tonight, when I try to bring the system up with my sons 8600's. The BIOS setting for sli is set for one video adapter. Options are (AUTO; Single Adapter; Dual Adapters). Like I said Windows XP or Vista have no problem detecting the video, either on AUTO or Single Adapter. Will post back with my results.


25th September 2007, 08:31 PM
Hi Pommard, In the link you provided (the linux tested link) it shows the display drivers as Nvidia, If you look in your xorg.conf file in the device section does it show "Device" = nv, or does it show "Device"=Nvidia?

26th September 2007, 12:07 AM
Hi Tim, I only provided that link to show that the motherboard is supposed to work with linux. I have ATI x1950. I will post what the xorg.conf has on my system. If I remember correctly it is using the "VESA" drivers. It would not work when I tried the Livna flgxr driver.

26th September 2007, 12:30 AM
Pommard, if you run the command system-config display and go into the hardware tab does it give a choice for Radeon?

26th September 2007, 04:33 AM
Tim, can run the display config comand in text mode, so there is no hardware tab. I just keep getting the messages that it cannot open display. Even tried Fedora 8 test 2 this evening, and get the same thing, but the message is now changed to card instead of display. I ran "system-config-display - v" and it does show that the video card is a Ati x1950. Just having issues with it not being able to open for some reason. On Saturday I am going to try one or both of my sons 8600s, and see if that helps. Though, I might give up, and try another distribution as the install fails to see my SATA DVD writers. I installed via the internet tonight, and it took a few hrs, and still no graphics. Thanks for the help.

26th September 2007, 11:49 PM
Ok, I have an update. I was finally able to use 'system-config-display', and have it work. I had to remove one of my 2 gig sticks of ram. After running the display config comand I was able to run 'init 5' and I got the gui login screen. I did a shutdown, and added the 2 gig back. Same problem no graphics. Seems that fc 8 will not run with 4 gig of ram on my system. Will do some more research, and post back my findings.

27th September 2007, 03:31 PM
Update on my FC7 woes. Had today off, so decided to re-install FC7. Here are my findings. With 4 gig (2x2gig) of ram in the system. I cannot access the DVD after it installs the initial drivers. System will install from one of the mirrors, but then I have no Graphical environment. What does work is removing one of the memory sticks and running with 2 gig. In that configuration, the DVD is picked up, the install completes, and I have a graphical interface. I'm actually up on it now doing the updates. When I put back the other dimm to make it 4 gig again the system will not go into graphical mode.
Any ideas why 64bit Fedora is behaving this way?

Thank you.

27th September 2007, 09:27 PM
Have you tried the PAE kernel versions? The standard kernel is supposed to handle up tp 4 gigs, but it's worth a shot, also have you run a memory test on the memory? It's might be bad. Can you boot/install etc with only 2 gigs and try swapping the chips to see if one is problematic?

Just guessing... Hope it helps

28th September 2007, 02:36 PM
It is the 64 bit version of Fedora 7 it should be able to see all the memory. Anyway, after lots of searching, and reading I must say I finally got it working. Here is what I did. Removed a dimm to bring the memory down to 2 gig. F 7 installed with no problems, it didn't even have a problem locating the DVD drive. I booted into the system, and I had the graphical interface. I shutdown, added the other Dimm to make the system have 4 gig again, and rebooted.
At the grub screen, I added "mem=4096M". System booted and I have most of my memory, don't remember the number exactly, but it's like 3.2 gig. During my readings, I came across and article, that said I would need to rebuild my kernel with a source that allows 64gig of ram, to be able to see all 4 gig. So I'm researching on how to rebuild my kernel and searching for the proper kernel.

Thank you for all that attempted to help.

28th September 2007, 05:28 PM
It looks like you are not alone in encountering this. Did you read this thread yet?


9th October 2007, 11:40 AM
Hello Everybody,

In the last some days I experienced some strange things around installation of FC7 x86-64. First I should declare, that I previously installed an Ubuntu 6.04 without any problems onto my Seagate 7200.7 SATA HDD.

The configuration:

ASUS M2N-E /w BIOS 0402
ASUS X1300Pro
Seagate 7200.9 ATA HDD (160 GB) - attached to the board as Primary Master
Pioneer DVR212-D SATA - attached to SATA1
Seagate 7200.7 SATA HDD (120 GB) - attached to SATA2
2*512 MB A-Data Vitesta RAM.

I booted the FC7 installation DVD, I've got the GUI. Okay, no problem c'mon with the installation. When the partition screen came up, I've got a message:

Partition table of sdb (!) drive unable to read, first I have to initialize the drive. Hopp, stop, there is my working Ubuntu, i do not want to delete it... I pressed OK for every errormessage, so I could select the partitioning method (I thought). I selected Custom layout... and I have detected that there is no partitionable disk space... (further info: I also tried to install PCLinusOS2007 to this HDD - also without success) Ok, no problem, I booted back to Windows and created the necessary partitions with ext3 fs. Started FC7 DVD again... and the same problem. I cannot imagine, what happened. I cannot detect the problem because Ubuntu worked well.
Okay, then put Windows and all the datas from that partitions to the SATA-drive - I thought. I have deleted all the non-NTFS partitions on this drive (yes, Ubuntu also) and prepared the SATA-drive for moving files. This way is not-so-want from me, i do not want to move 110 GB of datas from one drive to another one.

Today morning I have spoken with my friend - and he gave me the solution! He told me that the SATA-sockets are controlled in pairs - I mean 1-2 / 3-4 / 5-6... Then I've detected that Pio in SATA1 and the smaller HDD on SATA2. FC7 installer signed my ATA drive as sda device and the Pio as sdb and cannot detect my SATA HDD on SATA2 socket...

I do not know that the "real" reason is known already, but it was so strange for me.
I hope that this can help anybody.

9th October 2007, 12:49 PM
i don't know about your bios settings, but i think that is where your problem lies, most motherboards have an option to run sata drives in a mostly windows compatible situation or to name them like E-IDE drives so every other OS in the world can work normally as well :)

9th October 2007, 01:14 PM
Okay, Zero, I will try to find that option - I do not need to change this setting in the past (I didn't have SATA drives). (In another point of view, this behaviour is strange, because Ubuntu could detect my drives correctly.)

9th October 2007, 02:22 PM
the SATA thing is a known issue throughout several distributions, it all depends on which chipset you have/ on which motherboard/ and with what settings

btw, i have 3 SATA drives myself ;)

9th October 2007, 02:50 PM
Absolutely offtopic: when I built up my current machine, I planned to buy a board with VIA chipset (I do not like nForce), but the boards have so-old VIA chipsets there for A64 :(

9th October 2007, 03:52 PM
i love nforce personally, at least nvidia has linux drivers :)

9th October 2007, 05:45 PM
So, now I am at home and write these lines under Fedora Core 7 :)

I checked your suggestion, Zero, and checked my BIOS. Default the Enhanced IDE-handling for SATA is set to Auto - the other option is None. I put the HDD to SATA3 and everything works fine during the installation, so I hope that my infos on previous page will be helpful to others, who has the same problem.

9th October 2007, 07:24 PM
no problem ;) i am glad i could help you :)

good luck and keep in touch with the forum ;)

27th October 2007, 09:13 PM
My never ending quest to use all 8 gig of ram in my system continues. I am able to boot normally with mem=4096M as a kernel paramater. Any attempt to use 8192M or even 10240M makes X server unable to come up. What I have found is that by adding acpi=off with mem=10240M or by itself I get all my memory. Only problem with using acpi off is that I lose access to my SATA drives (2 hds 2 DVD RWs) and no USB ports and no sound. I tried Ubuntu, and it has the same symptoms as FC7. Only distribution that worked without any problems was Suse 10.3. Suse saw all my ram during the installation. Only problem with Suse is that it had no sound, and I prefer Fedora.
Any ideas how I can get my system to see all the ram and have my devices functioning? I am currently running Fedora 7 x86_64, with "acpi=off" being passed to the kernel.
free command shows:
total used free shared buffers cached
Mem: 8201512 881292 7320220 0 32620 399580
-/+ buffers/cache: 449092 7752420
Swap: 2031608 0 2031608

and /proc/meminfo shows:

[cv@archiexi ~]$ cat /proc/meminfo
MemTotal: 8201512 kB
MemFree: 7315780 kB


27th October 2007, 09:16 PM
are you using the pae kernel? there is a special kernel thta is used to support up to 64GB of mem ;)

28th October 2007, 12:34 AM
Have you filed a bug in bugzilla? They might know if the regular kernel supports more than 2 GB of RAM, there is nothing in the release notes or anything in any documents that says it doesn't so my guess it's a bug.

28th October 2007, 02:51 AM
are you using the pae kernel? there is a special kernel thta is used to support up to 64GB of mem ;)

Zero - I'm running the 64 bit version of F7. From what I understand the PAE kernel is for the 32 bit version.

28th October 2007, 02:54 AM
Have you filed a bug in bugzilla? They might know if the regular kernel supports more than 2 GB of RAM, there is nothing in the release notes or anything in any documents that says it doesn't so my guess it's a bug.

Haven't file a bug yet. But think I will have to, as Suse 10.3 works, but without sound. Thanks.

28th October 2007, 03:48 AM
i'm not sure about that, all i recal is that 4gb (or 4gb+ up to 64gb) needs the PAE kernel to function correctly, os some tweaks like like mem=4096 and the likes

have you tried the search-function with something like "memory detection problem" or "2gb memory detection" or something like that?