PDA

View Full Version : FC6 Webcam support



yaxomoxay
19th September 2007, 01:26 AM
Guys,
I'm trying to install a webcam (Creative VF-0040) but I get an error. What should I do ?

[root@localhost gspcav1-20070508]# make
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/enrico/
gspcav1-20070508 CC=cc modules
make: *** /lib/modules/2.6.22.2-42.fc6/build: No such file or
directory. Stop.
make: *** [default] Error 2


I already installed the kernel headers (I think) thru


[root@localhost enrico]# yum install kernel-devel
Loading "installonlyn" plugin
Existing lock /var/run/yum.pid: another copy is running. Aborting.
[root@localhost enrico]# yum install kernel-devel
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for kernel-devel to pack into transaction set.
kernel-devel-2.6.22.4-45. 100% |=========================| 716 kB 00:03
---> Package kernel-devel.i686 0:2.6.22.4-45.fc6 set to be installed
--> Running transaction check
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-devel.i586 0:2.6.22.2-42.fc6 set to be erased
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
kernel-devel i686 2.6.22.4-45.fc6 updates 4.7 M
Removing:
kernel-devel i586 2.6.22.2-42.fc6 installed 15 M

Transaction Summary
================================================== ===========================
Install 1 Package(s)
Update 0 Package(s)
Remove 1 Package(s)

Total download size: 4.7 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): kernel-devel-2.6.2 100% |=========================| 4.7 MB 00:20
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
package kernel-devel-2.6.22.5-49.fc6 (which is newer than kernel-devel-2.6.22.4-45.fc6) is already installed

Error Summary