PDA

View Full Version : howto install apt?



numerodix
4th May 2004, 04:27 AM
Is there a howto for this? I understand is popular so people have to get the info somewhere, right? I saw one of the threads here and tried installing it myself and this is what I get:

# rpm -i apt-0.5.15cnc6-0.fdr.11.1.i386.rpm
warning: apt-0.5.15cnc6-0.fdr.11.1.i386.rpm: V3 DSA signature: NOKEY, key ID 8df56d05
error: Failed dependencies:
librpm-4.2.so is needed by apt-0.5.15cnc6-0.fdr.11.1
librpmdb-4.2.so is needed by apt-0.5.15cnc6-0.fdr.11.1
librpmio-4.2.so is needed by apt-0.5.15cnc6-0.fdr.11.1

Either that or is there an up-to-date list of working yum repositories? I'd like to install mplayer but I can't cause of failed dependencies that can't be located..

Jman
4th May 2004, 04:36 AM
The semi-official replacement yum.conf is here: http://fedorafaq.org/faq/samples/yum.conf

apt is in one of the yum repositories, just run
yum install apt and one software manager will install another! :D The graphical synaptic tool has been built for Fedora as well. It's nice.

numerodix
4th May 2004, 04:50 AM
Hm when I run that command with the yum.conf you provided, I get this:

# yum install apt
Gathering header information file(s) from server(s)
Server: Fedora Core 1.92 - i386 - Base
retrygrab() failed for:
http://mirror.hiwaay.net/redhat/fedora/linux/core/1.92/i386/os/headers/header.info
Executing failover method
retrygrab() failed for:
http://rpmfind.net/linux/fedora/core/1.92/i386/os/headers/header.info
Executing failover method
retrygrab() failed for:
http://mirrors.usc.edu/pub/linux/fedora/fedora/fedora/1.92/i386/yum/os/headers/header.info
Executing failover method
failover: out of servers to try
Error getting file http://mirror.hiwaay.net/redhat/fedora/linux/core/1.92/i386/os/headers/header.info
[Errno 4] IOError: HTTP Error 404: Not Found


Ps. any idea how long until FC2 goes stable? and can I upgrade from test3 to stable just using yum when the time comes?

gonzalo76
4th May 2004, 05:06 AM
Upgrade to the last RPM version for Fedora Core 1 first here (http://rpmfind.rediris.es/rpm2html/librpmio-4.2.so.html)
Then try to install APT. If not, try to install an older version of APT.

numerodix
4th May 2004, 05:08 AM
that's no good either:

# rpm -i rpm-4.2.1-0.30.i386.rpm
warning: rpm-4.2.1-0.30.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
popt = 1.8.1 is needed by rpm-4.2.1-0.30

numerodix
4th May 2004, 05:10 AM
What I'd like to know is would this be working fine if I was on FC1, is this because I'm running unstable?

gonzalo76
4th May 2004, 05:26 AM
Originally posted by numerodix
What I'd like to know is would this be working fine if I was on FC1, is this because I'm running unstable?

My HowTo was for Fedora Core 1

http://www.fedoraforum.org/forum/showthread.php?s=&threadid=1608

I said:

THIS FILE ONLY WORKS FOR FEDORA CORE 1 !!!!
I'll do another one for Fedora Core 2 final stable version as soon as it'll be released.

You should download apt for your current Fedora version.

Good Luck

tempusme
8th May 2004, 09:13 PM
i'm having the same problem and exact same reasons, i believe.

are there any FC1.92 Repos yet? fedora.us only has http://download.fedora.us/fedora/fedora/1.92/i386/ , which doesn't have yum yet... so i can't seem to install apt. i've tried, but i'm missing dependencies also.

spottyrover
14th May 2004, 01:27 PM
I installed apt-get using this site (http://ccrma.stanford.edu/planetccrma/software/) then I installed synaptic so I had an easy to use gui

my set up is
# Package repository URLs

# Planet CCRMA for Fedora Core 1

# Main site, CCRMA, California, USA

rpm http://www-ccrma.stanford.edu/planetccrma/apt/ fedora/1/i386 core updates
rpm http://www-ccrma.stanford.edu/planetccrma/apt/ fedora/1/i386 planetccrma
rpm http://www-ccrma.stanford.edu/planetccrma/apt/ fedora/1/i386 planetcore

rpm-src http://www-ccrma.stanford.edu/planetccrma/apt/ fedora/1/i386 planetccrma

# Mirrors: IRCAM, Paris, France

#rpm #http://freesoftware.ircam.fr/mirrors/planetccrma/apt/ fedora/1/i386 core updates
#rpm #http://freesoftware.ircam.fr/mirrors/planetccrma/apt/ fedora/1/i386 planetccrma
#rpm #http://freesoftware.ircam.fr/mirrors/planetccrma/apt/ fedora/1/i386 planetcore

#rpm-src #http://freesoftware.ircam.fr/mirrors/planetccrma/apt/ fedora/1/i386 planetccrma

rpm http://rpm.livna.org/ fedora/1/i386 stable unstable testing
rpm-src http://rpm.livna.org/ fedora/1/i386 stable unstable testing



# Fedora Linux 1
# rpm http://ayo.freshrpms.net fedora/linux/1/i386 core updates freshrpms
# rpm http://ayo.freshrpms.net fedora/linux/1/i386 tupdates
# rpm http://ayo.freshrpms.net fedora/linux/1/i386 extras alternatives
# rpm-src http://ayo.freshrpms.net fedora/linux/1/i386 core updates freshrpms
# rpm-src http://ayo.freshrpms.net fedora/linux/1/i386 tupdates
# rpm-src http://ayo.freshrpms.net fedora/linux/1/i386 extras alternatives


I hope this helps

harlekin
17th May 2004, 10:16 AM
there R 2 similar versions of apt out right now. the depent on different rpm-versions. as u use rpm-4.3 u should try 2 install this one:
http://download.fedora.us/fedora/fedora/2/i386/RPMS.stable/apt-0.5.15cnc6-0.fdr.11.1.91.i386.rpm

btw the 1.92 repositories dont exits anymore...
they changed the pathes allready for the launch of core 2 (e.g use 2 instead of 1.92 in the pathes of yum.conf or source.list [for apt])