PDA

View Full Version : Wine installation error



midnightmagnum
9th September 2007, 12:46 AM
I am a complete noob to Linux and i was wonder how i would go about fixing this problem. Should I just delete the files or is that a bad idea. Any help is greatly appreciated.

Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package wine.i386 0:0.9.43-2.fc7 set to be updated
--> Processing Dependency: wine-ldap = 0.9.43-2.fc7 for package: wine
--> Processing Dependency: wine-nas = 0.9.43-2.fc7 for package: wine
--> Processing Dependency: wine-esd = 0.9.43-2.fc7 for package: wine
--> Processing Dependency: wine-tools = 0.9.43-2.fc7 for package: wine
--> Processing Dependency: wine-capi = 0.9.43-2.fc7 for package: wine
--> Processing Dependency: wine-core = 0.9.43-2.fc7 for package: wine
--> Processing Dependency: wine-cms = 0.9.43-2.fc7 for package: wine
--> Processing Dependency: wine-jack = 0.9.43-2.fc7 for package: wine
--> Processing Dependency: wine-twain = 0.9.43-2.fc7 for package: wine
--> Running transaction check
---> Package wine-capi.i386 0:0.9.43-2.fc7 set to be updated
---> Package wine-cms.i386 0:0.9.43-2.fc7 set to be updated
---> Package wine-nas.i386 0:0.9.43-2.fc7 set to be updated
---> Package wine-twain.i386 0:0.9.43-2.fc7 set to be updated
---> Package wine-esd.i386 0:0.9.43-2.fc7 set to be updated
---> Package wine-ldap.i386 0:0.9.43-2.fc7 set to be updated
---> Package wine-jack.i386 0:0.9.43-2.fc7 set to be updated
---> Package wine-tools.i386 0:0.9.43-2.fc7 set to be updated
---> Package wine-core.i386 0:0.9.43-2.fc7 set to be updated
--> Processing Dependency: libgphoto2_port.so.0 for package: wine-core
--> Processing Dependency: libGLU.so.1 for package: wine-core
--> Processing Dependency: libgphoto2.so.2 for package: wine-core
--> Running transaction check
---> Package gphoto2.i386 0:2.3.1-5.fc7 set to be updated
--> Processing Dependency: libexif.so.12 for package: gphoto2
---> Package mesa-libGLU.i386 0:6.5.2-13.fc7 set to be updated
--> Running transaction check
---> Package libexif.i386 0:0.6.15-2.fc7 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
wine i386 0.9.43-2.fc7 updates 19 k
Installing for dependencies:
gphoto2 i386 2.3.1-5.fc7 fedora 1.4 M
libexif i386 0.6.15-2.fc7 updates 229 k
mesa-libGLU i386 6.5.2-13.fc7 updates 204 k
wine-capi i386 0.9.43-2.fc7 updates 25 k
wine-cms i386 0.9.43-2.fc7 updates 37 k
wine-core i386 0.9.43-2.fc7 updates 9.6 M
wine-esd i386 0.9.43-2.fc7 updates 35 k
wine-jack i386 0.9.43-2.fc7 updates 37 k
wine-ldap i386 0.9.43-2.fc7 updates 87 k
wine-nas i386 0.9.43-2.fc7 updates 23 k
wine-tools i386 0.9.43-2.fc7 updates 611 k
wine-twain i386 0.9.43-2.fc7 updates 47 k

Transaction Summary
================================================== ===========================
Install 13 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 12 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
file /usr/share/locale/de/LC_MESSAGES/libexif-12.mo from install of libexif-0.6.15-2.fc7 conflicts with file from package libexif-0.6.13-3.fc7
file /usr/share/locale/es/LC_MESSAGES/libexif-12.mo from install of libexif-0.6.15-2.fc7 conflicts with file from package libexif-0.6.13-3.fc7
file /usr/share/locale/fr/LC_MESSAGES/libexif-12.mo from install of libexif-0.6.15-2.fc7 conflicts with file from package libexif-0.6.13-3.fc7
file /usr/share/locale/pl/LC_MESSAGES/libexif-12.mo from install of libexif-0.6.15-2.fc7 conflicts with file from package libexif-0.6.13-3.fc7

Error Summary
-------------

leigh123linux
9th September 2007, 01:39 AM
try


su
yum update libexif

midnightmagnum
9th September 2007, 09:10 AM
Well i tried updating but it didn't work. I not sure if I am reading it wrong but it looks like the files from the package are out of date not the ones from my os

brr872002
9th September 2007, 09:30 AM
yum - y install yumex or yum -y install kyum
You will get GUI options for updates

or

Try
rpm -e libexif-0.6.15-2.fc7

If there is no error

run
yum -y install wine

leigh123linux
9th September 2007, 10:03 AM
try

su
yum install yum-downloadonly
yumdownloader libexif
rpm -U --replacepkgs --replacefiles libexif*rpm




If the above commands fail to remove the package , remove it with this command ( last resort only)


rpm -e --nodeps libexif-0.6.15-2.fc7
rpm -U --replacepkgs --replacefiles libexif*rpm

midnightmagnum
9th September 2007, 07:13 PM
Thanks for all the help when i removed the files and re downloaded them it worked