PDA

View Full Version : Second monitor doesn't get windows borders in Compiz Fusion with Twinview



Raiko
6th September 2007, 03:02 AM
The spin effect of clicking on the different workspaces works on the second monitor, but the window borders do not.

Emerald is my Window Decorator and Compiz is my window manager.

Any help would be appreciated.

Here is my Xorg.conf





# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" LeftOf "Screen0"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"

# Removed Option "Xinerama" "1"
Option "AIGLX" "on"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CMO CMC 19"
HorizSync 30.0 - 82.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Acer AL1912"
HorizSync 24.0 - 80.0
VertRefresh 49.0 - 75.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7600 GT"
Option "Twinview"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
BusID "PCI:7:0:0"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7600 GT"
Option "Twinview"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
BusID "PCI:2:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
Option "metamodes" "nvidia-auto-select +0+0"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

LordMorgul
10th October 2007, 05:51 AM
If you haven't fixed this issue yet you might get some help with it if you can post:
- version of fedora you're working on
- versions of emerald, compiz-fusion (and are they from base or from Kage's repo?)

- your kernel version
- your nvidia driver version