PDA

View Full Version : Error right after the logging



wegorekm
5th September 2007, 03:27 PM
Right after the logging a warning pops up:
You session only lasted less then 10 seconds...

I click 'view details' :

localuser:michal being added to access control list
/usr/bin/gnome-session: /lib/libc.so.6: version 'GLIBC_2.7'not found (required by /lib/libasound.so.2)

The error came after the software updating with 'Software Update' from main menu.
After the logging i can't do anything but read the message and try to re-log.

Is there any possibility to avoid reinstalling the system?

PS. Logging in text-mode works (ctrl-alt-f1), internet works and yum works as well.
Besides i have ubuntu on the other partition if this could help
---------
FC7,Pentium M

ppesci
5th September 2007, 03:59 PM
Can you try to use kde?

startkde

This will give you a more friendly environment to work while you solve the problem.

My machine is up to date and my packages status are:


rpm -qa|grep glibc
glibc-common-2.6-4
glibc-headers-2.6-4
glibc-devel-2.6-4
glibc-2.6-4

rpm -qf /lib/libc.so.6
glibc-2.6-4

rpm -qf /lib/libasound.so.2
alsa-lib-1.0.14-3.fc7


There are no such thing like GLIBC_2.7. You can check against my installation that works well.

HTH

wegorekm
5th September 2007, 04:33 PM
startkde
>command not found

How can i install kde?

Everything is the same besides
rpm -qf /lib/libasound.so.2
alsa-lib-1.0.14-3.fc7 - thats Yours

i have alsa-lib-1.0.14-3.fc8

ppesci
5th September 2007, 04:57 PM
Oops, alsa-lib is you problem. You are not using F 7, you are using Fedora 8 and is a beta version.

you can to try to downgrade alsa-lib to solve the problem, that is, install alsa-lib-1.0.14-3.fc7. I think there are an option --downgrage in yum to do this, check man pages.


man yum

If you have F 7, (I don't think so), then check your repositories and disable beta versions.

Later, if you want to install kde, type the command

yum groupinstall "KDE (K Desktop Environment)"

but first, solve the sound problem (alsa-lib) or you will have problem with kde too,

HTH

wegorekm
5th September 2007, 05:26 PM
I can't find an option to downgrade ;(
I have fedora7.

Maybe shall i remove and install this package?

Thx for all your help so far.

ppesci
5th September 2007, 06:21 PM
Try:

yum --obsoletes update alsa-lib-1.0.14-3.fc7


if this doesn work, you wil need to get the package from internet and use rpm to force install

HTH