PDA

View Full Version : Fedora woes (boot, fstab )



DigitalDuality
5th September 2007, 01:44 PM
I was just wondering if anyone could give me some insight, and i wish i had better documentation to explain. But here it goes.

2 days ago, i rebooted fedora and i had not made any major system changes whatsoever. No major updates, hardware changes, no odd software installs, etc.. The last thing i could remember doing was mounting a hp camera to extract some pictures (and did so with a blackberry usb cable). The computer acted oddly. It automounted it and allowed me to do what i needed, but normally the camera will state it's attached to a computer. I've done this many times on my fedora 7 kde box. This time it didn't.

Upon bootup, it gets past the bios, it starts grub, it checks fstab, then starts throwing all these hex cmd error at me. It stated lines 4 and 6 in fstab were wrong. Well line 4 was an external hard-drive, and i had no clue what line 6 was. I believe it stated something about devps. Anyways. It kept booting into a repair disc mode and without knowing what was wrong i was unable to troubleshoot it and really didn't have the time to.

I tried installing ubuntu (i didn't have my fedora disc on me) and that failed, after reboot of t he live disc, it was get to grub and just hang. I don't get that either as i've had ubuntu installed at least 4-5 different versions and they work fine. I tried a debian net-install, doing lvm with luks and writing junk data over all the free space on the disc before installing and it worked just fine beyond that point.

No problems, and no troubles now.

Anyone have the slightest clue as to what could have gone wrong?

tashirosgt
5th September 2007, 02:43 PM
Which version of Fedora was this? One theory for your problem is when Fedora was installed, it wrote an fstab on the assumption that the external hard drive or other equipment would stay attached to your system and that when you rebooted, perhaps a some glitch caused the drive not to be detected, so Fedora's assignment of device names (/dev/sda1, /dev/sda2 ) didn't match up with the original assignment of device names. .. But that's just a theory.