PDA

View Full Version : compiz-fusion configuration



NetSpy
4th September 2007, 02:20 PM
Greetings

Im using fedora core 6 im having a problem with compiz-fusion,can one provide me the setup guide step by step to configure it into my machine.looking forward for your kind response.

Regards
NetSpy

leigh123linux
4th September 2007, 03:29 PM
There are no compiz-fusion packages for FC6 only F7

benso37
7th September 2007, 07:05 PM
There are no compiz-fusion packages for FC6 only F7


Can I install and run compiz-fusion under Fedora 7 (KDE)? I'm most interested in the shift switcher plugin.

leigh123linux
7th September 2007, 07:34 PM
Can I install and run compiz-fusion under Fedora 7 (KDE)? I'm most interested in the shift switcher plugin.


Yes , both 32 bit and 64 bit are available for F7 ( you will need to install a 3D driver and if you use a ATI card you will also need XGL )

you need this repo

http://forums.fedoraforum.org/forum/showthread.php?t=159056&highlight=compiz-fusion


su
gedit /etc/yum.repos.d/kagesenshi.repo

Then add this

[kagesenshi-compiz]
name=KageSenshi's Compiz Fusion repository
baseurl=http://devel.foss.org.my/~kagesenshi/repo/pub/$basearch/
enabled=1
gpgcheck=0


As the fedora versions of compiz and emerald clash with compiz-fusion I have added some edits to the fedora repos to block there versions ( exclude=beryl* emerald* compiz* )


su
yum remove compiz*
su -c 'perl -i -pe "s/(\[.*\])/\1\nexclude=beryl* emerald* compiz*/" /etc/yum.repos.d/fedora.repo '
su -c 'perl -i -pe "s/(\[.*\])/\1\nexclude=beryl* emerald* compiz*/" /etc/yum.repos.d/fedora-updates.repo '
yum install compiz-gnome compiz-kde fusion-icon* compiz-fusion-plugins-extra compiz-fusion-plugins-unsupported compizconfig-backend* emerald-themes

P.S I build the 64 bit packages for this repo :)

benso37
7th September 2007, 08:15 PM
Yes , both 32 bit and 64 bit are available for F7 ( you will need to install a 3D driver and if you use a ATI card you will also need XGL )

you need this repo

http://forums.fedoraforum.org/forum/showthread.php?t=159056&highlight=compiz-fusion


su
gedit /etc/yum.repos.d/kagesenshi.repo

Then add this

[kagesenshi-compiz]
name=KageSenshi's Compiz Fusion repository
baseurl=http://devel.foss.org.my/~kagesenshi/repo/pub/$basearch/
enabled=1
gpgcheck=0


As the fedora versions of compiz and emerald clash with compiz-fusion I have added some edits to the fedora repos to block there versions ( exclude=beryl* emerald* compiz* )


su
yum remove compiz*
su -c 'perl -i -pe "s/(\[.*\])/\1\nexclude=beryl* emerald* compiz*/" /etc/yum.repos.d/fedora.repo '
su -c 'perl -i -pe "s/(\[.*\])/\1\nexclude=beryl* emerald* compiz*/"/etc/yum.repos.d/fedora-updates.repo '
yum install compiz-gnome compiz-kde fusion-icon* compiz-fusion-plugins-extra compiz-fusion-plugins-unsupported compizconfig-backend* emerald-themes

P.S I build the 64 bit packages for this repo :)


su -c 'perl -i -pe "s/(\[.*\])/\1\nexclude=beryl* emerald* compiz*/"/etc/yum.repos.d/fedora-updates.repo ' returns the following error.

Illegal division by zero at -e line 1, <> line 1.

leigh123linux
7th September 2007, 08:24 PM
Ok try this


su
su -c 'perl -i -pe "s/(\[.*\])/\1\nexclude=beryl* emerald* compiz*/" /etc/yum.repos.d/fedora-updates.repo '

I missed a space :rolleyes: