PDA

View Full Version : How to speed up "nv" driver?



a_small_cake
3rd September 2007, 07:18 PM
As I'm "forced" to use "nv" driver because "nvidia" driver freezes my system I would like to know some tips about how to speed it up. "Nv" driver is horribly slow, it is noticeable especially when browsing www sites in Firefox (and generally with rendering windows).I can live without 3D support, but this slowness is killing me.

Crito
3rd September 2007, 07:56 PM
You could try the nouveau driver. It was installed but disabled by default on my computer, yum info xorg-x11-drv-nouveau to verify. I *believe* all you have to do is change "nv" in xorg.conf to driver "nouveau" but since I haven't tried it personally might want to get additional help/advice from someone who has.

a_small_cake
3rd September 2007, 08:05 PM
You could try the nouveau driver. It was installed but disabled by default on my computer, yum info xorg-x11-drv-nouveau to verify. I *believe* all you have to do is change "nv" in xorg.conf to driver "nouveau" but since I haven't tried it personally might want to get additional help/advice from someone who has.

Yes I tried "nouveau" but I was unable to start X with them so they are no option for me for now.

Vansolrick
3rd September 2007, 09:58 PM
I know this isnt very direct to your question, but you could try installing a driver from the nvidia archive at their website manually. Just download one of the older .run drivers, open a terminal and do



su -
init 3

(you will now be in a shell with no X)
Log in as 'root'
cd to the dir you saved the nvidia driver .run


cd /path/to/filewithdriverdownload

use to see the contents of the folder you put the .run in so you can see the full name of the file:


dir

Then simply do a:


sh <nvidiadriver>.run

*Replace the <nvidiadriver> with the actual name of the file

Also this may not work unless you have gcc installed



yum install gcc


As far as the nv driver, I was running it for a while because my system was also freezing with the livna nvidia driver. And, there isnt a lot of tweaking that you can do to speed it up. But the latest driver seems to be working fine for now. Its not 100 percent stable but its getting the job done semi-well. Sorry for my bad grammar/spelling; I'm not very good at writing howtos or instructions.

leigh123linux
3rd September 2007, 10:09 PM
As I'm "forced" to use "nv" driver because "nvidia" driver freezes my system I would like to know some tips about how to speed it up. "Nv" driver is horribly slow, it is noticeable especially when browsing www sites in Firefox (and generally with rendering windows).I can live without 3D support, but this slowness is killing me.


I had to tweak ( the red bits ) xorg.conf to get the nvidia driver to run smooth ( it don't matter if it's the homepage driver or livna or the freshrpms driver as they are all built from the same driver source )




Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "G70 [GeForce 7600 GT]"
Option "DPI" "96 x 96"
Option "coolbits" "1"
Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
Option "TripleBuffer" "true"
Option "RenderAccel" "True"
BusID "PCI:5:0:0"
EndSection

a_small_cake
4th September 2007, 12:04 PM
I had to tweak ( the red bits ) xorg.conf to get the nvidia driver to run smooth ( it don't matter if it's the homepage driver or livna or the freshrpms driver as they are all built from the same driver source )




Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "G70 [GeForce 7600 GT]"
Option "DPI" "96 x 96"
Option "coolbits" "1"
Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
Option "TripleBuffer" "true"
Option "RenderAccel" "True"
BusID "PCI:5:0:0"
EndSection

Didn't help, system freezes with flashing led lights as always...So there is no way to speed up "nv" driver? I have GF7 so it should work fast in 2D environment anyway.

update

GFX card was damaged. Now, with new card, everything works.