PDA

View Full Version : system-config-network won't open



fishel
28th August 2007, 03:54 PM
Hi, I have been using Fedora for a year now and have upgraded from 5 to 6 to 7. I have been able to solve any issues arising but this one has me stumped. I have been having funny issues with Gnome like applications closing when I try to add/open a file and the firewall app won’t open but I will show the worst because I have the error message.

It is system-config-network

Thanks for any help.

It won’t open and shows the following error window:


Component: system-config-network
Version: 1.3.96
Summary: TBa70e87bf
NewInterfaceDialog.py:25:<module>:ImportError: /usr/lib/libgnomeui-2.so.0:
undefined symbol: g_once_init_enter_impl

Traceback (most recent call last):
File "/usr/sbin/system-config-network-gui", line 142, in main
import netconfpkg.gui.GUI_functions
File "/usr/share/system-config-network/netconfpkg/gui/__init__.py",
line 36, in <module>
exec _cmd
File "<string>", line 1, in <module>
File
"/usr/share/system-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 25, in <module>
import gnome.ui
ImportError: /usr/lib/libgnomeui-2.so.0: undefined symbol:
g_once_init_enter_impl

Local variables in innermost frame:
signal: None
__builtins__: {'IndexError': <type 'exceptions.IndexError'>, 'all':
<built-in function all>, 'help': Type help() for interactive help, or
help(object) for help about object., 'vars': <built-in function vars>,
'SyntaxError': <type 'exceptions.SyntaxError'>, 'unicode': <type
'unicode'>, 'UnicodeDecodeError': <type
'exceptions.UnicodeDecodeError'>, 'isinstance': <built-in function
isinstance>, 'copyright': Copyright (c) 2001-2006 Python Software
Foundation.
All Rights Reserved.

Copyright (c) 2000 BeOpen.com.
All Rights Reserved.

Copyright (c) 1995-2001 Corporation for National Research Initiatives.
All Rights Reserved.

Copyright (c) 1991-1995 Stichting Mathematisch Centrum, Amsterdam.
All Rights Reserved., 'NameError': <type 'exceptions.NameError'>,
'dict': <type 'dict'>, 'input': <built-in function input>, 'oct':
<built-in function oct>, 'SystemExit': <type 'exceptions.SystemExit'>,
'StandardError': <type 'exceptions.StandardError'>, 'repr': <built-in
function repr>, 'sorted': <built-in function sorted>, 'False': False,
'RuntimeWarning': <type 'exceptions.RuntimeWarning'>, 'list': <type
'list'>, 'iter': <built-in function iter>, 'reload': <built-in function
reload>, 'Warning': <type 'exceptions.Warning'>, 'round': <built-in
function round>, 'dir': <built-in function dir>, 'cmp': <built-in
function cmp>, 'set': <type 'set'>, 'reduce': <built-in function
reduce>, 'intern': <built-in function intern>, 'issubclass': <built-in
function issubclass>, 'Ellipsis': Ellipsis, 'EOFError': <type
'exceptions.EOFError'>, 'locals': <built-in function locals>, 'slice':
<type 'slice'>, 'FloatingPointError': <type
'exceptions.FloatingPointError'>, 'sum': <built-in function sum>,
'getattr': <built-in function getattr>, 'abs': <built-in function abs>,
'exit': Use exit() or Ctrl-D (i.e. EOF) to exit, 'True': True,
'FutureWarning': <type 'exceptions.FutureWarning'>, 'ImportWarning':
<type 'exceptions.ImportWarning'>, 'None': None, 'hash': <built-in
function hash>, 'len': <built-in function len>, 'credits': Thanks to
CWI, CNRI, BeOpen.com, Zope Corporation and a cast of thousands
for supporting Python development. See www.python.org for more
information., 'frozenset': <type 'frozenset'>, '__name__':
'__builtin__', 'ord': <built-in function ord>, 'super': <type 'super'>,
'_': <bound method i18n.gettext of <rhpl.translate.i18n instance at
0xb7ce78ec>>, 'TypeError': <type 'exceptions.TypeError'>, 'license': See
http://www.python.org/2.5/license.html, 'KeyboardInterrupt': <type
'exceptions.KeyboardInterrupt'>, 'UserWarning': <type
'exceptions.UserWarning'>, 'filter': <built-in function filter>,
'range': <built-in function range>, 'staticmethod': <type
'staticmethod'>, 'SystemError': <type 'exceptions.SystemError'>,
'BaseException': <type 'exceptions.BaseException'>, 'pow': <built-in
function pow>, 'RuntimeError': <type 'exceptions.RuntimeError'>,
'float': <type 'float'>, 'MemoryError': <type 'exceptions.MemoryError'>,
'StopIteration': <type 'exceptions.StopIteration'>, 'globals': <built-in
function globals>, 'divmod': <built-in function divmod>, 'enumerate':
<type 'enumerate'>, 'apply': <built-in function apply>, 'LookupError':
<type 'exceptions.LookupError'>, 'open': <built-in function open>,
'quit': Use quit() or Ctrl-D (i.e. EOF) to exit, 'basestring': <type
'basestring'>, 'UnicodeError': <type 'exceptions.UnicodeError'>, 'zip':
<built-in function zip>, 'hex': <built-in function hex>, 'long': <type
'long'>, 'ReferenceError': <type 'exceptions.ReferenceError'>,
'ImportError': <type 'exceptions.ImportError'>, 'chr': <built-in
function chr>, 'xrange': <type 'xrange'>, 'type': <type 'type'>,
'__doc__': "Built-in functions, exceptions, and other objects.\n
\nNoteworthy: None is the `nil' object; Ellipsis represents `...' in
slices.", 'Exception': <type 'exceptions.Exception'>, 'tuple': <type
'tuple'>, 'UnicodeTranslateError': <type
'exceptions.UnicodeTranslateError'>, 'reversed': <type 'reversed'>,
'UnicodeEncodeError': <type 'exceptions.UnicodeEncodeError'>, 'IOError':
<type 'exceptions.IOError'>, 'hasattr': <built-in function hasattr>,
'delattr': <built-in function delattr>, 'setattr': <built-in function
setattr>, 'raw_input': <built-in function raw_input>, 'SyntaxWarning':
<type 'exceptions.SyntaxWarning'>, 'compile': <built-in function
compile>, 'ArithmeticError': <type 'exceptions.ArithmeticError'>, 'str':
<type 'str'>, 'property': <type 'property'>, 'GeneratorExit': <type
'exceptions.GeneratorExit'>, 'int': <type 'int'>, '__import__':
<built-in function __import__>, 'KeyError': <type
'exceptions.KeyError'>, 'coerce': <built-in function coerce>,
'PendingDeprecationWarning': <type
'exceptions.PendingDeprecationWarning'>, 'file': <type 'file'>,
'EnvironmentError': <type 'exceptions.EnvironmentError'>, 'unichr':
<built-in function unichr>, 'any': <built-in function any>, 'OSError':
<type 'exceptions.OSError'>, 'DeprecationWarning': <type
'exceptions.DeprecationWarning'>, 'min': <built-in function min>,
'UnicodeWarning': <type 'exceptions.UnicodeWarning'>, 'execfile':
<built-in function execfile>, 'id': <built-in function id>, 'complex':
<type 'complex'>, 'bool': <type 'bool'>, 'ValueError': <type
'exceptions.ValueError'>, 'NotImplemented': NotImplemented, 'map':
<built-in function map>, 'buffer': <type 'buffer'>, 'max': <built-in
function max>, 'object': <type 'object'>, 'TabError': <type
'exceptions.TabError'>, 'callable': <built-in function callable>,
'ZeroDivisionError': <type 'exceptions.ZeroDivisionError'>, 'eval':
<built-in function eval>, '__debug__': True, 'IndentationError': <type
'exceptions.IndentationError'>, 'AssertionError': <type
'exceptions.AssertionError'>, 'classmethod': <type 'classmethod'>,
'UnboundLocalError': <type 'exceptions.UnboundLocalError'>,
'NotImplementedError': <type 'exceptions.NotImplementedError'>,
'AttributeError': <type 'exceptions.AttributeError'>, 'OverflowError':
<type 'exceptions.OverflowError'>}
__file__: None
gtk: None
__name__: None
os: None
__doc__: None

PabloTwo
28th August 2007, 10:06 PM
Hi,

Have you tried: yum update system-config-network-tui

Paul

fishel
29th August 2007, 12:06 AM
I have already tried to remove and reinstall system-config-network.
system-config-network-tui is not a package.
-tui is not a valid option for yum.
-t did nothing.

anyway thanks for trying :)

PabloTwo
29th August 2007, 02:45 AM
Hi,

Sorry. system-config-network-tui is a package on FC6, which is what I use, and it installs system-config-network as part of the package. I guess it's a bit different with F7. And, that was some whopper of an error message. Good luck.

Paul

Iron_Mike
29th August 2007, 04:26 AM
Well to be honest upgrading from any major releases isn't recommended. It can be done but the recommended way is to install from the F7 release CD.......BTW the error looks like a python error which may be contributed to your upgrade route....

fishel
29th August 2007, 12:39 PM
I also think it's a python error.
Is there a way to "reload" python?
Without removing gnome also?

Thanks

ajoian
29th August 2007, 04:45 PM
Fedora 7 also has system-config-network-tui use that one is in the console mode and does not depend on the X interface.

fishel
30th August 2007, 12:43 PM
ajoian, thanks for clarifying this. system-config-network-tui does work, but my wireless controller doesn't show up in it.
Also I still have the python errors.
It seems to me a shortcoming of YUM is the lack of the ability to reinstall packages to repair a broken one, this way you don't have to uninstall/reinstall all the dependencies.

PabloTwo
30th August 2007, 01:51 PM
It seems to me a shortcoming of YUM is the lack of the ability to reinstall packages to repair a broken one, this way you don't have to uninstall/reinstall all the dependencies.

rpm -e --nodeps packagename

The above command will remove a package without removing the dependencies. You can then reinstall same package with yum.

Paul

fishel
11th September 2007, 06:56 AM
Well just to close this topic with the resolution:

I saw the error was in libgnomeui-2.so.0. I checked the version I had installed on my system was libgnomeui-2.19.1-1.fc8 (I assume fc8 stands for fedora 8. How it got I my system I dont know). So I did a rpm -e --nodeps libgnomeui, then a reinstalled libgnomeui and I was back in business.

Thanks all