PDA

View Full Version : file sysyem doesnot work, why? Please help



anyegongjue
26th August 2007, 03:01 AM
I use linux just for a short time. And one time I double cilck a *.exe file by mistake.

That EXE file is about installing a sound card drive in Windows system. After that, my language bar doesnot work. And I cannot open all the help document in any software.

The SELinux says that "SELinux is preventing access to files with the default label, default_t." and "Affected RPM Packages: procmail-3.22-19.fc7 [application]filesystem-2.4.6-1.fc7 [target]".

I really don't know about information that SELinux provide. I don't have enough knowledge about that.

So is there anyone can help me?

Thank you very much!

============================below is what SELinux tells me ==========================

Summary
SELinux is preventing access to files with the default label, default_t.

Detailed Description
SELinux permission checks on files labeled default_t are being denied.
These files/directories have the default label on them. This can indicate a
labeling problem, especially if the files being referred to are not top
level directories. Any files/directories under standard system directories,
/usr, /var. /dev, /tmp, ..., should not be labeled with the default label.
The default label is for files/directories which do not have a label on a
parent directory. So if you create a new directory in / you might
legitimately get this label.

Allowing Access
If you want a confined domain to use these files you will probably need to
relabel the file/directory with chcon. In some cases it is just easier to
relabel the system, to relabel execute: "touch /.autorelabel; reboot"

Additional Information

Source Context system_u:system_r:procmail_t
Target Context system_u:object_r:default_t
Target Objects root [ dir ]
Affected RPM Packages procmail-3.22-19.fc7
[application]filesystem-2.4.6-1.fc7 [target]
Policy RPM selinux-policy-2.6.4-8.fc7
Selinux Enabled True
Policy Type targeted
MLS Enabled True
Enforcing Mode Enforcing
Plugin Name plugins.default
Host Name localhost.localdomain
Platform Linux localhost.localdomain 2.6.20-2925.9.fc7xen
#1 SMP Tue May 22 08:53:03 EDT 2007 i686 i686
Alert Count 4
First Seen 2007年08月26日 星期日 11时41分11秒
Last Seen 2007年08月26日 星期日 12时00分03秒
Local ID 75846347-a55b-46b3-a2c6-6dd124c5bd72
Line Numbers

Raw Audit Messages

avc: denied { search } for comm="procmail" dev=sda3 egid=0 euid=0
exe="/usr/bin/procmail" exit=-13 fsgid=0 fsuid=0 gid=0 items=0 name="root"
pid=4648 scontext=system_u:system_r:procmail_t:s0 sgid=0
subj=system_u:system_r:procmail_t:s0 suid=0 tclass=dir
tcontext=system_u:object_r:default_t:s0 tty=(none) uid=0

markkuk
26th August 2007, 12:03 PM
The message you quoted in your post tells you what to do in the "Allowing Access" section. Just read and follow the instructions.