PDA

View Full Version : Installing third party driver – what am I doing wrong?



Thinpad
22nd August 2007, 03:59 PM
I’m trying to install this driver (http://sourceforge.net/projects/cayman3341/) which will allow me to use my USB router on my laptop (it has no Ethernet).

I chose to install the developer tools from the DVD when installing Fedora.

I downloaded the driver and copied it's SRC folder to root. The folder contains two files: cayman3341.c & Makefile

I opened the terminal and typed ‘cd src’

I then followed the instructions and typed ‘make’

This is what followed:

http://img501.imageshack.us/img501/7537/p8210020eh9.jpg

Anyone know what is up? Apologies if this is a very trivial question, I’m totally new to Linux and totally out of my depth.

This is my sixth day trying to work Fedora and I’m determined not to give up!

Here is the documentation from the driver:


Cayman 3341 USB linux driver
============================

About
-----
This is a driver for Netopia Cayman 3341 DSL modem/router for Linux 2.6.X.
Netopia Cayman 3341 is a DSL modem supplied by Irish telecommunication
company Eircom as a part of their DSL package.

Installation
------------
Go to directory src. Type:
make
sudo cp cayman3341.ko /lib/modules/`uname -r`/kernel/drivers/usb/net/
sudo depmod
After that you can plug the modem in and configure your new network device.

Release notes
-------------
0.3.0: Disconnect function implemented -- rmmod works fine now.
0.2.0: closing the network device works now - it is possible to do ifconfig
down and ifconfig up.
If an attempt to configure the network device is made too early after
plugging the device in, when the driver is not ready yet, it will
return -EAGAIN.
0.1.0: Functions well but does not unload. After the cable is unplugged or
the network interface is shut down, it is highly recommended to
reboot.


License
-------
This software is licensed under GNU General Public License v.2 or later.

Disclaimer
----------
This software was written by Petr Blahos <pblahos@sourceforge.net> without
any help or support from Netopia. Netopia on the contrary refused to provide
any information leading to successful implementation of the driver.

This driver is based on rtl8150.c which is a part of the kernel tree.

The author of this software takes no responsibility whatsoever for any damage
imposed by installing or using this software.

PatMcLJr
22nd August 2007, 04:50 PM
kinda looks like it's giving you the answer

“incompatible”

maybe ubuntu or Debian ? I have had good luck with Slackware and oddball hardware.

Best of Luck,
Pat Jr.

Thinpad
22nd August 2007, 09:13 PM
Thanks for the input.

It is designed for Linux; I would have thought that would allow it to work on any distribution. It would be a shame if it’s not compatible since I’ve spent so much time trying to get it to work with Fedora.

Anyone else have any ideas?

leigh123linux
22nd August 2007, 09:32 PM
try ( fedora dropped this file in fc6 )

su -
touch /usr/src/kernels/2.6.21-1.3194.fc7-i686/include/linux/config.h

markkuk
22nd August 2007, 09:43 PM
The driver code isn't compatible with current Linux kernels, the file config.h was dropped around version 2.6.20 not just from Fedora but from the mainline kernel (a.k.a "vanilla" kernel). The driver code in Sourceforge hasn't been updated since 2004 so it looks abandoned. If you can't get anyone experienced in Linux driver development to fix the code, you need to get different hardware with working and maintained Linux support.

Thinpad
22nd August 2007, 09:48 PM
Ah... so I'm screwed :(

Oh well.

Would I perhaps be able to load an older version of Fedora on that would be compatible?

If so, do you know which version might be compatible?

Thanks!

Thinpad
23rd August 2007, 10:06 PM
There is no way I can get a hold of the config.h file and use it with the current version, is there?

I'm guess that Fedora Core 3 might be compatible with this driver, so I might try giving that download...

leigh123linux
23rd August 2007, 10:26 PM
There is no way I can get a hold of the config.h file and use it with the current version, is there?

I'm guess that Fedora Core 3 might be compatible with this driver, so I might try giving that download...

have you tried this ( it creates a config.h file so you can compile )


su -
touch /usr/src/kernels/2.6.21-1.3194.fc7-i686/include/linux/config.h

Thinpad
24th August 2007, 03:25 PM
Thanks for helping me Leigh

I followed your instruction at the time, but nothing happened after I typed it so I wasn’t sure what to do.

I typed out the same thing today and attempted to compile, but unfortunately I just got a new error:

http://img249.imageshack.us/img249/7336/p8230026tk3.jpg

:(

leigh123linux
24th August 2007, 03:59 PM
have you tried

su
make clean
./configure
make
make install

Thinpad
24th August 2007, 04:39 PM
No luck unfortunatly. This time:

‘No rule to make target ‘clean’

http://img406.imageshack.us/img406/7170/p8230028fw1.jpg

Hopelessly
31st August 2007, 04:26 AM
I'm a gentoo user, but I've been trying to get the exact same device working (with the exact same drivers) for the last day or so.

I've had some luck, in that I've been able to get the module to compile and load, however it's not working quite right, I think the main problem is it's not getting the mac address from the router.

To get it to compile, simply comment out the three lines that are giving errors (the first two are depreciated and unneeded, but I'm not so sure about the last.

With it I've been able to ping other machines on the ethernet, but most other packets are lost.

Thinpad; is this by any chance an eircom supplied router, and if so do you know what firmware you are using?