PDA

View Full Version : Enabling local filesystem quotas



albi123
21st August 2007, 09:04 PM
When I start up Fedora core 6, it goes up the point where it says "Enabling local file system quotas" and then doesn't go any further than that. I hit Ctrl alt backspace and got this:


/etc/rc.d/rc.sysinit: line927: 1340 segmentation fault rm -rf
/tmp/.X*-unix /tmp/.ICE-unix /tmp/.font-unix /tmp/hsperfdata_*
/tmp/Kde-* /tmp/Ksocket-* /tmp/mc-* /tmp/mcop-* /tmp/orbt-*
/tmp/scrollkeeper-* /tmp/ssh-* /dev/.in_sysinit

I have been using Fedora core 6 for about a year now and this is the first time I have had this problem.

PhillyFloyd
15th September 2007, 02:49 AM
thats from /etc/rc.d/rc.sysinit when it checks if /sbin/quotaon exists and if it does it tries to enable it -- it even spits it out there, line 927:

you can turn off system quotas, chmod 000 the quotaon executable etc ... however it looks like it had issues with the stuff just after quota checks which is he Clean up various /tmp bits and it seg faults ...


878 # Clean up various /tmp bits
879 [ -n "$SELINUX_STATE" ] && restorecon /tmp
880 rm -f /tmp/.X*-lock /tmp/.lock.* /tmp/.gdm_socket /tmp/.s.PGSQL.*
881 rm -rf /tmp/.X*-unix /tmp/.ICE-unix /tmp/.font-unix /tmp/hsperfdata_* \
882 /tmp/kde-* /tmp/ksocket-* /tmp/mc-* /tmp/mcop-* /tmp/orbit-* \
883 /tmp/scrollkeeper-* /tmp/ssh-* \
884 /dev/.in_sysinit


can you post what comes before and after those messages you posted