View Full Version : fuse group missing (FC7)

21st August 2007, 06:45 AM

I am trying to mount a remote drive using fuse and sshfs. I installed both and I can mount the remote drive -- but only as root. Its clearly a permission issue since I get a "permission denied" when I try to brows the mounted drive as a user. I know that I am supposed to add my user to the fuse group but there is no such group (checked under system -> Administration -> Users and Groups).

From what I read fuse is supposed to create a fuse group once its installed, but in my case such group was not created. I am using fuse 2.7.0 -3 and fuse-sshfs 1.7-2.

Has anyone encountered this problem? ANy suggestions would be highly appreciated!


21st August 2007, 07:04 AM
When you are running the Users and Groups application (system-config-users), uncheck the "Hide system users and groups" box in Edit->Preferences. "fuse" is a system group and it's not displayed by default.

21st August 2007, 07:25 AM
Thanks markkuk!

It worked like a charm! the only change I had to make is to the permissions of the mount point which I did with chmod a+w /your_mount_point

Thanks again!