PDA

View Full Version : gnome panel text problem



awelch
21st August 2007, 04:31 AM
Hi, I've been trying to just simply change the gnome panel text color from black to white. I tried doing this under my regular user name and it didn't work:
--------------------------------------------------------------------------------------------------------
To change the text colour in the Gnome panel, do the following:

Type “gedit .gtkrc-2.0″ without the quotes in a terminal window.

In the gedit window, insert the following text:

style “panel”
{
fg[NORMAL] = “#ffffff”
# fg[PRELIGHT] = “#000000?
# fg[ACTIVE] = “#ffffff”
# fg[SELECTED] = “#000000?
# fg[INSENSITIVE] = “#8A857C”
# bg[NORMAL] = “#000000?
# bg[PRELIGHT] = “#dfdfdf”
# bg[ACTIVE] = “#D0D0D0?
# bg[SELECTED] = “#D8BB75?
# bg[INSENSITIVE] = “#EFEFEF”
# base[NORMAL] = “#ffffff”
# base[PRELIGHT] = “#EFEFEF”
# base[ACTIVE] = “#D0D0D0?
# base[SELECTED] = “#DAB566?
# base[INSENSITIVE] = “#E8E8E8?
# text[NORMAL] = “#161616?
# text[PRELIGHT] = “#000000?
# text[ACTIVE] = “#000000?
# text[SELECTED] = “#ffffff”
# text[INSENSITIVE] = “#8A857C”
}
widget “*PanelWidget*” style “panel”
widget “*PanelApplet*” style “panel”
class “*Panel*” style “panel”
widget_class “*Mail*” style “panel”
class “*notif*” style “panel”
class “*Notif*” style “panel”
class “*Tray*” style “panel”
class “*tray*” style “panel”class “*tray*” style “panel”

Notice the third line has no hash (#) symbol in front of the text. This is because this line has been uncommented. This is the command Gnome uses to determine what colour the panel text should be. In this case, “#ffffff” makes it white.

Save the document and close gedit.

Now type “killall gnome-panel” in the terminal window, again without quotes. the Gnome panel should restart and the text will be white. Now, if the text colour didn’t change when you did all the above, it’s possibly because cutting and pasting from this blog may have caused the quotation marks in the text above to be the wrong type for Gnome to interpret. Reopen the gtkrc-2.0 file and use the find/replace menu item to replace every quote mark.
--------------------------------------------------------------------------------------------------------
Then I did the same exact thing after logging out and logging in as root and it worked. Then I logged back in my regular username and tried it again, and again it didn't work. Why will this work logged in as root, but not logged in regularly and how do I fix this? Thanks.

tashirosgt
21st August 2007, 07:00 PM
I notice on my RHEL 4.0 machine these .gtkrc* files have a notation that they are written by the "gnome-settings-daemon'. Perhaps when you save the file as an ordinary user, some process may have permission to rewrite it and when you save the file as root, it cannot be overwritten. What are the permissions on the file? When you say that "this will work", does this mean the file is changed when you are an ordinary user but the color doesn't change. Or does something change the file back to having black text?