PDA

View Full Version : Samba Not Working



davidedwardgill
20th August 2007, 09:49 PM
Hello

It's been a LONG time since I have had to set up a Samba server and it looks like I forgot how to ride the bike. I'm trying to set up a server to share some files, and I can't get it to appear on the network let alone share a fine :(!

Anyway, here is my smb.conf file:

[root@localhost Dave]# more /etc/samba/smb.conf
# Samba config file created using SWAT
# from 127.0.0.1 (127.0.0.1)
# Date: 2004/01/07 16:27:19

[global]
workgroup = PCKNIGHTS
netbios name = knightServe
guest ok = Yes
hosts allow = 192.168.1.0/255.255.255.0

os level = 32
local master = yes
encrypt passwords = yes
update encrypted = yes
null passwords = yes
guest account = KnightGuest

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[XPCD]
comment = Windows XP SP2
path = /home/Dave/XPCD
guest ok = yes
browseable = yes

Here is the print out of testparm

[root@localhost Dave]# testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[printers]"
Processing section "[XPCD]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
workgroup = PCKNIGHTS
netbios name = KNIGHTSERVE
update encrypted = Yes
null passwords = Yes
guest account = KnightGuest
os level = 32
guest ok = Yes
hosts allow = 192.168.1.0/255.255.255.0

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[XPCD]
comment = Windows XP SP2
path = /home/Dave/XPCD

Why in the world are they different? Any assistance would be greatly apprechiated!

bbfuller
20th August 2007, 10:20 PM
Hello davidedwardgill

There is one thing that might catch the unwary out with Samba on Fedora 7 where it is different to earlier Fedoras.

When you enable the server in services, previously you had to just enable smb and it enabled nmb automatically.

Now you have to start each service independently.