PDA

View Full Version : help with WPA key...



HMSS013
19th August 2007, 03:02 AM
trying to use a linksys that has a WPA key using my FC7 laptop...but the network manager does not give me the option under the key type...

the wpa_supplicant package is installed by default...

stevea
19th August 2007, 04:42 AM
Yeah well I use two Linksys w/ WPA in my house, My laptops are F7. Both use NetworkManager and I'm having zero problems (were FC6).

*WHICH * Linksys ? Which WPA settings are you using ? How are you entering the key s to NM ?

HMSS013
19th August 2007, 05:18 AM
WRT54G using WPA

select the network with NerworkManager and the box only lets me use WEP and LEAP...

stevea
19th August 2007, 07:24 AM
Really ? left click the NM icon, select "connect to other wireless network", fill in the essid and select one of the 8 or 9 wep/wpa/leap methods. No ?

If your WRT54G (I have a G and a GS) will take it - I'd suggest the DD-WRT firmware. It's miles better than the linksys firmware.

stevea
19th August 2007, 07:26 AM
Oh yeah - I have had problems w/ WPA when the ESSID is hidden. Don't hide the ESSID. You can hunt the Cisco website - they say it offers no security and a lot of bother.

stevea
19th August 2007, 07:55 PM
sorry, duplicate.

HMSS013
20th August 2007, 03:47 AM
Really ? left click the NM icon, select "connect to other wireless network", fill in the essid and select one of the 8 or 9 wep/wpa/leap methods. No ?

If your WRT54G (I have a G and a GS) will take it - I'd suggest the DD-WRT firmware. It's miles better than the linksys firmware.



select the network on the list... and the dropdown menu only offers WEP/Leap

Iron_Mike
20th August 2007, 12:07 PM
This is exactly right selecting the AP and using the drop down menu, BUT even if your AP is listed, try selecting "Connect to other network" and fill in the blanks, under security it will have wpa/wpa2 in the list.....

HMSS013
21st August 2007, 11:30 PM
This is exactly right selecting the AP and using the drop down menu, BUT even if your AP is listed, try selecting "Connect to other network" and fill in the blanks, under security it will have wpa/wpa2 in the list.....

once again... that drop down menu does not have wpa/wpa2 just wep128/wep64hex/wep64ascii/leap

Iron_Mike
21st August 2007, 11:59 PM
You need to verify that the wpa_supplicant is installed. You said in the 1st msg that it is, but you need to check:

rpm -qa wpa_supplicant

it might be installed but the wpa_supplicant.conf file might be missing

HMSS013
22nd August 2007, 12:29 AM
wpa_supplicant is installed...

the problem seems that the wpa_supplicant service fails to start...

i have two different readouts from different attempts to start the wpa_supplicant service...

from trying to launch it from the "Services" Configuration:

wpa_supplicant failed. The error was: Starting wpa_supplicant: ioctl[SIOCSIWPMKSA]: No such device

ioctl[SIOCSIWMODE]: No such device
ioctl[SIOCGIFFLAGS]: No such device
ioctl[SIOCGIWRANGE]: No such device
ioctl[SIOCGIFINDEX]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device



from trying to start it using the command prompt:

/bin/bash: line 1: 2021 Segmentation fault wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dndiswrapper -B
[FAILED]


Starting wpa_supplicant: Failed to read or parse configuration '/etc/wpa_supplicant/wpa_supplicant.conf'.
/bin/bash: line 1: 2241 Segmentation fault wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dndiswrapper -B
[FAILED]

HMSS013
22nd August 2007, 08:38 PM
after altering the wpa_supplicant.conf string from '-iwlan0' to '-iweth1' that seems to remedy the failure to start the wpa_supplicant service... but it still returns these errors

ioctl[SIOCSIWMODE]: No such device
ioctl[SIOCGIFFLAGS]: No such device
ioctl[SIOCGIWRANGE]: No such device
ioctl[SIOCGIFINDEX]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device

and still... no WPA options on any of the connection dropdown menus

Iron_Mike
22nd August 2007, 11:51 PM
Turn off the service and reboot the computer. Open a terminal window and su - (su dash) for root priv and paths. Now type:

wpa_supplicant -Dwext -ieth1 -c/etc/wpa_supplicant/wpa_supplicant.conf -dd

What happens then?? Next for testing purposes, change your wpa passphrase to something simple like "workaholic" straight ascii no wierd control characters and try it again....

BTW what brand is your wireless device??

HMSS013
23rd August 2007, 12:07 AM
[root@localhost ~]# wpa_supplicant -Dwext -ieth1 -c/etc/wpa_supplicant/wpa_supplicant.conf -dd
Initializing interface 'eth1' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group='wheel' (DEPRECATED)
Line: 4 - start of a new network block
ssid - hexdump_ascii(len=3):
61 6e 79 any
key_mgmt: 0x4
Priority group 0
id=0 ssid='any'
Initializing interface (2) 'eth1'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
SIOCGIWRANGE: WE(compiled)=22 WE(source)=14 enc_capa=0x0
capabilities: key_mgmt 0x0 enc 0x3
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:02:2d:24:c3:ae
wpa_driver_wext_set_wpa
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x1 - Driver does not support WPA.
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
ioctl[SIOCSIWENCODEEXT]: Operation not supported
Driver did not support SIOCSIWENCODEEXT, trying SIOCSIWENCODE
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
ioctl[SIOCSIWENCODEEXT]: Operation not supported
Driver did not support SIOCSIWENCODEEXT, trying SIOCSIWENCODE
ioctl[SIOCSIWENCODE]: Invalid argument
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
ioctl[SIOCSIWENCODEEXT]: Operation not supported
Driver did not support SIOCSIWENCODEEXT, trying SIOCSIWENCODE
ioctl[SIOCSIWENCODE]: Invalid argument
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
ioctl[SIOCSIWENCODEEXT]: Operation not supported
Driver did not support SIOCSIWENCODEEXT, trying SIOCSIWENCODE
ioctl[SIOCSIWENCODE]: Invalid argument
wpa_driver_wext_set_countermeasures
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - wpa_driver_wext_set_drop_unencrypted
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - Setting scan request: 0 sec 100000 usec
Using existing control interface directory.
ctrl_interface_group=10 (from group name 'wheel')
ctrl_iface bind(PF_UNIX) failed: Address already in use
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/eth1' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

Failed to add interface eth1
State: DISCONNECTED -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_wext_set_wpa
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x0 - Failed to disable WPA in the driver.
wpa_driver_wext_set_drop_unencrypted
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x0 - wpa_driver_wext_set_countermeasures
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - No keys have been configured - skip key clearing
Segmentation fault

HMSS013
23rd August 2007, 12:10 AM
Turn off the service and reboot the computer. Open a terminal window and su - (su dash) for root priv and paths. Now type:

wpa_supplicant -Dwext -ieth1 -c/etc/wpa_supplicant/wpa_supplicant.conf -dd

What happens then?? Next for testing purposes, change your wpa passphrase to something simple like "workaholic" straight ascii no wierd control characters and try it again....

BTW what brand is your wireless device??



1. this isn't my router, i am not going to change any settings... the problem is not with the router so the remedy is not in altering the router settings... it works fine with other machines...

2. the passphrase is already a simple all one word lower case format

3. if i cant pull down WPA in the dropdown box i cant really try connecting now can i....

Iron_Mike
23rd August 2007, 11:39 AM
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

Delete '/var/run/wpa_supplicant/eth1' manually if it is not used anymore

See this part here you already have a copy of the supplicant running, OR there is a "socket" that hasn't been deleted.

jrbell
29th August 2007, 11:58 AM
ctrl_iface bind(PF_UNIX) failed: Address already in use
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/eth1' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

From your error messages one would think that if you deleted /var/run/wpa_supplicant/eth1 and retry the test it might work. My two cents.