PDA

View Full Version : Fedora 7 + Beryl + Nvidia Drivers = Problems



TimNC
18th August 2007, 04:24 PM
OK, so I haven't touched Linux since the 90s so please bear with me. A lot has changed since Slackware 3 :p

I downloaded the iso for Fedora 7 and installed it on my notebook. My notebook is an Acer Aspire 9800 with a Nvidia GeForce Go 7600. My install was good and X started and my resolution was supported and everything.

Then I installed Beryl, and I got the "white screen" after starting it. I saw that I could spin the cube, but every side but the top and bottom was white. After some googling I saw a lot of people suggested to update the video drivers. Checking the X setting, my driver was some sort of RIVA TNT driver being used so I figured it would pay to update.

So I downloaded the NVIDIA-Linux-x86-1.0-9755.pkg1.run and edited my startup to a command prompt instead of X, typed "sh NVIDIA-Linux-x86-1.0-9755.pkg1.run" and went through their wizard where it claims it recompiled my kernel. When it was done I tried to start X and it failed. I rebooted just to make sure, slapped myself because this isn't Windows I shouldn't have to do that, and tried it again. Same problem.

So here is what my error log says:


(EE) Failed to load module "glx" (module does not exist, 0)
(EE) Failed to load module "nvidia" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found


So being so long since I've been involved with Linux and afraid my troubleshooting may make it worse, I decided to come to the community for help.

If I haven't provided enough information just ask and I'll get you what you need.

--tim

Dangermouse
18th August 2007, 04:34 PM
Hello from what i have heard so bear in mind i might be totally wrong, and if anyone knows better please correct me, is that the native drivers just dont work very well, and ive no idea how you can remove the drivers you have installed but here is what i think would of been better
This guide works for both 32 and 64 bit
For FX cards or newer


su -
rpm -ivh http://rpm.livna.org/livna-release-7.rpm
yum -y install kmod-nvidia xorg-x11-drv-nvidia-libs-32bit
nvidia-config-display enable
service nvidia restart


For MX cards


su -
rpm -ivh http://rpm.livna.org/livna-release-7.rpm
yum -y install kmod-nvidia-96xx xorg-x11-drv-nvidia-96xx-libs-32bit
nvidia-96xx-config-display enable
service nvidia-96xx restart


These guides will probably update you to the latest available kernel as well, and also if the kernel is updated a restart will be needed instaed of

service nvidia restart

TimNC
18th August 2007, 09:48 PM
Ok Dangermouse I tried the first option you gave and reboot and IT WORKS! I get the NVIDIA logo when X starts and Beryl works like a champ! The only odd thing is under Display Settings / Hardware it says my Vido Card is Unknown and if I click on Configure it says I'm using "nvidia - Vendor-supplied driver for nvidia cards".

If that's the way it should be then I'm all good.

Thanks for the help.