View Full Version : cdrw drive won't mount?

23rd February 2004, 02:11 AM
I have tried to mount the cdrw drive from right-clicking the desktop and selecting cdrom. I get an error message telling me that my cdrom is not a format that can be read.

I have tried audio cd's and backup data cd's. What could be the problem? The drive is detected when I open up Sound Juicer CD Ripper that is included with Fedora. I haven't done anything different to the OS or hardware.

23rd February 2004, 04:11 AM

Are you in Gnome or KDE? Can you type mount /dev/hdx (where x is the device) /mnt/cdrom ?

23rd February 2004, 04:15 AM
Also check your /etc/fstab and make sure that it makes sense with the proper dev device being your cdrom drive.

23rd February 2004, 06:47 AM
For GNOME, go to Preferences -> CD Properties and from there you can check the boxes for "Mount CD when Inserted". Then, just simply insert the CD and a CD icon will pop up on the desktop with the CD automounted. To unmount just right-click the icon and select eject.

24th February 2004, 05:18 AM
I have tried typing /mnt/cdrom in Terminal and I get the error message,

bash: /mnt/cdrom: is a directory

Then I checked under Gnome, CD Properties and everything was checked. Since installing Fedora, I have never had the cd mounted automatically. I always get the error that it is not in a format that can be read. I just don't get it since the other app, Sound Juicer, detects the drive. Odd.

13th March 2004, 07:51 AM
Is there a file that I need to edit? My cdrw is the only optical drive in this PC. I'm confused b/w scsi and ide entries that I need to enter. Why does sound juicer detect the drive but no where else can I mount the drive?

13th March 2004, 06:06 PM
Serpico, post here your CDROM entries in your /etc/sysconfig/hwconf file. For each CDROM there will be a 'class: CDROM' entry.

Also post here the contents of your /etc/fstab and /boot/grub/grub.conf, oh yeah and your /mnt/ folder.

I take it you are using grub right?

13th March 2004, 07:36 PM
Thanks. Sorry for the long post.
Here is what's listed under /etc/sysconfig/hwconf :

class: CDROM
bus: IDE
detached: 0
device: hdc
driver: ignore
desc: "YAMAHA CRW8424E"

Here is what's listed for /etc/fstab :

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda5 swap swap defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hda1 /mnt/c vfat users,owner,rw,umask=000 0 0
/dev/hdb1 /mnt/d vfat users,owner,rw,umask=000 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0

Here is the info from /boot/grub/grub.conf :

# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,1)
# kernel /vmlinuz-version ro root=/dev/hda3
# initrd /initrd-version.img
title Fedora Core (2.4.22-1.2174.nptl)
root (hd0,1)
kernel /vmlinuz-2.4.22-1.2174.nptl ro root=LABEL=/ hdc=ide-scsi rhgb
initrd /initrd-2.4.22-1.2174.nptl.img
title Fedora Core (2.4.22-1.2115.nptl)
root (hd0,1)
kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/ hdc=ide-scsi rhgb
initrd /initrd-2.4.22-1.2115.nptl.img
title DOS
rootnoverify (hd0,0)
chainloader +1

In my /mnt folder I have :
C (windows xp partition - fat32)
D (fat32 second hard disk)

Hope you guys can help. Thanks.

14th March 2004, 01:44 PM
Your hwconf CDROM entry is wrong.

Your grub config is fine. It has 'hdc=ide-scsi' which is correct.

Your fstab entry is wrong.

Do the following
1. As root in a console type '/sbin/insmod ide-scsi'

2. As root edit the /etc/fstab and modify the existing entry for cdrom to this:-

/dev/scd0 /mnt/cdrom udf,iso9660 noauto,owner,kudzu 0 0

3. Reboot.

Open /etc/sysconfig/hwconf and you should see an entry now like this:-

class: CDROM
bus: SCSI
detached: 0
device: scd0
driver: ignore
desc: "YAMAHA CRW8424E"
host: 0
id: 0
channel: 0
lun: 0
generic: sg0

4. As root in a console type 'cdrecord -scanbus' and you should see your CD-RW on 0,0,0

That should be it :)

14th March 2004, 05:38 PM
I tried your suggestions and everything seemed to be ok until after the reboot. I checked the files again and nothing got saved. The /etc/fstab file went back to the original state without the modification you asked me to type in. Which of course everything else, like the /etc/sysconfig/hwconf stayed the same.

I was logged in as root through terminal of course or else it wouldn't have let me saved. But I will try one more time your suggestion before giving up! :)

14th March 2004, 06:43 PM
Serpico, if this doesn't work then there is a problem, because I have just successfully done this on my own computer, but my CD-RW was hdd, still it should still work out the same.

What happens is when you boot-up, kudzu should recognise that your CD-ROM is a CD-RW and that it should be listed as bus:SCSI in hwconf. If this isn't happening, perhaps kudzu does not recognise your particular make of CD-RW.

There's one difference between mine and your grub.conf which is probably irrelevant but still it's different, is that your root commands read 'root=LABEL=/ hdc=ide-scsi rhgb' whereas mine reads 'root=LABEL=/ rhgb hdc=ide-scsi' (ok mine is hdd but I've altered it here to show you the difference). The reason it's different is because I added the ide-scsi option myself manually.

14th March 2004, 06:54 PM
I'm confused now b/c as I earlier posted, Sound Juicer detects the cdrw but Nautilus gives me an error message when trying to mount it.

"Nautilus was unable to mount the selected volume. The volume is probably in a format that cannot be mounted."

The only thing I got in there right now, is an audio cd for testing purposes. What is making kudzu not remembering the file change and going back to IDE instead of SCSI? From everything I've read and done, it seems that both are indicated but in different locations. Nothing is the same throughout. Very odd and confusing.

I'll continue to try...

Update: just tried Sound Juicer again and not it says not cd-roms detected. But how can /etc/sysconfig/hwconf find it correctly?

16th March 2004, 12:37 PM
I have the same problem after installing a new kernel (2.6.4). With the old kernel (2.4.22 or smth like that) everything was all right.

And simcon's method didn't help me too.

Any more ideas?

The drive is not detected (like simcon's drive is) when I open up Sound Juicer CD Ripper.

But I get the error:
Nautilus was unable to mount the volume. There is probably no media in the device.

And after pressing Details it sais:
mount: /dev/cdrom is not a valid block device

16th March 2004, 03:59 PM
From what I have experienced, Nautilus will not mount from the desktop when I have an audio cd in the drive. But after changing /dev/cdrom in the /etc/fstab file to /dev/hdc and moving it up before the mounted fat32 partitions, it worked again in Sound juicer. I was able to rip a song into a Ogg file (no mp3 built-in codec) and play it with no problems.

I don't have a data cd that is readable in Fedora, but put one in anyway and went through Nautilus to /mnt/cdrom in the directory. It allowed me to click with no error's, but of course the cd was not readable and did not show any information. But like I said, this time I didn't get any errors about mounting.

The only time I get an error is mounting the cdrom from the desktop. So for all I know it could be a bug. Hope this sheds some light to others.

16th March 2004, 04:43 PM
I removed the link /dev/hdc with the command
rm -rf /dev/hdc
and now I cannot access cdrw in the old kernel too.
How can I relink (or whatever it is) it???

Stupid me!

17th March 2004, 11:57 AM
serpico: I think it best if you thoroughly scanned through your log files for any pertinent info. Run this in a terminal:

tail -f /var/log/messages

This will keep at active watch on the log file and print out each ebtry as it appears. Then go and try to mount a CD or any similar CDRW activity and watch the terminal for an idea what's happening in the logs. For a pleasant GUI interface to this, run System oTools -> System Logs.

PetzZz: The `MAKEDEV` program will recreate this device for you. You have to run it from /dev directory. See `man MAKEDEV` for details.

20th March 2004, 09:09 AM
I got mine to work with 2.6.4-ck1 made from the source from www.kernel.org and a patch.

1) configuring the kernel right: Read through the options and press ? if in menuconfig to see the help and you should be able to do this. I knew from past experience and have got the cd to work in several other distros with no problems so it isn't a kernel thing unless you configured it wrong. Something is set wrong within fedora.

2) Edit your fstab and smartd.conf so they are looking in the right place. I am not sure that smartd is necessary, but I did it and now I get no errors from it anymore either. If you have an atapi cd-rom it will go to a hdc or something like that instead of sd1 or something like that. You need to set this in /etc/fstab so it works right with other stuff in fedora. I never had to do this with slackware. but then slackware 9.1 is ready for kernel 2.6. Fedora core 1 really isn't.

3) Now for what made it work. I had to edit grub.conf and take out the reference to ide-scsi from the 2.6.4-ck1 kernel entry. If you don't have a scsi drive you don't need this option with kernel > 2.6 as writing is supported inherently for these drives by the kernel.

4) that was it. Very annoying to figure out.


I forgot to add that I also disabled kudzu because it kept trying to stop my ethernet card. I compiled the driver into the kernel and that is most likely why that was happening. I don't know if kudzu has any affect over the cd-rom. I might of left something out from above also as I was just jumping through configs looking for problems. I don't think I did though.

21st March 2004, 11:11 PM
Originally posted by kongit
I got mine to work with 2.6.4-ck1
I got mine too now, with it. Thank you for mentioning it in the Kernel 2.6 in FC1 HOWTO.