PDA

View Full Version : User acess for CD Writing



gala_dragos
16th August 2007, 09:08 AM
Hi! I think this is another one of those black holes in linux documentation/usage. I wanna use my DVD-RW and CD-RW without being root, but guess what, YOU CAN'T :confused: :mad: . I've been searching with google "set CDROM permissions in fedora" and all the pages that appeared were about installing fedora from CD. :mad: LOL!!!!! So can anybody explain how to set up DVD-RW permissions so I can write CD's in user mode? :D

Wayne
16th August 2007, 09:13 AM
Really, I guess my Fedora 7 install must be broken then, as I can write CDs and DVDs just fine as 'Joe User' Maybe you need to give a bit more info.

Wayne

gala_dragos
16th August 2007, 09:30 AM
It's simple: until now I've been using root to burn CD's, but now I am trying to burn as another user (not root) and it doesn't work. Program asks for permissions to sg0, sg1 and sg2 devices. There is no entry in fstab about those devices.

Wayne
16th August 2007, 09:35 AM
That's why I asked for more info. What version of Fedora, KDE or Gnome, What's the ID of the drive on the BUS, what burning program you're using?

I had similar trouble with GnomeBaker, it automatically set the drive as device sr0 in its preferences and would throw up errors when trying to burn, but the drive is really scd0. It could be something as simple as changing the device name.

Wayne

gala_dragos
16th August 2007, 09:36 AM
Fedora7, KDE interface, burning software: NERO for Linux 3

gala_dragos
16th August 2007, 09:38 AM
k3b complains that cdrecord and cdrao should be run with root permissions

a_small_cake
16th August 2007, 09:45 AM
I never use root for burning cd/dvd. My user can do that without problems.

gala_dragos
16th August 2007, 09:50 AM
Is it just me? Or I'm the only one having this problem?

markkuk
16th August 2007, 10:34 AM
Check the "Don't show this message again" box and k3b works without problems.

gala_dragos
16th August 2007, 10:46 AM
how about making nero to run in user mode? anybody knows how to change permissions for those devices?
why nero? because k3b gives me only maximum burning speed for DVD and I don't wanna burn at 18x.

LocutusOfBorg
16th August 2007, 11:01 AM
No experience with nero here, but when it comes to device permissions I use a custom set of udev rules so that my optical drives are always 666.
With K3b you can select burning speed in the "burn" dialog (instead of "auto", choose what you want); as for the root permission for cdrdao/wodim, if you have k3bsetup it can do it for you - otherwise you can set them suid root manually.

EDIT, sorry, I didn't see your other thread about speed - but maybe it is related to the permission issue... can you set the speed as root?

gala_dragos
16th August 2007, 11:49 AM
no I can't set speed as root. This is valid only for DVD disks, CD disk have no problems. I only get three speed options with DVD disks: Auto/Ignore/maximum_medium_supported_speed. That is if In put an 8x DVD I get 8x DVD write speed there, and if I put 16x DVD I get 16x DVD write speed.

gala_dragos
16th August 2007, 11:50 AM
You were right about permissions! I've set all sg devices with 666 and it works.

gala_dragos
16th August 2007, 12:06 PM
from where do you download k3bsetup?

LocutusOfBorg
16th August 2007, 01:01 PM
It's part of K3b, but the fedora version is built without it. You can rebuild the srpms, if you want it.

gala_dragos
16th August 2007, 02:22 PM
done an upgrade from 1.0.1 to 1.0.3 and now I don't get those messages. Also the speed thing has resolved. Now I'm getting more writing speed options for dvd's.

Thanks

jim1944
31st December 2008, 09:29 PM
You were right about permissions! I've set all sg devices with 666 and it works.
I'm running into the same problem. I can mkisofs as normal user but cannot cdrecord unless I'm root. What I'm wondering is if in my situation I should set permission of sr0 to 666 to get around the problem. Here's a partial ls -l /dev


total 0
crw------- 1 root root 10, 175 2008-12-31 14:33 agpgart
crw------- 1 root root 10, 134 2008-12-31 14:33 apm_bios
crw-rw----+ 1 root root 14, 4 2008-12-31 14:34 audio
drwxr-xr-x 2 root root 120 2008-12-31 14:34 bsg
drwxr-xr-x 3 root root 60 2008-12-31 14:34 bus
lrwxrwxrwx 1 root root 3 2008-12-31 14:34 cdrom -> sr1
lrwxrwxrwx 1 root root 3 2008-12-31 14:34 cdrom1 -> sr0
lrwxrwxrwx 1 root root 3 2008-12-31 14:34 cdrw1 -> sr0
crw------- 1 root root 5, 1 2008-12-31 14:33 console
<...snip...>
drwxr-xr-x 2 root root 180 2008-12-31 14:34 snd
brw-rw----+ 1 root disk 11, 0 2008-12-31 14:33 sr0
brw-rw----+ 1 root disk 11, 1 2008-12-31 14:33 sr1
lrwxrwxrwx 1 root root 15 2008-12-31 14:34 stderr -> /proc/self/fd/2
lrwxrwxrwx 1 root root 15 2008-12-31 14:34 stdin -> /proc/self/fd/0
lrwxrwxrwx 1 root root 15 2008-12-31 14:34 stdout -> /proc/self/fd/1
<...etc...>

What I'm thinking is that because cdrw1 is a link to sr0, that I should set permissions of sr0 to 666. Does that make sense?

I know there's a gui CD burner for gnome desktop but I'm using Xfce. Is there a gui for burning CDs in Xfce that would not require changing permissions?

Thanks
Jim

jim1944
1st January 2009, 04:49 PM
I'm running into the same problem. I can mkisofs as normal user but cannot cdrecord unless I'm root. What I'm wondering is if in my situation I should set permission of sr0 to 666 to get around the problem.

<...snip...>

What I'm thinking is that because cdrw1 is a link to sr0, that I should set permissions of sr0 to 666. Does that make sense?

I know there's a gui CD burner for gnome desktop but I'm using Xfce. Is there a gui for burning CDs in Xfce that would not require changing permissions?

Thanks
Jim

I found a better way as suggested by "Red Hat Fedora 4 Unleashed". As root:

# groupadd cdrw
# chgrp cdrw /dev/sr0
# usermod -G cdrw <user>
This creates a new group, cdrw, changes the group ownership of the CD burner to cdrw and makes <user> a member of that group. This gives <user> permission to burn CDs.

The book also mentions a gui tool, xcdroast, that apparently isn't installed by default in F7+ but was in F4. I'm going to be checking into the availability of that.

Jim

jim1944
2nd January 2009, 05:03 AM
The book also mentions a gui tool, xcdroast, that apparently isn't installed by default in F7+ but was in F4. I'm going to be checking into the availability of that.

Jim
Even though I use Xfce, gnome is installed and I can bring up nautilus from the command line and that allows buring CDs via gui. It spews out a bunch of warning messages that people who use gnome don't see but it works.

Jim

Seve
2nd January 2009, 05:31 AM
Hello:

Jim, which version of Fedora are you using ?

Seve

jim1944
2nd January 2009, 04:53 PM
Hello:

Jim, which version of Fedora are you using ?

Seve
F10.

My last fresh install was F7. I've upgraded since. This might explain why things are configured the way they are. A fresh install might configure things differently and install different packages by default. (If that's the point of your question.)

Jim