PDA

View Full Version : Gateway 400VTX Problems ) PLEASE HELP



lanboy
2nd May 2004, 06:25 PM
I've got a Gateway 400VTX laptop, and I've tried nearly everything to try to get a resolution of 1024x768 on this thing. Its currently stuck at 800x600 and 640x480. This laptop has an Intel 845 chipset. I've tried everything on the software side, tried reworking the XFree86 config file, among other things. I'm guessing its a bios vid memory issue. I will post my config file for diagnosis. Thanks for the help!

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.5
VertRefresh 40.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 845"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Bana
3rd May 2004, 02:09 AM
Try commenting out the HorizSync and VertRefresh rate lines? (thats what a problem was with FC2 Test3 so it might be worth trying here). Good luck though.

mrmcctt
31st October 2004, 06:31 PM
Try commenting out the HorizSync and VertRefresh rate lines? (thats what a problem was with FC2 Test3 so it might be worth trying here). Good luck though.

I have the same system and the same problem. What I need to know is how to "comment out" lines in the xorg.conf file.

Jman
1st November 2004, 03:39 AM
Comment out lines by putting a # in front, like the very first line. This is common in many config files.

mrmcctt
1st November 2004, 04:28 AM
My laptop (Gateway 400vtx) has a 15" display capable of 1024x768. As suggested above, I entered the xorg.conf file and commented out the HorizSync and VertRefresh rate lines, saved the file and logged out. when I restart (log in) my display is set at 640x480. I can set it back to 800x600 (millions of colors). I have removed them from the file below but it was interesting to note that the lines I commented out were placed right below the Section "Monitor" heading and two new active lines were added below.

I'm hoping that someone will see something in the file below that could be the cause of the problem.

Thanks
__________________________________________________ _____________________________________
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 37.9
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 852"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

JackCroww
8th April 2005, 02:59 PM
Any solution found to this yet?

AudioDef
28th May 2005, 06:49 PM
I have the same problem with my Gateway M305 and its Intel 852 integrated chip. I can't seem to get it over 800x600. I've tried the following:

Various configurations of xorg.conf
Driver from Intel
855resolution

Also, the same problem occurs with Fedora Core 3 and 4, Ubuntu Linux, Debian, ArkLinux, and Licoris. The only OS it works is Windoze - which I'd like to stop using. This laptop is a fairly recent model and it would be a waste of money to trade it in for a different model at this time.

I can find references to this problem all over the net, and it's hard to believe there isn't a fixed solution for this issue.

SirKha
1st July 2005, 08:15 PM
I am also having this problem, I have a 400VTX with an 852 chipset, and cannot get any better then 800x600. I am probably going to get a new laptop because of it, so it would be nice if I could fix this, so that I might save a thousand or so dollars :)

John Kha

iLLNESS
23rd July 2005, 07:01 AM
damn no ones figured it out yet?

ive got a m305 with a intel 852 gfx chip and no 1024 :(

MarkT
21st October 2005, 04:52 AM
I have the M305crv with the same problem. i've email gateway many times asking for a bios upgrade to fix this. I think I may start a "Don't buy a Gateway" campain.
I wish my company never bought this piece of crap.

Anyway , could anyone tell me what to use to find a valid modeline. I can not use any of the web generated ones because I do not have access to the LCD specs.

the stupid thing is , 1024x768 is listed in the BIOS.
X just does not see it as valid.

i tried the new intel_drv.o with the ForceBIOS "800x600=1024x768" option and got a different no valid screens error so i'm hoping its just the modeline now.

mattwa
3rd August 2007, 06:53 PM
Hi everyone..I have an easy solution to this problem..I think. I just got a 400VTX from a friend and i had to install a new hardrive. I couldnt get 1024 either SO I went to the gateway website and found display drivers for it and I downloaded them and installed then (there in a zip file) and ta da! 1024! I dont think it has anything to do with BIOS really...Sorry for being so late i just found this forum today and it looks like its been 2 years since the last post. lol. Hope im not too late in helping all you guys.

andrei4002
26th August 2007, 06:55 PM
@mattwa

could you be a little more specific of what exactly did you do to make the graphics card work on linux in 1024*768 resolution?

mattwa
27th August 2007, 02:15 AM
Oh...oops. I thought you guys meant windows XP not linux. I really dont know how to work any of linux so when you the person who made this thread didnt post the word "linux" but put stuff in that has to do with linux. My bad...sorry. Im dumb. :(
Matt

andrei4002
27th August 2007, 08:06 AM
well ... as you see this is a Fedora forum, not a Microsoft Windows one :p

i looked on other sites about this problem but still i can't find (actually nobody else could either) any solution.. the damn linux won't play 1024 on my 400vtx :mad:

http://ubuntuforums.org/showthread.php?t=233958

mattwa
27th August 2007, 08:04 PM
Well excuse me for living :P

losnggeneration
5th November 2008, 09:42 AM
I don't know if anyone else still has one of these laying around (m305CRV at least that also suffered from this problem.) Well, this has been fixed in the newer intel drivers. So change the i810 driver to intel and 1024x768 now works. (note you'll need a fairly new distro, F9 has the newer driver IIRC, but I don't it on that machine currently)