PDA

View Full Version : Need to manually install Nvidia Display Driver (FC7)



g8keepR
14th August 2007, 01:18 AM
I know I run sh NVIDIA-blah.sh. It compiles fine. I even load the module via insmod /usr/lib/modules/etc...

I verify that the driver is loaded (via lsmod | grep nvidia), but when I start X, it says that it failed to load glx and failed to load nvidia.

Is there some workaround for this? I remember back in FC3-4 days I had to manually copy the modules to some other folder for this to work. Do I need to do this again?

Do not ask why I need to do this... I just do :)

Thanks.

g8keepR
14th August 2007, 01:53 AM
ok nevermind. I managed to install 9639 fine. 9746 was giving me glx issues.

Maya (my source of frustration) now works with fc7. problem solved!

bseltzer
14th August 2007, 02:17 AM
The more or less standard path for X modules is /usr/lib/xorg/modules. Either your compiled NVIDIA driver was built to look somewhere else or your /etc/X11/xorg.conf has paths configured to look somewhere other than where the modules are.

So... Try to find out where libglx.so, etc. are actually located (again, /usr/lib/xorg/modules would be the place I'd start) and either reconfig /etc/X11/xorg.conf to look in the same place or, re-run the NVIDIA installed with the "--x-module-path" switch set to an appropriate path.

Regards,
Bert

Edit--- Ooops! Guess I type too slowly :rolleyes: Sounds like you've got an older card that the 97xx series driver doesn't support. Didn't even think of that. Anyway, glad you got it worked out.

g8keepR
14th August 2007, 03:26 AM
thanks for your reply. it had to do w/ the driver version. I have a 6800GT card. While the latest 100.x driver worked for general xwindows. Maya (the program I was trying to get working) did not like it.

It's also wierd that using livna's kmod-nvidia-96xx did not work and only this manually installed way. wierd...

bseltzer
14th August 2007, 05:04 AM
Hmmmm... Now I'm a bit confused. You said in your OP that


I verify that the driver is loaded (via lsmod | grep nvidia), but when I start X, it says that it failed to load glx and failed to load nvidia.

which doesn't sound like it "worked". Hence my assumption that there as a problem with the path to the modules.

The 97xx driver as well as the 100.14.xx should work with your card. Clearly from what you've told me, the 96xx driver works with your card as well. You also mention the kmod-nvidia drivers from livna, which leads me to ask if you've tried both, were you absolutely sure you completely removed one before trying the other. Mixing the NVIDIA software with firewing's stuff is known to be bad ju-ju.

So I'm still wondering if what you experienced is a Maya specific problem, which seems pretty unlikely, or is there something else going on here. Weird, indeed....

If you care to pursue this further to get to it's root, I'd be interested in whatever you discover.

Thanks,
Bert

g8keepR
14th August 2007, 12:37 PM
sure. after work I'll try it again. This driver isn't work 100% either as I'm discovering. I'm getting wierd artifacts behind my "busy mouse" animations when a program loads. Also in Maya, some of the windows get wigged out when I scroll.

Supposedly the 9746 drivers should work with Maya anyways, so I'll give that install another go along with the livna drivers tonight.

g8keepR
15th August 2007, 12:41 AM
Update ...

I'm using the latest livna drivers now, 100.14.11. Get this. In order for Maya to work , I have to run the nvidia x server settings program (nvidia-settings). Once I start this program, Maya will run. wtf? I don't get it.

Now I don't get those drawing errors and everything is working... again. :)

kRogue
15th August 2007, 05:30 AM
for what it is worth, when I was first using FC7, x-windows and openGL acted strangely when I first installed nvidia's drivers, but after running nvidia-settings it wrote the correct resolution magic to my xorg configuration file and afterwards everything was fine (the biggest issue was full screen GL apps)

g8keepR
15th August 2007, 01:33 PM
Interesting... I'll check the xorg.conf file to see if it changes.

FYI, this has to be done every time Xwindows is restarted (reboot or relogin).

g8keepR
16th August 2007, 12:44 AM
my xorg.conf does not change

chuong
3rd September 2007, 10:31 AM
g8keepR

we're on the same boat mate.

Either Nvidia display settings or just the monitor display settings (System > Administrator > Display ) runned once, will fix Maya.

I wish there was some bloody fix for this. I don't like having to load it just to fix the damn thing.